summaryrefslogtreecommitdiffstats
path: root/main/tinc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-18 11:02:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-18 11:03:35 +0000
commit1c7e42e7aaa8dd9d515d11b670cc3d3fb5028756 (patch)
tree75a2a0fce4e9bb8169cb3cb75924ec365b92183e /main/tinc
parent2a70f0e27ebde0004703c8416e4682e0b5cafeb3 (diff)
downloadaports-1c7e42e7aaa8dd9d515d11b670cc3d3fb5028756.tar.bz2
aports-1c7e42e7aaa8dd9d515d11b670cc3d3fb5028756.tar.xz
main/tinc: build fix for musl
Diffstat (limited to 'main/tinc')
-rw-r--r--main/tinc/APKBUILD12
-rw-r--r--main/tinc/musl.patch24
2 files changed, 34 insertions, 2 deletions
diff --git a/main/tinc/APKBUILD b/main/tinc/APKBUILD
index 196c6f513..efbd000c2 100644
--- a/main/tinc/APKBUILD
+++ b/main/tinc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tinc
pkgver=1.0.23
-pkgrel=1
+pkgrel=2
pkgdesc="tinc is a Virtual Private Network (VPN) daemon"
url="http://www.tinc-vpn.org/"
arch="all"
@@ -11,6 +11,7 @@ makedepends="zlib-dev lzo-dev openssl-dev"
install=""
subpackages="$pkgname-doc"
source="http://www.tinc-vpn.org/packages/tinc-$pkgver.tar.gz
+ musl.patch
tincd.initd
tincd.lo.initd
tinc.networks"
@@ -18,7 +19,11 @@ source="http://www.tinc-vpn.org/packages/tinc-$pkgver.tar.gz
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- # apply patches here
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -50,14 +55,17 @@ package() {
}
md5sums="762c0d47bdf1b33a40b19165d9c2761f tinc-1.0.23.tar.gz
+f2c913659191a0c81ed13dde305ca8bc musl.patch
411a260ed9bb1fc441444c3efbeafd7b tincd.initd
b95471eab010c0ed002cf3d16a009ced tincd.lo.initd
475d64d9aa410ec7e91f5b079800abc9 tinc.networks"
sha256sums="bcf06bdf16ff903821e33fc1ce6219d6429971aa5acd70f4e8a35b4332442812 tinc-1.0.23.tar.gz
+a394327605fa38e1b7bbbb49eda6461c96553d31370107e337482934ea8b042c musl.patch
0e8a18f9af03d967b30eac2c1de5d233449fae8a97342cdb88bf60e6b3867e73 tincd.initd
bd0909202c2f5b6fb0d97cac4f7f02a392393acd4b300a04db3a5416f4345035 tincd.lo.initd
7165721abd3706c95973118fbb503e18f9a008da6bdbf21a4ce35ecf7818d5ad tinc.networks"
sha512sums="86fae9fd87d6b129069327b2714260d90be145e817ba857773ed9bd108b1c515e70654bab2ff5c6b841d792cbaa4657ca7416b7540a9688f37e1697f279d0f00 tinc-1.0.23.tar.gz
+2a631b82e2d24139e8bf07057578d3f8e7f566829492cbbb82d030505ba00fe63943c57778156bca6985ab216e7b0d5ad8aeb25f7d7affa3189b7b3a005d0312 musl.patch
4a5da677d030dd24d347a86e7e892ea9aab57c2b4de8c9fa6ef576e239e4169f3ee6934162edc004a00678405f199606f05c173dd1ff94ee2f711536b1dfc072 tincd.initd
63df032f815b4a1e84c972e4cbfe115eda9fb80419b21d72811a947a8c9742f51442b5a06b0dbd220eb9a673b115fe62972019bdd4bac5855a36908c68bf5638 tincd.lo.initd
f7cb459c170898e51176bd92c642335386db90b7bca2abb3f6eb2514546efbd74e5fd2c8845060111dd48a0dd2cc1890717a03315c9b86185047c259cdc27135 tinc.networks"
diff --git a/main/tinc/musl.patch b/main/tinc/musl.patch
new file mode 100644
index 000000000..9b200a60d
--- /dev/null
+++ b/main/tinc/musl.patch
@@ -0,0 +1,24 @@
+diff --git a/src/have.h b/src/have.h
+index a96dd7d..9a4bd51 100644
+--- a/src/have.h
++++ b/src/have.h
+@@ -176,10 +176,6 @@
+ #include <netinet/ip6.h>
+ #endif
+
+-#ifdef HAVE_NET_ETHERNET_H
+-#include <net/ethernet.h>
+-#endif
+-
+ #ifdef HAVE_NET_IF_ARP_H
+ #include <net/if_arp.h>
+ #endif
+@@ -192,8 +188,4 @@
+ #include <netinet/icmp6.h>
+ #endif
+
+-#ifdef HAVE_NETINET_IF_ETHER_H
+-#include <netinet/if_ether.h>
+-#endif
+-
+ #endif /* __TINC_SYSTEM_H__ */