summaryrefslogtreecommitdiffstats
path: root/main/tvheadend
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-13 14:01:08 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-13 14:01:08 +0000
commit473492472809f977559378ca4c61ca572e6034e6 (patch)
tree028114626319c768dc6b417d064e9487ff301115 /main/tvheadend
parent97ba991ad14e989eb6a8c7499c39a54c1442b3fb (diff)
downloadaports-473492472809f977559378ca4c61ca572e6034e6.tar.bz2
aports-473492472809f977559378ca4c61ca572e6034e6.tar.xz
main/tvheadend: upgrade to 3.2.34
Diffstat (limited to 'main/tvheadend')
-rw-r--r--main/tvheadend/APKBUILD12
-rw-r--r--main/tvheadend/tvheadend.initd9
2 files changed, 15 insertions, 6 deletions
diff --git a/main/tvheadend/APKBUILD b/main/tvheadend/APKBUILD
index 9962498ba..98012ebec 100644
--- a/main/tvheadend/APKBUILD
+++ b/main/tvheadend/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=tvheadend
-pkgver=3.2.18
-pkgrel=2
+pkgver=3.2.34
+pkgrel=0
pkgdesc="TV Streaming server for linux"
url="http://www.lonelycoder.com/hts/tvheadend_overview.html"
arch="all"
@@ -14,11 +14,11 @@ pkgusers="$pkgname"
pkggroups="$pkgname"
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
-source="https://github.com/downloads/tvheadend/tvheadend/tvheadend-$pkgver.tar.gz
+source="https://github.com/tvheadend/tvheadend/archive/3.2patch2.tar.gz
tvheadend.initd
tvheadend.confd
"
-_builddir="$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir/$pkgname-3.2patch2"
prepare() {
local i
@@ -54,6 +54,6 @@ package() {
"$pkgdir/etc/$pkgname" || return 1
}
-md5sums="e1cf63cf2ae8b000e77eb313968f6b7b tvheadend-3.2.18.tar.gz
-8b7da39441150596bdeb2456f7cf73ed tvheadend.initd
+md5sums="501f7c4f3f9e4120f585b06821e27cd4 3.2patch2.tar.gz
+c68694d41e7ce0d94913e4332c060618 tvheadend.initd
17cf7dfaf27706409a004c246c1a2c3c tvheadend.confd"
diff --git a/main/tvheadend/tvheadend.initd b/main/tvheadend/tvheadend.initd
index 9b56313a8..b72df3378 100644
--- a/main/tvheadend/tvheadend.initd
+++ b/main/tvheadend/tvheadend.initd
@@ -6,6 +6,9 @@ depend() {
start() {
ebegin "Starting tvheadend"
+
+ checkconf || return 1
+
start-stop-daemon --start \
--exec ${TVHBIN} -- \
-C -f -u ${TVHUSER} \
@@ -21,3 +24,9 @@ stop() {
eend $?
}
+checkconf() {
+ if [ ! -d "$TVHCONF" ]; then
+ eerror "config directory does not exist!"
+ return 1
+ fi
+}