summaryrefslogtreecommitdiffstats
path: root/main/util-vserver
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-23 14:23:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-29 08:04:49 +0000
commitb31426a7cb6c867fb4eef8d31337ed66945c8d47 (patch)
tree026a5ac038ee941535c83a5a691ad9635b74bde5 /main/util-vserver
parent924600203af8728926fcd03d44e983d247cd438d (diff)
downloadaports-b31426a7cb6c867fb4eef8d31337ed66945c8d47.tar.bz2
aports-b31426a7cb6c867fb4eef8d31337ed66945c8d47.tar.xz
main/util-vserver: upgrade to 0.30.216_pre3025
and allow setup-vs-guest to use FQDN as vserver name
Diffstat (limited to 'main/util-vserver')
-rw-r--r--main/util-vserver/APKBUILD11
-rw-r--r--main/util-vserver/init-script.patch11
-rw-r--r--main/util-vserver/setup-vs-guest4
3 files changed, 7 insertions, 19 deletions
diff --git a/main/util-vserver/APKBUILD b/main/util-vserver/APKBUILD
index e1dbeec16..23ad026c6 100644
--- a/main/util-vserver/APKBUILD
+++ b/main/util-vserver/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-vserver
-pkgver=0.30.216_pre2994
+pkgver=0.30.216_pre3025
_realver=${pkgver%_*}-${pkgver#*_}
-pkgrel=1
+pkgrel=0
pkgdesc="Linux-VServer admin utilities"
url="http://www.nongnu.org/util-vserver/"
arch="all"
@@ -18,7 +18,6 @@ source="http://people.linux-vserver.org/~dhozac/t/uv-testing/util-vserver-$_real
validate.patch
alpine.patch
bb-grep.patch
- init-script.patch
setup-vs-template
setup-vs-guest
"
@@ -34,7 +33,8 @@ prepare() {
esac
done
msg "Running autotools..."
- libtoolize --force && aclocal -I m4 && autoconf && automake || return 1
+ libtoolize --force && aclocal -I m4 && autoconf && automake --gnu \
+ || return 1
# this is an ugly workaround
sed -i -e "s:as_echo=.*:as_echo=echo:g" configure
@@ -70,12 +70,11 @@ package() {
install -Dm755 ../setup-vs-guest "$pkgdir"/usr/sbin/setup-vs-guest
}
-md5sums="c2801f089982043bd0528349a1c61bb7 util-vserver-0.30.216-pre2994.tar.bz2
+md5sums="46592e4695c6011c828872b66a483fc0 util-vserver-0.30.216-pre3025.tar.bz2
73c7437dea6937a57cf38d166ef83c09 chmod.patch
ff8f561f672524eb46fe633f584ef60e ensc_pathprog.patch
da8b70c4fd40e68894b3903ffd121397 validate.patch
04000261fd990a3963b0e98260b481bd alpine.patch
3fc52e20d998f02995f21912738f5d36 bb-grep.patch
-6e574535409b3ab0361023f1a7f082eb init-script.patch
fae6626b724dec90a19924d68d355cd2 setup-vs-template
ef35e154d1a221631a53f9c2cfbe9834 setup-vs-guest"
diff --git a/main/util-vserver/init-script.patch b/main/util-vserver/init-script.patch
deleted file mode 100644
index 2bfd40a9a..000000000
--- a/main/util-vserver/init-script.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- util-vserver-0.30.216-pre2994.orig/gentoo/util-vserver
-+++ util-vserver-0.30.216-pre2994/gentoo/util-vserver
-@@ -58,7 +58,7 @@
- $__PKGLIBDIR/bash-wrapper 'hasCgroup'
- if [ $? -eq 0 ]; then
- ebegin "Mounting cgroup-hierarchy"
-- $__PKGLIBDIR/bash-wrapper '_generateCgroupOptions; test -n "$CGROUP_MNT" || exit 0; $_MKDIR -p "$CGROUP_MNT"; $_MOUNT -t cgroup -o "$CGROUP_SUBSYS" vserver "$CGROUP_MNT"'
-+ $__PKGLIBDIR/bash-wrapper '_generateCgroupOptions; test -n "$CGROUP_MNT" || exit 0; $_MKDIR -p "$CGROUP_MNT"; IFS=","; $_MOUNT -t cgroup -o "${CGROUP_SUBSYS[*]}" vserver "$CGROUP_MNT"'
- eend $?
- fi
- }
diff --git a/main/util-vserver/setup-vs-guest b/main/util-vserver/setup-vs-guest
index 8a4130669..985be9c3a 100644
--- a/main/util-vserver/setup-vs-guest
+++ b/main/util-vserver/setup-vs-guest
@@ -131,12 +131,12 @@ ask_until() {
# http://en.wikipedia.org/wiki/Hostname#Restrictions_on_valid_host_names
valid_hostname() {
# check length
- if [ $(echo "$1" | wc -c) -gt 63 ]; then
+ if [ $(echo "$1" | wc -c) -gt 255 ]; then
echo "Hostname '$1' is too long."
return 1
fi
# check that it only contains valid chars
- if ! [ -z "$(echo $1 | sed 's/[0-9a-z-]//g')" ]; then
+ if ! [ -z "$(echo $1 | sed 's/[0-9.a-z-]//g')" ]; then
echo "Hostname must only contain letters (a-z), digits (0-9) or -"
return 1
fi