summaryrefslogtreecommitdiffstats
path: root/main/varnish
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-05 00:42:33 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-05 00:42:33 +0100
commitcf47c99737fa0cbde0cd29d0ba1c97cbc75d52c5 (patch)
tree8260abd8ae7dee14b1cab648c24fe864db653e41 /main/varnish
parentbd18758a7695aa969e682665065086f5ecc3382c (diff)
downloadaports-cf47c99737fa0cbde0cd29d0ba1c97cbc75d52c5.tar.bz2
aports-cf47c99737fa0cbde0cd29d0ba1c97cbc75d52c5.tar.xz
main/varnish: fix build on eglibc
Diffstat (limited to 'main/varnish')
-rw-r--r--main/varnish/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/varnish/APKBUILD b/main/varnish/APKBUILD
index 6f61360d9..426caae96 100644
--- a/main/varnish/APKBUILD
+++ b/main/varnish/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="High-performance HTTP accelerator"
url="http://www.varnish-cache.org/"
arch="all"
license="BSD"
-depends="gcc uclibc-dev"
+depends="gcc"
depends_dev=
makedepends="$depends_dev pcre-dev ncurses-dev"
install=""
@@ -18,6 +18,12 @@ source="http://repo.varnish-cache.org/source/varnish-$pkgver.tar.gz
varnishd.logrotate
varnish-3.0.3-pthread-uclibc.patch"
+if [ "$ALPINE_LIBC" != "eglibc" ]; then
+ depends="$depends uclibc-dev"
+else
+ depends="$depends eglibc-dev"
+fi
+
_builddir="$srcdir"/varnish-$pkgver
prepare() {
local i