summaryrefslogtreecommitdiffstats
path: root/main/vlc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-01-21 09:23:23 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-01-21 09:24:11 +0000
commit7f0daebf8f73db51bd26a01aace179e07f59d188 (patch)
tree7c69b85f8be94203cc69e12a47a567ab396eb676 /main/vlc
parenta48995c297ca129b2beeac0533379e9f44c8a1f7 (diff)
downloadaports-7f0daebf8f73db51bd26a01aace179e07f59d188.tar.bz2
aports-7f0daebf8f73db51bd26a01aace179e07f59d188.tar.xz
main/vlc: cherrypick some omxil (rpi) patches
Diffstat (limited to 'main/vlc')
-rw-r--r--main/vlc/0001-omxil-Release-picture-in-direct-rendering-mode.patch32
-rw-r--r--main/vlc/0002-omxil-vout-Handle-dynamic-aspect-changes.patch81
-rw-r--r--main/vlc/0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch137
-rw-r--r--main/vlc/0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch56
-rw-r--r--main/vlc/0010-omxil-rpi-codecs.patch16
-rw-r--r--main/vlc/APKBUILD27
-rw-r--r--main/vlc/raspberrypi-mpeg4.patch10
7 files changed, 344 insertions, 15 deletions
diff --git a/main/vlc/0001-omxil-Release-picture-in-direct-rendering-mode.patch b/main/vlc/0001-omxil-Release-picture-in-direct-rendering-mode.patch
new file mode 100644
index 000000000..2ff3d82e2
--- /dev/null
+++ b/main/vlc/0001-omxil-Release-picture-in-direct-rendering-mode.patch
@@ -0,0 +1,32 @@
+From fe0d4afb9df270cadeea42675552029471646279 Mon Sep 17 00:00:00 2001
+From: Julian Scheel <julian@jusst.de>
+Date: Wed, 21 Aug 2013 10:53:41 +0200
+Subject: [PATCH] omxil: Release picture in direct rendering mode.
+
+In direct rendering mode a picture reference is acquired from the video output
+module. This reference has to be released when the internal omx buffer which
+uses this reference is freed. This avoids a blocking condition where the video
+output would wait for a picture to be freed forever.
+
+Signed-off-by: Julian Scheel <julian@jusst.de>
+Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
+---
+ modules/codec/omxil/omxil.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/modules/codec/omxil/omxil.c b/modules/codec/omxil/omxil.c
+index c49b7e5..71ee9b0 100644
+--- a/modules/codec/omxil/omxil.c
++++ b/modules/codec/omxil/omxil.c
+@@ -1047,6 +1047,8 @@ static OMX_ERRORTYPE PortReconfigure(decoder_t *p_dec, OmxPort *p_port)
+ for(i = 0; i < p_port->i_buffers; i++)
+ {
+ OMX_FIFO_GET(&p_port->fifo, p_buffer);
++ if (p_buffer->pAppPrivate != NULL)
++ decoder_DeletePicture( p_dec, p_buffer->pAppPrivate );
+ if (p_buffer->nFlags & SENTINEL_FLAG) {
+ free(p_buffer);
+ i--;
+--
+1.8.5.2
+
diff --git a/main/vlc/0002-omxil-vout-Handle-dynamic-aspect-changes.patch b/main/vlc/0002-omxil-vout-Handle-dynamic-aspect-changes.patch
new file mode 100644
index 000000000..d2dd8572f
--- /dev/null
+++ b/main/vlc/0002-omxil-vout-Handle-dynamic-aspect-changes.patch
@@ -0,0 +1,81 @@
+From 3b564f5f943a0687706ff5f1b6a70288eacfd909 Mon Sep 17 00:00:00 2001
+From: Julian Scheel <julian@jusst.de>
+Date: Thu, 5 Sep 2013 16:03:01 +0200
+Subject: [PATCH] omxil: vout: Handle dynamic aspect changes.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Handle changes of aspect ratio through the Control handler.
+
+Signed-off-by: Julian Scheel <julian@jusst.de>
+Signed-off-by: Martin Storsjö <martin@martin.st>
+---
+ modules/codec/omxil/vout.c | 33 +++++++++++++++++++++++++--------
+ 1 file changed, 25 insertions(+), 8 deletions(-)
+
+diff --git a/modules/codec/omxil/vout.c b/modules/codec/omxil/vout.c
+index 48aa744..d0864ae 100644
+--- a/modules/codec/omxil/vout.c
++++ b/modules/codec/omxil/vout.c
+@@ -126,6 +126,22 @@ static OMX_ERRORTYPE OmxFillBufferDone(OMX_HANDLETYPE omx_handle,
+ return OMX_ErrorNone;
+ }
+
++static void UpdateDisplaySize(vout_display_t *vd, vout_display_cfg_t *cfg)
++{
++ OMX_CONFIG_DISPLAYREGIONTYPE config_display;
++ OMX_INIT_STRUCTURE(config_display);
++
++ /* OMX_DISPLAY_SET_PIXEL is broadcom specific */
++ if (strcmp(vd->sys->psz_component, "OMX.broadcom.video_render"))
++ return;
++
++ config_display.nPortIndex = vd->sys->port.i_port_index;
++ config_display.set = OMX_DISPLAY_SET_PIXEL;
++ config_display.pixel_x = cfg->display.width * vd->fmt.i_height;
++ config_display.pixel_y = cfg->display.height * vd->fmt.i_width;
++ OMX_SetConfig(vd->sys->omx_handle, OMX_IndexConfigDisplayRegion, &config_display);
++}
++
+ static int Open(vlc_object_t *p_this)
+ {
+ vout_display_t *vd = (vout_display_t *)p_this;
+@@ -261,12 +277,7 @@ static int Open(vlc_object_t *p_this)
+ config_display.fullscreen = OMX_TRUE;
+ OMX_SetConfig(p_sys->omx_handle, OMX_IndexConfigDisplayRegion, &config_display);
+
+- if (vd->fmt.i_width != vd->cfg->display.width || vd->fmt.i_height != vd->cfg->display.height) {
+- config_display.set = OMX_DISPLAY_SET_PIXEL;
+- config_display.pixel_x = vd->cfg->display.width * vd->fmt.i_height;
+- config_display.pixel_y = vd->cfg->display.height * vd->fmt.i_width;
+- OMX_SetConfig(p_sys->omx_handle, OMX_IndexConfigDisplayRegion, &config_display);
+- }
++ UpdateDisplaySize(vd, vd->cfg);
+ }
+
+
+@@ -444,12 +455,18 @@ static int Control(vout_display_t *vd, int query, va_list args)
+ default:
+ msg_Err(vd, "Unknown request in omxil vout display");
+
++ case VOUT_DISPLAY_CHANGE_SOURCE_ASPECT:
++ return VLC_SUCCESS;
++ case VOUT_DISPLAY_CHANGE_DISPLAY_SIZE:
++ {
++ const vout_display_cfg_t *cfg = va_arg(args, const vout_display_cfg_t *);
++ UpdateDisplaySize(vd, cfg);
++ return VLC_SUCCESS;
++ }
+ case VOUT_DISPLAY_CHANGE_FULLSCREEN:
+ case VOUT_DISPLAY_CHANGE_WINDOW_STATE:
+- case VOUT_DISPLAY_CHANGE_DISPLAY_SIZE:
+ case VOUT_DISPLAY_CHANGE_DISPLAY_FILLED:
+ case VOUT_DISPLAY_CHANGE_ZOOM:
+- case VOUT_DISPLAY_CHANGE_SOURCE_ASPECT:
+ case VOUT_DISPLAY_CHANGE_SOURCE_CROP:
+ case VOUT_DISPLAY_GET_OPENGL:
+ return VLC_EGENERIC;
+--
+1.8.5.2
+
diff --git a/main/vlc/0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch b/main/vlc/0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch
new file mode 100644
index 000000000..02e19562f
--- /dev/null
+++ b/main/vlc/0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch
@@ -0,0 +1,137 @@
+From d32d532b62595b17dd88ea4e2e424cb11337118a Mon Sep 17 00:00:00 2001
+From: Julian Scheel <julian@jusst.de>
+Date: Thu, 5 Sep 2013 16:10:32 +0200
+Subject: [PATCH] omxil: rpi: Fetch pixel aspect ratio from decoder.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The broadcom omx implementation has a vendor extension to fetch pixel aspect
+information from the decoder. Use this to pass proper aspect information with
+the pictures.
+
+Signed-off-by: Julian Scheel <julian@jusst.de>
+Signed-off-by: Martin Storsjö <martin@martin.st>
+---
+ modules/codec/omxil/omxil.c | 63 +++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 63 insertions(+)
+
+diff --git a/modules/codec/omxil/omxil.c b/modules/codec/omxil/omxil.c
+index 59679f6..0fafedf 100644
+--- a/modules/codec/omxil/omxil.c
++++ b/modules/codec/omxil/omxil.c
+@@ -39,6 +39,7 @@
+
+ #include "omxil.h"
+ #include "omxil_core.h"
++#include "OMX_Broadcom.h"
+
+ #ifndef NDEBUG
+ # define OMXIL_EXTRA_DEBUG
+@@ -46,6 +47,13 @@
+
+ #define SENTINEL_FLAG 0x10000
+
++/* Defined in the broadcom version of OMX_Index.h */
++#define OMX_IndexConfigRequestCallback 0x7f000063
++#define OMX_IndexParamBrcmPixelAspectRatio 0x7f00004d
++
++/* Defined in the broadcom version of OMX_Core.h */
++#define OMX_EventParamOrConfigChanged 0x7F000001
++
+ /*****************************************************************************
+ * Local prototypes
+ *****************************************************************************/
+@@ -345,6 +353,34 @@ static OMX_ERRORTYPE SetPortDefinition(decoder_t *p_dec, OmxPort *p_port,
+ return omx_error;
+ }
+
++
++/*****************************************************************************
++ * UpdatePixelAspect: Update vlc pixel aspect based on the aspect reported on
++ * the omx port - NOTE: Broadcom specific
++ *****************************************************************************/
++static OMX_ERRORTYPE UpdatePixelAspect(decoder_t *p_dec)
++{
++ decoder_sys_t *p_sys = p_dec->p_sys;
++ OMX_CONFIG_POINTTYPE pixel_aspect;
++ OMX_INIT_STRUCTURE(pixel_aspect);
++ OMX_ERRORTYPE omx_err;
++
++ if (strncmp(p_sys->psz_component, "OMX.broadcom.", 13))
++ return OMX_ErrorNotImplemented;
++
++ pixel_aspect.nPortIndex = p_sys->out.i_port_index;
++ omx_err = OMX_GetParameter(p_sys->omx_handle,
++ OMX_IndexParamBrcmPixelAspectRatio, &pixel_aspect);
++ if (omx_err != OMX_ErrorNone) {
++ msg_Warn(p_dec, "Failed to retrieve aspect ratio");
++ } else {
++ p_dec->fmt_out.video.i_sar_num = pixel_aspect.nX;
++ p_dec->fmt_out.video.i_sar_den = pixel_aspect.nY;
++ }
++
++ return omx_err;
++}
++
+ /*****************************************************************************
+ * GetPortDefinition: set vlc format based on the definition of the omx port
+ *****************************************************************************/
+@@ -430,6 +466,7 @@ static OMX_ERRORTYPE GetPortDefinition(decoder_t *p_dec, OmxPort *p_port,
+ def->format.video.nStride = p_port->i_frame_stride;
+ #endif
+ p_port->i_frame_stride = def->format.video.nStride;
++ UpdatePixelAspect(p_dec);
+ break;
+
+ case AUDIO_ES:
+@@ -683,6 +720,23 @@ static OMX_ERRORTYPE InitialiseComponent(decoder_t *p_dec,
+ }
+ }
+
++ if(!strncmp(p_sys->psz_component, "OMX.broadcom.", 13))
++ {
++ OMX_CONFIG_REQUESTCALLBACKTYPE notifications;
++ OMX_INIT_STRUCTURE(notifications);
++
++ notifications.nPortIndex = p_sys->out.i_port_index;
++ notifications.nIndex = OMX_IndexParamBrcmPixelAspectRatio;
++ notifications.bEnable = OMX_TRUE;
++
++ omx_error = OMX_SetParameter(omx_handle,
++ OMX_IndexConfigRequestCallback, &notifications);
++ if (omx_error == OMX_ErrorNone)
++ msg_Dbg(p_dec, "Enabled aspect ratio notifications");
++ else
++ msg_Dbg(p_dec, "Could not enable aspect ratio notifications");
++ }
++
+ /* Set port definitions */
+ for(i = 0; i < p_sys->ports; i++)
+ {
+@@ -796,6 +850,12 @@ static int OpenGeneric( vlc_object_t *p_this, bool b_encode )
+ p_dec->fmt_out.video = p_dec->fmt_in.video;
+ p_dec->fmt_out.audio = p_dec->fmt_in.audio;
+ p_dec->fmt_out.i_codec = 0;
++
++ /* set default aspect of 1, if parser did not set it */
++ if (p_dec->fmt_out.video.i_sar_num == 0)
++ p_dec->fmt_out.video.i_sar_num = 1;
++ if (p_dec->fmt_out.video.i_sar_den == 0)
++ p_dec->fmt_out.video.i_sar_den = 1;
+ }
+ p_sys->b_enc = b_encode;
+ InitOmxEventQueue(&p_sys->event_queue);
+@@ -1615,6 +1675,9 @@ static OMX_ERRORTYPE OmxEventHandler( OMX_HANDLETYPE omx_handle,
+ msg_Dbg( p_dec, "Unhandled setting change %x", (unsigned int)data_2 );
+ }
+ break;
++ case OMX_EventParamOrConfigChanged:
++ UpdatePixelAspect(p_dec);
++ break;
+
+ default:
+ break;
+--
+1.8.5.2
+
diff --git a/main/vlc/0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch b/main/vlc/0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch
new file mode 100644
index 000000000..502f9671c
--- /dev/null
+++ b/main/vlc/0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch
@@ -0,0 +1,56 @@
+From 18cbe9639c57d5d3cc676909c64acd89997bcac3 Mon Sep 17 00:00:00 2001
+From: Julian Scheel <julian@jusst.de>
+Date: Thu, 12 Sep 2013 10:14:13 +0200
+Subject: [PATCH] omxil: bcm: h264: Don't wait for error free frame.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The bcm h264 decoder is not able to detect when the first error free frame has
+been decoded for certain h264 streams. To avoid not getting any frames out of
+the decoder, disable the StartWithValidFrame flag until that is fixed at bcm.
+See https://github.com/huceke/omxplayer/issues/96 for details.
+
+Signed-off-by: Julian Scheel <julian@jusst.de>
+Signed-off-by: Martin Storsjö <martin@martin.st>
+---
+ modules/codec/omxil/omxil.c | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/modules/codec/omxil/omxil.c b/modules/codec/omxil/omxil.c
+index 0fafedf..da86e23 100644
+--- a/modules/codec/omxil/omxil.c
++++ b/modules/codec/omxil/omxil.c
+@@ -50,6 +50,7 @@
+ /* Defined in the broadcom version of OMX_Index.h */
+ #define OMX_IndexConfigRequestCallback 0x7f000063
+ #define OMX_IndexParamBrcmPixelAspectRatio 0x7f00004d
++#define OMX_IndexParamBrcmVideoDecodeErrorConcealment 0x7f000080
+
+ /* Defined in the broadcom version of OMX_Core.h */
+ #define OMX_EventParamOrConfigChanged 0x7F000001
+@@ -745,6 +746,21 @@ static OMX_ERRORTYPE InitialiseComponent(decoder_t *p_dec,
+ if(omx_error != OMX_ErrorNone) goto error;
+ }
+
++ if(!strncmp(p_sys->psz_component, "OMX.broadcom.", 13) &&
++ p_sys->in.p_fmt->i_codec == VLC_CODEC_H264)
++ {
++ OMX_PARAM_BRCMVIDEODECODEERRORCONCEALMENTTYPE concanParam;
++ OMX_INIT_STRUCTURE(concanParam);
++ concanParam.bStartWithValidFrame = OMX_FALSE;
++
++ omx_error = OMX_SetParameter(omx_handle,
++ OMX_IndexParamBrcmVideoDecodeErrorConcealment, &concanParam);
++ if (omx_error == OMX_ErrorNone)
++ msg_Dbg(p_dec, "StartWithValidFrame disabled.");
++ else
++ msg_Dbg(p_dec, "Could not disable StartWithValidFrame.");
++ }
++
+ /* Allocate our array for the omx buffers and enable ports */
+ for(i = 0; i < p_sys->ports; i++)
+ {
+--
+1.8.5.2
+
diff --git a/main/vlc/0010-omxil-rpi-codecs.patch b/main/vlc/0010-omxil-rpi-codecs.patch
new file mode 100644
index 000000000..8fb8017e7
--- /dev/null
+++ b/main/vlc/0010-omxil-rpi-codecs.patch
@@ -0,0 +1,16 @@
+--- vlc-2.1.2.orig/modules/codec/omxil/omxil_core.c
++++ vlc-2.1.2/modules/codec/omxil/omxil_core.c
+@@ -202,6 +202,13 @@
+ {
+ #ifdef RPI_OMX
+ { "video_decoder.avc", "OMX.broadcom.video_decode" },
++ { "video_decoder.mpeg4", "OMX.broadcom.video_decode" },
++ { "video_decoder.mpeg2", "OMX.broadcom.video_decode" },
++ { "video_decoder.vp6", "OMX.broadcom.video_decode" },
++ { "video_decoder.vp8", "OMX.broadcom.video_decode" },
++ { "video_decoder.theora", "OMX.broadcom.video_decode" },
++ { "video_decoder.mjpg", "OMX.broadcom.video_decode" },
++ { "video_decoder.vc1", "OMX.broadcom.video_decode" },
+ { "iv_renderer", "OMX.broadcom.video_render" },
+ #endif
+ { 0, 0 }
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index ad7595919..2e84fdc5e 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -4,7 +4,7 @@ pkgname=vlc
pkgver=2.1.2
_pkgver=${pkgver/_/-}
_ver=${_pkgver%[a-z]}
-pkgrel=2
+pkgrel=3
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
pkgusers="vlc"
pkggroups="vlc"
@@ -75,12 +75,17 @@ makedepends="
xdg-utils
"
source="http://download.videolan.org/pub/videolan/$pkgname/${_ver}/$pkgname-$_pkgver.tar.xz
- raspberrypi-mpeg4.patch
fix-waitpid-usage.patch
uclibc-define-fminf.patch
dbus-fmaxf.patch
uclibc-fix-idn.patch
+ 0001-omxil-Release-picture-in-direct-rendering-mode.patch
+ 0002-omxil-vout-Handle-dynamic-aspect-changes.patch
+ 0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch
+ 0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch
+ 0010-omxil-rpi-codecs.patch
+
vlc.trigger"
_builddir="$srcdir"/$pkgname-$_ver
@@ -241,23 +246,35 @@ daemon() {
}
md5sums="fb6787ad749aadcfaeab3471939b3426 vlc-2.1.2.tar.xz
-8de1e959ef80806cf9f0c3918d8ba9b3 raspberrypi-mpeg4.patch
7b1a482e521b9d6dcdb6710aff51894f fix-waitpid-usage.patch
34bacc70c150bdbe19476d84a76f2849 uclibc-define-fminf.patch
0f373eaee7e74def94d0dab2be9d0c01 dbus-fmaxf.patch
a57ecdeb28b93c2ac0ade2adff2da2b4 uclibc-fix-idn.patch
+76ab721e5d303158201293c4ae5b5ba9 0001-omxil-Release-picture-in-direct-rendering-mode.patch
+3d39249940b63e20ac6c84c68ee67677 0002-omxil-vout-Handle-dynamic-aspect-changes.patch
+4209dd3c03001a921ece0f8647ecb1c5 0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch
+616a2e6dc58810732146ea922819aea2 0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch
+d43b448ee0ba6980ecfc5fdfa655f473 0010-omxil-rpi-codecs.patch
350b30698eb784def7d19446eb1d6c81 vlc.trigger"
sha256sums="219b812be1bc2eba40faa86419d0aa2c479a7380af8af216e8bfa22eb6fc8ec4 vlc-2.1.2.tar.xz
-cde16969d902df62756aa412841a894451fb22333d9cd365cca8cfd2aded7a80 raspberrypi-mpeg4.patch
0c802698c215dd2d2ad9a4889b1d46dfd5d6c304d4cd1b34bacb2bacc35dd3c9 fix-waitpid-usage.patch
b16801cca70c0f13830a27146025cc55b947897744d9da1ab713c5f5ce0460a0 uclibc-define-fminf.patch
3ebb0577b1ef9780eba27cd829c9839b2ddf7729c5a2a81019d08b2c0a7e5b79 dbus-fmaxf.patch
8e15a1c29fed29eeafef4dd37c73cc0da578b40d9d94713ac12a69c101040901 uclibc-fix-idn.patch
+3ff97e9c1b4055ac9a0981fa90b6f55abe72e44d5606a963f9b66f6274672822 0001-omxil-Release-picture-in-direct-rendering-mode.patch
+f9e5d27aa46cc4ebb929afaa30f53343eb40347915ec827cf461a42745fa525a 0002-omxil-vout-Handle-dynamic-aspect-changes.patch
+7709d3fa0090e4aa8fb21eff55320fa11b681e6b7a8faab24b4473645cda3112 0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch
+fe0b937e0b0a05b7d2cccd27dab49df77e84928e49fb148bae3d0effeb261d2f 0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch
+11db39f206ddb968d6a4411c75bfa6102189cb8e784316c491dd964ee9a3dfaf 0010-omxil-rpi-codecs.patch
0639c022dc844fad95eb0246b1d24557641939bbda91af0c700374378d8f054a vlc.trigger"
sha512sums="24ea51befb30ec2e4f796866bf086d36e809cb97bf04203a4637518c91a3035fa38a8e778aaf6fb3481db49d19236ae88bcbf31e1e4f7ae79b9d7bcc3cf037af vlc-2.1.2.tar.xz
-1f988588f7d7699e36d371e2ed2df918d476697737fab8c29a5833858e428651200939339a6f31fe6b608cc4387f53dbc6b2581bc453746c1d178c2af943ec60 raspberrypi-mpeg4.patch
3c6ff4f25b7e1f0041bc47872a2b59b6c4f8bc1747d6830e9f2d9c35ee75cd2581558a12225070dede37d6a2287b0fc5c089c8f4f8ae26784aa6aded7177bed0 fix-waitpid-usage.patch
0d9310afef1afbf15a19bcc8aa1835416830666d79a5461b45df900afde5b115ec7c18d4bc15d36efe45b912ebb51ceb91cc20ebd0be0ecc4ff3fd0e06dd4a55 uclibc-define-fminf.patch
b51041adcb16234289c928444a8c03db549640af28cc8dc75f732863bea519141dc36a44f353d2e42d8afde1fd8052faff0b2b661bf04a10c64f1f18f120e87b dbus-fmaxf.patch
24d7ae347a81e05aa2273c180ed76dfb0c8140ef1e4f877a88326fdf37acec0ac8bf1bde98845e40cd57c93fe6e5c186623a6f6f66ed6fe94386826260d88738 uclibc-fix-idn.patch
+0dc1c827af73f29fe715e3d75812ca916d0feac355d7c5f7ac1696bfbf3aca31dabbdd0ec05174a1c15713c530748f9dcb1b4b87819f3a6570c86c71ac503954 0001-omxil-Release-picture-in-direct-rendering-mode.patch
+c276962f33c38ad64caa6c4f8ca673c4367635b8998ee8a1003047f89e652c535027c68a836822d9b762d1b76ad04bd04dc0d19bbfabc5c3b7d14a7ee1cdd744 0002-omxil-vout-Handle-dynamic-aspect-changes.patch
+db15b7488768b429f26e4e7fdf82259ffc834fa2bdf1461b297b36111aad87603f7b015b0855afb8bc797fb351311dee555bbef0dc0a5d029748b057a3c23f92 0003-omxil-rpi-Fetch-pixel-aspect-ratio-from-decoder.patch
+a9bd6f622a9868de3e0a9f6643b906a73cabcfbc79ffebafbac00a45e3eec31cbb7bc9c9ec2748c58c928e95f45b29878ac78f654e5e658413687b60aaf52683 0004-omxil-bcm-h264-Don-t-wait-for-error-free-frame.patch
+6fb242c37bd9af224b7bcd78702ac1b5612748c7363405e594c509288940a18ae4334f032497e9d6e11f83e870b9437a5c3197db0271123c95de24db63b8802e 0010-omxil-rpi-codecs.patch
a081dd93248b63724ffb65cde0a00db0e1f3b9a1d47074800d898e39dc71c074b3dd3fa18e5fbc45fa90376e7df6d7ef8689c4253c1d9405868a3f8bbd76adcc vlc.trigger"
diff --git a/main/vlc/raspberrypi-mpeg4.patch b/main/vlc/raspberrypi-mpeg4.patch
deleted file mode 100644
index cbeea441b..000000000
--- a/main/vlc/raspberrypi-mpeg4.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- vlc-2.1.2.orig/modules/codec/omxil/omxil_core.c
-+++ vlc-2.1.2/modules/codec/omxil/omxil_core.c
-@@ -202,6 +202,7 @@
- {
- #ifdef RPI_OMX
- { "video_decoder.avc", "OMX.broadcom.video_decode" },
-+ { "video_decoder.mpeg4", "OMX.broadcom.video_decode" },
- { "iv_renderer", "OMX.broadcom.video_render" },
- #endif
- { 0, 0 }