summaryrefslogtreecommitdiffstats
path: root/main/vte3
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-11 17:29:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-11 17:29:53 +0000
commitf56236485b185bb2b2efb442caa57bd6ad3d3287 (patch)
tree74c064bfae571438e8caec05d303e862c7a736dc /main/vte3
parent9e1d6757aff41b936a599f81765eb833252feec0 (diff)
downloadaports-f56236485b185bb2b2efb442caa57bd6ad3d3287.tar.bz2
aports-f56236485b185bb2b2efb442caa57bd6ad3d3287.tar.xz
main/vte3: moved from testing
Diffstat (limited to 'main/vte3')
-rw-r--r--main/vte3/APKBUILD50
-rw-r--r--main/vte3/allow_alt_in_terminal.patch11
2 files changed, 61 insertions, 0 deletions
diff --git a/main/vte3/APKBUILD b/main/vte3/APKBUILD
new file mode 100644
index 000000000..4520132a3
--- /dev/null
+++ b/main/vte3/APKBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=vte3
+pkgver=0.34.7
+pkgrel=2
+pkgdesc="Virtual Terminal Emulator library"
+url="https://developer.gnome.org/vte/"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends=
+depends_dev="glib-dev pango-dev gtk+3.0-dev"
+makedepends="$depends_dev intltool python ncurses-dev gobject-introspection-dev"
+source="http://ftp.gnome.org/pub/GNOME/sources/vte/${pkgver%.*}/vte-$pkgver.tar.xz
+ allow_alt_in_terminal.patch"
+
+_builddir="$srcdir"/vte-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/$pkgname \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-introspection \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ ln -sf /usr/share/vte/termcap-0.0 "$pkgdir"/usr/share/vte/termcap
+ find "$pkgdir" -name '*.la' -delete
+}
+md5sums="aaab625a8d3ffe1f9a95fc9cd132040e vte-0.34.7.tar.xz
+6ae30139b7d7ca78b56a3b55426c83f2 allow_alt_in_terminal.patch"
+sha256sums="187e49cca574f548d04ceea701e95a1531ff9dd9cd1953ce6455824720dab932 vte-0.34.7.tar.xz
+6e4488f9a60f52a2a7eeb09865bdc42f00c309eb4cf8d548b524b9c33fadcd8a allow_alt_in_terminal.patch"
+sha512sums="a122814f7fee4202c0bc4862798c98b078e5b185eb8c3c11959001b33bd5e029579f7337f85bdffb3f8a7b22af3a6763a2353ecff16a8e5c8b941431adabc5e0 vte-0.34.7.tar.xz
+a4786a97a5caa42db3b29808c3542777684fcf7d931a116d4e3d847e859a64fb59a2d5b60927dc8e5c2733efc55c29aa4d30aeb02597aff5f034c172cc528833 allow_alt_in_terminal.patch"
diff --git a/main/vte3/allow_alt_in_terminal.patch b/main/vte3/allow_alt_in_terminal.patch
new file mode 100644
index 000000000..d8437173c
--- /dev/null
+++ b/main/vte3/allow_alt_in_terminal.patch
@@ -0,0 +1,11 @@
+--- vte-0.28.2/src/keymap.h.orig
++++ vte-0.28.2/src/keymap.h
+@@ -27,7 +27,7 @@
+
+ G_BEGIN_DECLS
+
+-#define VTE_META_MASK GDK_META_MASK
++#define VTE_META_MASK GDK_MOD1_MASK
+ #define VTE_NUMLOCK_MASK GDK_MOD2_MASK
+
+ /* Map the specified keyval/modifier setup, dependent on the mode, to either