summaryrefslogtreecommitdiffstats
path: root/main/wine
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-16 12:57:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-16 12:57:23 +0000
commit00d8a7996324d05f7c3bda266691f68c4cfd587f (patch)
tree1fb774c504038075d923bc456c755f7b22978d53 /main/wine
parent92f0c4a8fb6a46befb00de60325acfd5efffd771 (diff)
downloadaports-00d8a7996324d05f7c3bda266691f68c4cfd587f.tar.bz2
aports-00d8a7996324d05f7c3bda266691f68c4cfd587f.tar.xz
main/wine: build fixes for bison-3
Diffstat (limited to 'main/wine')
-rw-r--r--main/wine/APKBUILD30
-rw-r--r--main/wine/jscript-use-bison-directives-instead-of-defines.patch49
-rw-r--r--main/wine/msi-use-bison-directives-insetad-of-defines.patch134
-rw-r--r--main/wine/vbscript-Use-bison-directives-instead-of-defines.patch49
-rw-r--r--main/wine/wbemprox-Use-bison-directives-instead-of-defines.patch57
-rw-r--r--main/wine/wrc-Remove-non-bison-compatibility-code.patch57
6 files changed, 371 insertions, 5 deletions
diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
index 665fcd9cc..d456ef328 100644
--- a/main/wine/APKBUILD
+++ b/main/wine/APKBUILD
@@ -2,7 +2,7 @@
pkgname=wine
pkgver=1.6
_ver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
arch="x86"
@@ -17,6 +17,11 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
tiff-dev v4l-utils-dev udisks2-dev
autoconf automake"
source="http://downloads.sourceforge.net/project/wine/Source/wine-$_ver.tar.bz2
+ jscript-use-bison-directives-instead-of-defines.patch
+ msi-use-bison-directives-insetad-of-defines.patch
+ vbscript-Use-bison-directives-instead-of-defines.patch
+ wbemprox-Use-bison-directives-instead-of-defines.patch
+ wrc-Remove-non-bison-compatibility-code.patch
"
_builddir="$srcdir"/$pkgname-$_ver
@@ -42,7 +47,7 @@ build() {
--with-dbus \
--with-x \
|| return 1
- make
+ make
}
package() {
@@ -53,6 +58,21 @@ package() {
"$pkgdir"/usr/bin/wine
}
-md5sums="47cf1e121d395e9c8ca1a4ab88f1e658 wine-1.6.tar.bz2"
-sha256sums="e1f130efbdcbfa211ca56ee03357ccd17a31443889b4feebdcb88248520b42ae wine-1.6.tar.bz2"
-sha512sums="f8a98d732547c685e20ec3b7c50b44943307396b93097ef53b01ab1919209a159b81bd1560d8b2f242cec7f7303e446a8632ddd238359fc1861acc555105c92a wine-1.6.tar.bz2"
+md5sums="47cf1e121d395e9c8ca1a4ab88f1e658 wine-1.6.tar.bz2
+38bea0015354da182dfa7f7ff870cbbb jscript-use-bison-directives-instead-of-defines.patch
+7fd584ab875b0834ee457eeb351b1190 msi-use-bison-directives-insetad-of-defines.patch
+40fc099154043424223bcf5836a64aa0 vbscript-Use-bison-directives-instead-of-defines.patch
+cd1fd88a4f58db703828eb5ec0e5c45f wbemprox-Use-bison-directives-instead-of-defines.patch
+c889b79461ee7a7480f8cc89682cee76 wrc-Remove-non-bison-compatibility-code.patch"
+sha256sums="e1f130efbdcbfa211ca56ee03357ccd17a31443889b4feebdcb88248520b42ae wine-1.6.tar.bz2
+80d16a130e9e84a0eb7853f36bb05dfaf420ec78e1f8df563d7ed4694a10df7a jscript-use-bison-directives-instead-of-defines.patch
+b84ca975dba80f0cb90321177f2bcbac35f86d244fa15e7ae3de921ddb10803c msi-use-bison-directives-insetad-of-defines.patch
+e8e20f6ca8702dbe76fbe12751685d1ae28157fb430fe3280098201aaa96769c vbscript-Use-bison-directives-instead-of-defines.patch
+3da101c81ae94d14dbcda8d0af32ab4dcdda85a020c01640a75581a011d9f4dc wbemprox-Use-bison-directives-instead-of-defines.patch
+5348fde97aa89825a872805d84062dc623782a7b7d8321f6b3ddb4ff2dd11f8f wrc-Remove-non-bison-compatibility-code.patch"
+sha512sums="f8a98d732547c685e20ec3b7c50b44943307396b93097ef53b01ab1919209a159b81bd1560d8b2f242cec7f7303e446a8632ddd238359fc1861acc555105c92a wine-1.6.tar.bz2
+5ef7ec422aa13ea9b26937eed8ee63ed12452d2c7dbc8ae9ec3f336dbf3e5be72845d19dcaeac5598303c09833896accd200bb0cca48dadef9e4a748ce5ef60d jscript-use-bison-directives-instead-of-defines.patch
+23863f79c90614430a0ba880daaad76c95d7d0bbe2d192a02b0121012f39f68d46cfb86fb01990ca19c358807f16e383d891ca295057774901277ba3f5236392 msi-use-bison-directives-insetad-of-defines.patch
+90ed0ec93372d3c45bacce3e90c825205eeb31645848a48875f71ff066e59b53f1a97f575615e66d1f2fff82703c60e016969d5b2fa66bc7f23688b67d2cf3e7 vbscript-Use-bison-directives-instead-of-defines.patch
+5631449ede0f8f93f9a02c52bcf8e583c6ca2216113c911b6f6ed145b22eab09b9756df4dbb68a449ecbc4e7ac88d87311789f1dddf495a771c96345bf032c18 wbemprox-Use-bison-directives-instead-of-defines.patch
+b34670680b5f0bef33e49ae411b2728e18d84a35fbb73f853b1692e88585b28d30c0f49f9bc53fbd9e440fc9b178e9b52e51434d4c13b977815dc982a3c72cec wrc-Remove-non-bison-compatibility-code.patch"
diff --git a/main/wine/jscript-use-bison-directives-instead-of-defines.patch b/main/wine/jscript-use-bison-directives-instead-of-defines.patch
new file mode 100644
index 000000000..0a0cb9aa9
--- /dev/null
+++ b/main/wine/jscript-use-bison-directives-instead-of-defines.patch
@@ -0,0 +1,49 @@
+From ffbe1ca986bd299e1fc894440849914378adbf5c Mon Sep 17 00:00:00 2001
+From: Alexandre Julliard <julliard@winehq.org>
+Date: Thu, 1 Aug 2013 11:59:12 +0200
+Subject: [PATCH] jscript: Use bison directives instead of defines to specify
+ extra lexer parameters.
+
+---
+ dlls/jscript/parser.y | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/dlls/jscript/parser.y b/dlls/jscript/parser.y
+index f5a2e72..327366a 100644
+--- a/dlls/jscript/parser.y
++++ b/dlls/jscript/parser.y
+@@ -25,10 +25,7 @@
+
+ WINE_DEFAULT_DEBUG_CHANNEL(jscript);
+
+-#define YYLEX_PARAM ctx
+-#define YYPARSE_PARAM ctx
+-
+-static int parser_error(const char*);
++static int parser_error(parser_ctx_t*,const char*);
+ static void set_error(parser_ctx_t*,UINT);
+ static BOOL explicit_error(parser_ctx_t*,void*,WCHAR);
+ static BOOL allow_auto_semicolon(parser_ctx_t*);
+@@ -139,7 +136,9 @@ static source_elements_t *source_elements_add_statement(source_elements_t*,state
+
+ %}
+
+-%pure_parser
++%lex-param { parser_ctx_t *ctx }
++%parse-param { parser_ctx_t *ctx }
++%pure-parser
+ %start Program
+
+ %union {
+@@ -1386,7 +1385,7 @@ static expression_t *new_call_expression(parser_ctx_t *ctx, expression_t *expres
+ return &ret->expr;
+ }
+
+-static int parser_error(const char *str)
++static int parser_error(parser_ctx_t *ctx, const char *str)
+ {
+ return 0;
+ }
+--
+1.8.1.6
+
diff --git a/main/wine/msi-use-bison-directives-insetad-of-defines.patch b/main/wine/msi-use-bison-directives-insetad-of-defines.patch
new file mode 100644
index 000000000..5df225e7c
--- /dev/null
+++ b/main/wine/msi-use-bison-directives-insetad-of-defines.patch
@@ -0,0 +1,134 @@
+From 3f98185fb8f88c181877e909ab1b6422fb9bca1e Mon Sep 17 00:00:00 2001
+From: Alexandre Julliard <julliard@winehq.org>
+Date: Thu, 1 Aug 2013 12:00:04 +0200
+Subject: [PATCH] msi: Use bison directives instead of defines to specify extra
+ lexer parameters.
+
+---
+ dlls/msi/cond.y | 10 ++++------
+ dlls/msi/query.h | 13 +++++++++++++
+ dlls/msi/sql.y | 23 ++++-------------------
+ 3 files changed, 21 insertions(+), 25 deletions(-)
+
+diff --git a/dlls/msi/cond.y b/dlls/msi/cond.y
+index 97bb002..fa55825 100644
+--- a/dlls/msi/cond.y
++++ b/dlls/msi/cond.y
+@@ -42,11 +42,6 @@
+ #include "wine/unicode.h"
+ #include "wine/list.h"
+
+-#define YYLEX_PARAM info
+-#define YYPARSE_PARAM info
+-
+-static int cond_error(const char *str);
+-
+ WINE_DEFAULT_DEBUG_CHANNEL(msi);
+
+ typedef struct tag_yyinput
+@@ -66,6 +61,7 @@ struct cond_str {
+ static LPWSTR COND_GetString( COND_input *info, const struct cond_str *str );
+ static LPWSTR COND_GetLiteral( COND_input *info, const struct cond_str *str );
+ static int cond_lex( void *COND_lval, COND_input *info);
++static int cond_error( COND_input *info, const char *str);
+
+ static void *cond_alloc( COND_input *cond, unsigned int sz );
+ static void *cond_track_mem( COND_input *cond, void *ptr, unsigned int sz );
+@@ -110,6 +106,8 @@ static BOOL num_from_prop( LPCWSTR p, INT *val )
+
+ %}
+
++%lex-param { COND_input *info }
++%parse-param { COND_input *info }
+ %pure-parser
+
+ %union
+@@ -798,7 +796,7 @@ static void cond_free( void *ptr )
+ }
+ }
+
+-static int cond_error(const char *str)
++static int cond_error( COND_input *info, const char *str )
+ {
+ TRACE("%s\n", str );
+ return 0;
+diff --git a/dlls/msi/query.h b/dlls/msi/query.h
+index ca34b4c..063fbb9 100644
+--- a/dlls/msi/query.h
++++ b/dlls/msi/query.h
+@@ -96,6 +96,19 @@ struct expr
+ } u;
+ };
+
++typedef struct
++{
++ MSIDATABASE *db;
++ LPCWSTR command;
++ DWORD n, len;
++ UINT r;
++ MSIVIEW **view; /* View structure for the resulting query. This value
++ * tracks the view currently being created so we can free
++ * this view on syntax error.
++ */
++ struct list *mem;
++} SQL_input;
++
+ UINT MSI_ParseSQL( MSIDATABASE *db, LPCWSTR command, MSIVIEW **phview,
+ struct list *mem ) DECLSPEC_HIDDEN;
+
+diff --git a/dlls/msi/sql.y b/dlls/msi/sql.y
+index ead7743..fa54741 100644
+--- a/dlls/msi/sql.y
++++ b/dlls/msi/sql.y
+@@ -34,29 +34,12 @@
+ #include "wine/debug.h"
+ #include "wine/unicode.h"
+
+-#define YYLEX_PARAM info
+-#define YYPARSE_PARAM info
+-
+-static int sql_error(const char *str);
+-
+ WINE_DEFAULT_DEBUG_CHANNEL(msi);
+
+-typedef struct tag_SQL_input
+-{
+- MSIDATABASE *db;
+- LPCWSTR command;
+- DWORD n, len;
+- UINT r;
+- MSIVIEW **view; /* View structure for the resulting query. This value
+- * tracks the view currently being created so we can free
+- * this view on syntax error.
+- */
+- struct list *mem;
+-} SQL_input;
+-
+ static UINT SQL_getstring( void *info, const struct sql_str *strdata, LPWSTR *str );
+ static INT SQL_getint( void *info );
+ static int sql_lex( void *SQL_lval, SQL_input *info );
++static int sql_error( SQL_input *info, const char *str);
+
+ static LPWSTR parser_add_table( void *info, LPCWSTR list, LPCWSTR table );
+ static void *parser_alloc( void *info, unsigned int sz );
+@@ -77,6 +60,8 @@ static struct expr * EXPR_wildcard( void *info );
+
+ %}
+
++%lex-param { SQL_input *info }
++%parse-param { SQL_input *info }
+ %pure-parser
+
+ %union
+@@ -866,7 +851,7 @@ INT SQL_getint( void *info )
+ return r;
+ }
+
+-static int sql_error( const char *str )
++static int sql_error( SQL_input *info, const char *str )
+ {
+ return 0;
+ }
+--
+1.8.1.6
+
diff --git a/main/wine/vbscript-Use-bison-directives-instead-of-defines.patch b/main/wine/vbscript-Use-bison-directives-instead-of-defines.patch
new file mode 100644
index 000000000..a11c46029
--- /dev/null
+++ b/main/wine/vbscript-Use-bison-directives-instead-of-defines.patch
@@ -0,0 +1,49 @@
+From f86c46f6403fe338a544ab134bdf563c5b0934ae Mon Sep 17 00:00:00 2001
+From: Alexandre Julliard <julliard@winehq.org>
+Date: Thu, 1 Aug 2013 12:00:23 +0200
+Subject: [PATCH] vbscript: Use bison directives instead of defines to specify
+ extra lexer parameters.
+
+---
+ dlls/vbscript/parser.y | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/dlls/vbscript/parser.y b/dlls/vbscript/parser.y
+index 4b380ef..3c54fd8 100644
+--- a/dlls/vbscript/parser.y
++++ b/dlls/vbscript/parser.y
+@@ -25,10 +25,7 @@
+
+ WINE_DEFAULT_DEBUG_CHANNEL(vbscript);
+
+-#define YYLEX_PARAM ctx
+-#define YYPARSE_PARAM ctx
+-
+-static int parser_error(const char*);
++static int parser_error(parser_ctx_t *,const char*);
+
+ static void parse_complete(parser_ctx_t*,BOOL);
+
+@@ -82,7 +79,9 @@ static const WCHAR propertyW[] = {'p','r','o','p','e','r','t','y',0};
+
+ %}
+
+-%pure_parser
++%lex-param { parser_ctx_t *ctx }
++%parse-param { parser_ctx_t *ctx }
++%pure-parser
+ %start Program
+
+ %union {
+@@ -426,7 +425,7 @@ Identifier
+ | tPROPERTY { $$ = propertyW; }
+ %%
+
+-static int parser_error(const char *str)
++static int parser_error(parser_ctx_t *ctx, const char *str)
+ {
+ return 0;
+ }
+--
+1.8.1.6
+
diff --git a/main/wine/wbemprox-Use-bison-directives-instead-of-defines.patch b/main/wine/wbemprox-Use-bison-directives-instead-of-defines.patch
new file mode 100644
index 000000000..2ad146c0c
--- /dev/null
+++ b/main/wine/wbemprox-Use-bison-directives-instead-of-defines.patch
@@ -0,0 +1,57 @@
+From c14e322a92a24e704836c5c12207c694a30e805f Mon Sep 17 00:00:00 2001
+From: Alexandre Julliard <julliard@winehq.org>
+Date: Thu, 1 Aug 2013 12:00:44 +0200
+Subject: [PATCH] wbemprox: Use bison directives instead of defines to specify
+ extra lexer parameters.
+
+---
+ dlls/wbemprox/wql.y | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/dlls/wbemprox/wql.y b/dlls/wbemprox/wql.y
+index 8e347c2..58663d0 100644
+--- a/dlls/wbemprox/wql.y
++++ b/dlls/wbemprox/wql.y
+@@ -30,11 +30,6 @@
+ #include "wine/debug.h"
+ #include "wine/unicode.h"
+
+-#define YYLEX_PARAM ctx
+-#define YYPARSE_PARAM ctx
+-#define YYERROR_DEBUG 1
+-#define YYERROR_VERBOSE 1
+-
+ WINE_DEFAULT_DEBUG_CHANNEL(wbemprox);
+
+ struct parser
+@@ -181,7 +176,7 @@ static struct expr *expr_propval( struct parser *parser, const struct property *
+ return e;
+ }
+
+-static int wql_error( const char *str );
++static int wql_error( struct parser *parser, const char *str );
+ static int wql_lex( void *val, struct parser *parser );
+
+ #define PARSER_BUBBLE_UP_VIEW( parser, result, current_view ) \
+@@ -190,6 +185,9 @@ static int wql_lex( void *val, struct parser *parser );
+
+ %}
+
++%lex-param { struct parser *ctx }
++%parse-param { struct parser *ctx }
++%error-verbose
+ %pure-parser
+
+ %union
+@@ -691,7 +689,7 @@ static int wql_lex( void *p, struct parser *parser )
+ return token;
+ }
+
+-static int wql_error( const char *str )
++static int wql_error( struct parser *parser, const char *str )
+ {
+ ERR("%s\n", str);
+ return 0;
+--
+1.8.1.6
+
diff --git a/main/wine/wrc-Remove-non-bison-compatibility-code.patch b/main/wine/wrc-Remove-non-bison-compatibility-code.patch
new file mode 100644
index 000000000..ccb754b1a
--- /dev/null
+++ b/main/wine/wrc-Remove-non-bison-compatibility-code.patch
@@ -0,0 +1,57 @@
+From 8fcac3b2bb8ce4cdbcffc126df779bf1be168882 Mon Sep 17 00:00:00 2001
+From: Alexandre Julliard <julliard@winehq.org>
+Date: Thu, 1 Aug 2013 12:04:29 +0200
+Subject: [PATCH] wrc: Remove non-bison compatibility code.
+
+---
+ tools/wrc/parser.y | 27 +--------------------------
+ 1 file changed, 1 insertion(+), 26 deletions(-)
+
+diff --git a/tools/wrc/parser.y b/tools/wrc/parser.y
+index ad5fb98..ff59327 100644
+--- a/tools/wrc/parser.y
++++ b/tools/wrc/parser.y
+@@ -142,31 +142,6 @@
+ #include "wingdi.h"
+ #include "winuser.h"
+
+-#if defined(YYBYACC)
+- /* Berkeley yacc (byacc) doesn't seem to know about these */
+- /* Some *BSD supplied versions do define these though */
+-# ifndef YYEMPTY
+-# define YYEMPTY (-1) /* Empty lookahead value of yychar */
+-# endif
+-# ifndef YYLEX
+-# define YYLEX yylex()
+-# endif
+-
+-#elif defined(YYBISON)
+- /* Bison was used for original development */
+- /* #define YYEMPTY -2 */
+- /* #define YYLEX yylex() */
+-
+-#else
+- /* No yacc we know yet */
+-# if !defined(YYEMPTY) || !defined(YYLEX)
+-# error Yacc version/type unknown. This version needs to be verified for settings of YYEMPTY and YYLEX.
+-# elif defined(__GNUC__) /* gcc defines the #warning directive */
+-# warning Yacc version/type unknown. It defines YYEMPTY and YYLEX, but is not tested
+- /* #else we just take a chance that it works... */
+-# endif
+-#endif
+-
+ int want_nl = 0; /* Signal flex that we need the next newline */
+ int want_id = 0; /* Signal flex that we need the next identifier */
+ static stringtable_t *tagstt; /* Stringtable tag.
+@@ -2837,7 +2812,7 @@ static int rsrcid_to_token(int lookahead)
+
+ /* Get a token if we don't have one yet */
+ if(lookahead == YYEMPTY)
+- lookahead = YYLEX;
++ lookahead = yylex();
+
+ /* Only numbers are possibly interesting */
+ switch(lookahead)
+--
+1.8.1.6
+