summaryrefslogtreecommitdiffstats
path: root/main/x264
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-19 22:22:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-19 22:22:40 +0000
commit4d3e6a3db23e4f72cd580f2931c5ee1aab6dbf79 (patch)
tree92d1e6499d4051d58e410fcdc12eb41ed7bf57a8 /main/x264
parentc2dce737c85a5b1a36d2a971a35fdb8bf9b811e2 (diff)
downloadaports-4d3e6a3db23e4f72cd580f2931c5ee1aab6dbf79.tar.bz2
aports-4d3e6a3db23e4f72cd580f2931c5ee1aab6dbf79.tar.xz
main/x264: enable asm for non-x86
ref #1631
Diffstat (limited to 'main/x264')
-rw-r--r--main/x264/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
index cd3d69af4..5adffe646 100644
--- a/main/x264/APKBUILD
+++ b/main/x264/APKBUILD
@@ -1,22 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=x264
pkgver=20121217
-pkgrel=0
+pkgrel=1
pkgdesc="free library for encoding H264/AVC video streams"
url="http://www.videolan.org/developers/x264.html"
arch="all"
license="GPL"
depends=
-makedepends="libx11-dev bash"
+makedepends="libx11-dev bash yasm"
subpackages="$pkgname-dev"
source="ftp://ftp.videolan.org/pub/x264/snapshots/x264-snapshot-$pkgver-2245-stable.tar.bz2"
_builddir="$srcdir/$pkgname-snapshot-$pkgver-2245-stable"
build() {
cd "$_builddir"
+ local _asmopts=
+ if [ "$CARCH" = "x86" ]; then
+ _asmopts="--disable-asm"
+ fi
./configure --prefix=/usr \
--enable-visualize \
--enable-shared \
- --disable-asm \
+ $_asmopts \
--enable-pic || return 1
make || return 1
}
@@ -26,3 +30,5 @@ package() {
make DESTDIR="$pkgdir" bindir=/usr/bin libdir=/usr/lib includedir=/usr/include install || return 1
}
md5sums="078aef5b68d659d7cdec2d187d8bce6b x264-snapshot-20121217-2245-stable.tar.bz2"
+sha256sums="b22371a9ed0f60b42d5339647934fc3e177a766327304f064eca582336696c90 x264-snapshot-20121217-2245-stable.tar.bz2"
+sha512sums="4fc5aae9ac21d9a6bcb6c0aceb187b753b0d6de91b14aa090b33b5c5f84d8fe7c4650daea3d40d9751c308ebecaf05c6aab1550efac9c83841df45babb9ca768 x264-snapshot-20121217-2245-stable.tar.bz2"