summaryrefslogtreecommitdiffstats
path: root/main/x264
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/x264
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/x264')
-rw-r--r--main/x264/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
new file mode 100644
index 000000000..2429f146b
--- /dev/null
+++ b/main/x264/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=x264
+pkgver=20100107
+pkgrel=0
+pkgdesc="free library for encoding H264/AVC video streams"
+url="http://www.videolan.org/developers/x264.html"
+license="GPL"
+depends=
+makedepends="libx11-dev bash"
+subpackages="$pkgname-dev"
+source="http://ftp.videolan.org/pub/videolan/$pkgname/snapshots/$pkgname-snapshot-$pkgver-2245.tar.bz2"
+
+_builddir="$srcdir/$pkgname-snapshot-$pkgver-2245"
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-pthread \
+ --enable-visualize \
+ --enable-shared \
+ --disable-asm \
+ --enable-pic || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" bindir=/usr/bin libdir=/usr/lib includedir=/usr/include install || return 1
+}
+md5sums="58337bf425518cb79dd804bcfd10b7b7 x264-snapshot-20100107-2245.tar.bz2"