summaryrefslogtreecommitdiffstats
path: root/main/x264
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-15 13:01:45 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-15 13:01:45 +0000
commita8a060419bc5cff8488a8b31c30756362d24c526 (patch)
tree9ff763be193a6ea053d705b6b6bc11a1b35b3996 /main/x264
parent7f521bc25431acd7926cd00bba4d4c46a62812f7 (diff)
downloadaports-a8a060419bc5cff8488a8b31c30756362d24c526.tar.bz2
aports-a8a060419bc5cff8488a8b31c30756362d24c526.tar.xz
main/x264: fix arm build
the neon assembly seems to contain textrels, so disable all the assembly stuff for now.
Diffstat (limited to 'main/x264')
-rw-r--r--main/x264/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
index c24cb67ff..6ee948842 100644
--- a/main/x264/APKBUILD
+++ b/main/x264/APKBUILD
@@ -15,7 +15,13 @@ _builddir="$srcdir/$pkgname-snapshot-$pkgver-2245-stable"
build() {
cd "$_builddir"
local _asmopts=
- [ "$CARCH" = "x86" ] && _asmopts="--disable-asm"
+
+ case "$CARCH" in
+ # x86 assembly contains TEXTRELs
+ # arm neon assembly contains TEXTRELs
+ x86 | arm*) _asmopts="--disable-asm"
+ esac
+
# note: not autotools
./configure \
--host=$CHOST \