summaryrefslogtreecommitdiffstats
path: root/main/xbmc
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-08 00:20:46 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-08 00:20:46 +0100
commitd1eaf10704d5a406a72fdb45a01c350c5f9be391 (patch)
tree0de22067ee96b129ba19d183e52d10647d2ca10a /main/xbmc
parent884746bef585df365a59078591a8dae172af4419 (diff)
downloadaports-d1eaf10704d5a406a72fdb45a01c350c5f9be391.tar.bz2
aports-d1eaf10704d5a406a72fdb45a01c350c5f9be391.tar.xz
testing/xbmc: upgrade to 12_rc3 and move to main
Diffstat (limited to 'main/xbmc')
-rw-r--r--main/xbmc/APKBUILD76
-rw-r--r--main/xbmc/no-snesapu.patch46
-rw-r--r--main/xbmc/xbmc-uclibc.patch41
3 files changed, 163 insertions, 0 deletions
diff --git a/main/xbmc/APKBUILD b/main/xbmc/APKBUILD
new file mode 100644
index 000000000..83f681676
--- /dev/null
+++ b/main/xbmc/APKBUILD
@@ -0,0 +1,76 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=xbmc
+pkgver=12_rc3
+_realver=Frodo_rc3
+pkgrel=0
+pkgdesc="A software media player and entertainment hub for digital media"
+url="http://xbmc.org"
+arch="x86_64 x86"
+license="GPL"
+depends="python hicolor-icon-theme xdpyinfo libcrystalhd unrar mesa-demos curl"
+depends_dev="gettext-dev boost-dev mesa-dev glew-dev glu-dev mysql-dev libass-dev
+ libogg-dev libvorbis-dev libmodplug-dev curl-dev flac-dev libgcrypt-dev bzip2-dev
+ tiff-dev lzo-dev yajl-dev bluez-dev tinyxml-dev fribidi-dev sqlite-dev libpng-dev
+ libcdio-dev pcre-dev freetype-dev taglib-dev jasper-dev alsa-lib-dev dbus-dev
+ sdl-dev sdl_image-dev lame-dev libmicrohttpd-dev libbluray-dev avahi-dev
+ libxrandr-dev libxt-dev libxmu-dev samba-dev gawk libssh-dev libva-dev libnfs-dev
+ yasm-dev libmpeg2-dev libmad-dev libsamplerate-dev rtmpdump-dev
+ libjpeg-turbo-dev crystalhd-git-grsec-dev udev-dev libcap-dev udisks-dev faac-dev
+ libshairport-dev ffmpeg-dev afpfs-ng-dev libcec-dev"
+makedepends="$depends_dev automake autoconf m4 libtool swig findutils openjdk6-jre-base
+ boost-thread zip gperf cmake coreutils nasm"
+subpackages="$pkgname-dev $pkgname-doc"
+install=""
+options="ldpath-recursive"
+source="saveas-https://github.com/xbmc/xbmc/archive/$_realver.tar.gz/$pkgname-$pkgver.tar.gz
+ no-snesapu.patch
+ xbmc-uclibc.patch"
+
+_builddir="$srcdir/xbmc-$_realver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ # fix autotools
+ sed -i -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADER/" \
+ lib/libdvd/libdvdcss/configure.ac || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./bootstrap || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-debug \
+ --disable-ccache \
+ --enable-crystalhd \
+ --enable-vaapi \
+ --enable-ffmpeg-libvorbis \
+ --enable-external-ffmpeg \
+ --enable-rtmp \
+ --enable-joystick \
+ --enable-xrandr \
+ --enable-optical-drive \
+ --enable-external-libraries \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="b2c6dc4f1b69fa5dd2fffd6cf76312ad xbmc-12_rc3.tar.gz
+5ad388f29ab8f4ca6bc9e2b73bf946ef no-snesapu.patch
+a089ae512a3e990ec85a78a4e79a29f5 xbmc-uclibc.patch"
diff --git a/main/xbmc/no-snesapu.patch b/main/xbmc/no-snesapu.patch
new file mode 100644
index 000000000..d49b273ab
--- /dev/null
+++ b/main/xbmc/no-snesapu.patch
@@ -0,0 +1,46 @@
+diff --git a/Makefile.in b/Makefile.in
+index 31826b1..2f468e7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -168,7 +168,6 @@ PAPCODECS_DIRS= \
+ lib/timidity \
+ lib/libsidplay2 \
+ lib/stsound/StSoundLibrary \
+- lib/snesapu/SNES/SNESAPU \
+ lib/vgmstream
+
+ ifeq (@USE_ASAP_CODEC@,1)
+@@ -373,9 +372,6 @@ ifeq (@USE_ASAP_CODEC@,1)
+ endif
+ endif
+ $(MAKE) -C lib/stsound/StSoundLibrary
+-ifeq ($(or $(findstring powerpc,@ARCH@),$(findstring x86_64-linux,@ARCH@),$(findstring arm, @ARCH@),$(findstring freebsd,@ARCH@)),)
+- $(MAKE) -C lib/snesapu/SNES/SNESAPU
+-endif
+ imagelib: dllloader
+ $(MAKE) -C lib/cximage-6.0
+
+diff --git a/configure.in b/configure.in
+index 538d9af..3f04545 100644
+--- a/configure.in
++++ b/configure.in
+@@ -2348,7 +2348,6 @@ OUTPUT_FILES="Makefile \
+ lib/nosefart/Makefile \
+ lib/libsidplay2/Makefile \
+ lib/vgmstream/Makefile \
+- lib/snesapu/SNES/SNESAPU/Makefile \
+ lib/stsound/StSoundLibrary/Makefile \
+ xbmc/cores/playercorefactory/Makefile \
+ xbmc/music/karaoke/Makefile \
+diff --git a/xbmc/cores/paplayer/Makefile.in b/xbmc/cores/paplayer/Makefile.in
+index 31cc8bd..a433e82 100644
+--- a/xbmc/cores/paplayer/Makefile.in
++++ b/xbmc/cores/paplayer/Makefile.in
+@@ -31,7 +31,6 @@ SRCS += ASAPCodec.cpp
+ endif
+
+ ifneq ($(ARCH), arm)
+-CXXFLAGS += -DHAS_SPC_CODEC
+ SRCS += SPCCodec.cpp
+ endif
+
diff --git a/main/xbmc/xbmc-uclibc.patch b/main/xbmc/xbmc-uclibc.patch
new file mode 100644
index 000000000..5ea62c200
--- /dev/null
+++ b/main/xbmc/xbmc-uclibc.patch
@@ -0,0 +1,41 @@
+--- a/xbmc/cores/DllLoader/exports/util/EmuFileWrapper.h.orig
++++ b/xbmc/cores/DllLoader/exports/util/EmuFileWrapper.h
+@@ -27,8 +27,10 @@
+ #include "system.h"
+ #include "threads/CriticalSection.h"
+
+-#if defined(_LINUX) && !defined(TARGET_DARWIN) && !defined(__FreeBSD__) && !defined(__ANDROID__)
++#if defined(_LINUX) && !defined(TARGET_DARWIN) && !defined(__FreeBSD__) && !defined(__ANDROID__) && !defined(__UCLIBC__)
+ #define _file _fileno
++#elif defined(__UCLIBC__)
++#define _file __filedes
+ #endif
+
+ #define MAX_EMULATED_FILES 50
+--- a/xbmc/cores/DllLoader/exports/emu_msvcrt.h.orig
++++ b/xbmc/cores/DllLoader/exports/emu_msvcrt.h
+@@ -46,9 +46,9 @@
+
+ typedef void ( *PFV)(void);
+
+-#define __IS_STDIN_STREAM(stream) (stream == stdin || stream->_file == stdin->_file || stream->_file == 0)
+-#define __IS_STDOUT_STREAM(stream) (stream == stdout || stream->_file == stdout->_file || stream->_file == 1)
+-#define __IS_STDERR_STREAM(stream) (stream == stderr || stream->_file == stderr->_file || stream->_file == 2)
++#define __IS_STDIN_STREAM(stream) (stream == stdin || fileno(stream) == fileno(stdin) || fileno(stream) == 0)
++#define __IS_STDOUT_STREAM(stream) (stream == stdout || fileno(stream) == fileno(stdout) || fileno(stream) == 1)
++#define __IS_STDERR_STREAM(stream) (stream == stderr || fileno(stream) == fileno(stderr) || fileno(stream) == 2)
+ #define IS_STDIN_STREAM(stream) (stream != NULL && __IS_STDIN_STREAM(stream))
+ #define IS_STDOUT_STREAM(stream) (stream != NULL && __IS_STDOUT_STREAM(stream))
+ #define IS_STDERR_STREAM(stream) (stream != NULL && __IS_STDERR_STREAM(stream))
+--- a/xbmc/visualizations/XBMCProjectM/libprojectM/BeatDetect.cpp.orig
++++ b/xbmc/visualizations/XBMCProjectM/libprojectM/BeatDetect.cpp
+@@ -33,7 +33,7 @@
+
+ #include "Common.hpp"
+ #include "PCM.hpp"
+-#include <cmath>
++#include "math.h"
+ #include "BeatDetect.hpp"
+
+ #ifdef _WIN32
+