summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-ark
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 09:21:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:23:43 +0000
commitdc6665106e5c590a30c0c370f8d03836cf7d1e4d (patch)
tree312fd3abdcc3f35aa2cbab4f0c165c2e013bc56a /main/xf86-video-ark
parent8a5e12e99d5dd3859edb66580ea245c13963c42c (diff)
downloadaports-dc6665106e5c590a30c0c370f8d03836cf7d1e4d.tar.bz2
aports-dc6665106e5c590a30c0c370f8d03836cf7d1e4d.tar.xz
main/xf86-video-ark: rebuild against xorg-1.14
Diffstat (limited to 'main/xf86-video-ark')
-rw-r--r--main/xf86-video-ark/APKBUILD25
-rw-r--r--main/xf86-video-ark/mibstore.patch18
2 files changed, 38 insertions, 5 deletions
diff --git a/main/xf86-video-ark/APKBUILD b/main/xf86-video-ark/APKBUILD
index 18cabcd71..32e0cd093 100644
--- a/main/xf86-video-ark/APKBUILD
+++ b/main/xf86-video-ark/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-ark
pkgver=0.7.5
-pkgrel=1
+pkgrel=2
pkgdesc="X.Org driver for ark cards"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -11,19 +11,34 @@ depends=
makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto"
-source="http://xorg.freedesktop.org//releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org//releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ mibstore.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure --prefix=/usr || return 1
make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/xorg/modules/drivers/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="2e9809b5ae3f01a56be0d6e5441da03c xf86-video-ark-0.7.5.tar.bz2"
+md5sums="2e9809b5ae3f01a56be0d6e5441da03c xf86-video-ark-0.7.5.tar.bz2
+d4625a8bf75d55959faebadcae02e3e4 mibstore.patch"
+sha256sums="c690e046f34a393aac1c8d9616b4790e93cda60a460b00b9597d322175dbe51e xf86-video-ark-0.7.5.tar.bz2
+32130c11a9af2d125a8376c0fc5cc7a94ecec5b88f33005ec9cc54423feeffb9 mibstore.patch"
+sha512sums="67c2b4e2109bf9d84a007c9679d35e7c0a4e4ddcdb7be9fa5070ce7e2f666e018d8421ddd4890cf3abb4eb37e060a10666c62a9efbb5369eb7cd8647ee18a644 xf86-video-ark-0.7.5.tar.bz2
+f7ef3d7003e75ae6d27f4ec1100e6cb42546f3dd5871a2d92ad779909ebd1243976679f14e1a8443ba17bb3cd36fa755cdbda4be3627a49af0033513309ad6bb mibstore.patch"
diff --git a/main/xf86-video-ark/mibstore.patch b/main/xf86-video-ark/mibstore.patch
new file mode 100644
index 000000000..2bc41a73a
--- /dev/null
+++ b/main/xf86-video-ark/mibstore.patch
@@ -0,0 +1,18 @@
+--- ./src/ark_driver.c.orig 2013-03-07 10:16:06.584081552 +0000
++++ ./src/ark_driver.c 2013-03-07 10:16:23.270892075 +0000
+@@ -39,7 +39,6 @@
+ #include "compiler.h"
+ #include "mipointer.h"
+ #include "micmap.h"
+-#include "mibstore.h"
+ #include "fb.h"
+ #include "ark.h"
+
+@@ -538,7 +537,6 @@
+
+ fbPictureInit (pScreen, 0, 0);
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+
+ if (!pARK->NoAccel) {