summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-cirrus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-02 12:00:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-02 12:00:03 +0000
commit9c72b19c38932e437c73471aeaab17e899062515 (patch)
tree9140d0f8e7591b64dfa4168a3d2154440de472a4 /main/xf86-video-cirrus
parente4033c192c7f056d3907276553d5fb0256a159a0 (diff)
downloadaports-9c72b19c38932e437c73471aeaab17e899062515.tar.bz2
aports-9c72b19c38932e437c73471aeaab17e899062515.tar.xz
main/xf86-video-cirrus: upgrade to 1.5.1
Diffstat (limited to 'main/xf86-video-cirrus')
-rw-r--r--main/xf86-video-cirrus/APKBUILD8
-rw-r--r--main/xf86-video-cirrus/qemu.patch25
2 files changed, 3 insertions, 30 deletions
diff --git a/main/xf86-video-cirrus/APKBUILD b/main/xf86-video-cirrus/APKBUILD
index 1b0504f0b..c5ae8d97d 100644
--- a/main/xf86-video-cirrus/APKBUILD
+++ b/main/xf86-video-cirrus/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-cirrus
-pkgver=1.4.0
+pkgver=1.5.1
pkgrel=0
pkgdesc="Cirrus Logic video driver"
url="http://xorg.freedesktop.org/"
@@ -11,8 +11,7 @@ depends=
makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto"
-source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
- qemu.patch"
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -36,5 +35,4 @@ package() {
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="1e449789da866f974dbf6cbe3c8cc7bf xf86-video-cirrus-1.4.0.tar.bz2
-b3bd556766fcd0fee51ae0c286f75f05 qemu.patch"
+md5sums="16ea047a601896fb0ec995dbe9fb7ef2 xf86-video-cirrus-1.5.1.tar.bz2"
diff --git a/main/xf86-video-cirrus/qemu.patch b/main/xf86-video-cirrus/qemu.patch
deleted file mode 100644
index 444fb6010..000000000
--- a/main/xf86-video-cirrus/qemu.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -up xf86-video-cirrus-1.2.0/src/alp_driver.c.jx xf86-video-cirrus-1.2.0/src/alp_driver.c
---- xf86-video-cirrus-1.2.0/src/alp_driver.c.jx 2008-03-19 10:29:23.000000000 -0400
-+++ xf86-video-cirrus-1.2.0/src/alp_driver.c 2009-02-27 10:59:27.000000000 -0500
-@@ -812,6 +812,20 @@ AlpPreInit(ScrnInfoPtr pScrn, int flags)
- else
- xf86SetDDCproperties(pScrn,xf86PrintEDID(
- xf86DoEDID_DDC2(pScrn->scrnIndex,pCir->I2CPtr1)));
-+#ifdef XSERVER_LIBPCIACCESS
-+ if (!pScrn->monitor->DDC &&
-+ ((pCir->PciInfo->subvendor_id & 0xffff) == 0x1af4)) {
-+ xf86DrvMsg(pScrn->scrnIndex, X_INFO,
-+ "Defaulting to 1024x768 for QEMU\n");
-+ pScrn->monitor->nHsync = 1;
-+ pScrn->monitor->hsync[0].lo = 31.5;
-+ pScrn->monitor->hsync[0].hi = 48.0;
-+ pScrn->monitor->nVrefresh = 1;
-+ pScrn->monitor->vrefresh[0].lo = 56.0;
-+ pScrn->monitor->vrefresh[0].hi = 60.1;
-+ pScrn->monitor->maxPixClock = 65000;
-+ }
-+#endif
-
- /* Probe the possible LCD display */
- AlpProbeLCD(pScrn);
-