summaryrefslogtreecommitdiffstats
path: root/main/xf86-video-dummy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 09:31:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:23:43 +0000
commita1867e9ce5124f13a0d9babc0815fc9349e24ac3 (patch)
tree10b9bc6c6566e18e193da1080394da64993139a6 /main/xf86-video-dummy
parentb0c39c00831187a1b8da554d336e3c89eea48d38 (diff)
downloadaports-a1867e9ce5124f13a0d9babc0815fc9349e24ac3.tar.bz2
aports-a1867e9ce5124f13a0d9babc0815fc9349e24ac3.tar.xz
main/xf86-video-dummy: rebuild against xorg-server-1.14
Diffstat (limited to 'main/xf86-video-dummy')
-rw-r--r--main/xf86-video-dummy/APKBUILD25
-rw-r--r--main/xf86-video-dummy/mibstore.patch31
2 files changed, 51 insertions, 5 deletions
diff --git a/main/xf86-video-dummy/APKBUILD b/main/xf86-video-dummy/APKBUILD
index 1a5814ed2..7d08b9602 100644
--- a/main/xf86-video-dummy/APKBUILD
+++ b/main/xf86-video-dummy/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-dummy
pkgver=0.3.6
-pkgrel=1
+pkgrel=3
pkgdesc="X.Org driver for dummy cards"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -11,19 +11,34 @@ depends=
makedepends="pkgconfig xorg-server-dev libxi-dev fontsproto randrproto
videoproto renderproto xf86dgaproto"
-source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ mibstore.patch"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
./configure --prefix=/usr || return 1
make || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="dc40aebf031f933523dcf101befe99e4 xf86-video-dummy-0.3.6.tar.bz2"
+md5sums="dc40aebf031f933523dcf101befe99e4 xf86-video-dummy-0.3.6.tar.bz2
+c60006edbfd14b36c285fd760ec53c44 mibstore.patch"
+sha256sums="44335b640126d339700256dae731bd5af79afd027da172bad8a991a33a1de798 xf86-video-dummy-0.3.6.tar.bz2
+06fe79ba658712a1abb0612a049c1061618d30e72d4939fc59c8c905d9d4d5bb mibstore.patch"
+sha512sums="3a530083d591ebde37b58a329d9a6ed4955d09d8f3f7fb566840681f2588aa752014c8753f411aec0410a2704b3b55729868a27aee138df42eb7d7bb5a5a52c5 xf86-video-dummy-0.3.6.tar.bz2
+c141a4f316b67f06d07318af312c2a37c764b34ea6fdd17413a2e08e4f2e4e817499bea3bbbbf894fc4c08e74f721e3c640a300a8eb052b5b733b5142392c2ac mibstore.patch"
diff --git a/main/xf86-video-dummy/mibstore.patch b/main/xf86-video-dummy/mibstore.patch
new file mode 100644
index 000000000..4b0b46ef3
--- /dev/null
+++ b/main/xf86-video-dummy/mibstore.patch
@@ -0,0 +1,31 @@
+From 44f04fd3046043ed31369025f34353c4e0e5c1cd Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:54:36 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/dummy_driver.c b/src/dummy_driver.c
+index 62066d6..6062c39 100644
+--- a/src/dummy_driver.c
++++ b/src/dummy_driver.c
+@@ -14,9 +14,6 @@
+ /* All drivers initialising the SW cursor need this */
+ #include "mipointer.h"
+
+-/* All drivers implementing backing store need this */
+-#include "mibstore.h"
+-
+ /* All drivers using the mi colormap manipulation need this */
+ #include "micmap.h"
+
+@@ -617,7 +614,6 @@ DUMMYScreenInit(SCREEN_INIT_ARGS_DECL)
+ , lines - pScrn->virtualY);
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
+--
+cgit v0.9.0.2-2-gbebe