summaryrefslogtreecommitdiffstats
path: root/main/xfsprogs
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/xfsprogs
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
downloadaports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.bz2
aports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.xz
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/xfsprogs')
-rw-r--r--main/xfsprogs/APKBUILD35
-rw-r--r--main/xfsprogs/xfsprogs-3.0.0-gzip.patch24
2 files changed, 59 insertions, 0 deletions
diff --git a/main/xfsprogs/APKBUILD b/main/xfsprogs/APKBUILD
new file mode 100644
index 000000000..6efce7220
--- /dev/null
+++ b/main/xfsprogs/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfsprogs
+pkgver=3.0.1
+pkgrel=0
+pkgdesc="XFS filesystem utilities"
+url="http://oss.sgi.com/projects/xfs/"
+license="LGPL"
+depends="e2fsprogs"
+makedepends="e2fsprogs-dev bash"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://oss.sgi.com/projects/xfs/cmd_tars/${pkgname}-$pkgver.tar.gz
+ xfsprogs-3.0.0-gzip.patch
+ "
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ export DEBUG=-DNDEBUG
+ export OPTIMIZER="$CFLAGS"
+
+ ac_cv_header_aio_h=yes ac_cv_lib_rt_lio_listio=yes \
+ ./configure --prefix=/usr \
+ --sbindir=/sbin \
+ --libexecdir=/usr/lib \
+ --enable-gettext=no
+
+ make SHELL=/bin/bash || return 1
+ make -j1 DIST_ROOT="$pkgdir" install install-dev
+}
+md5sums="d7f879a21692d4f7abc16a20479b0829 xfsprogs-3.0.1.tar.gz
+c72865de30f55343e843dd4fd49a91c5 xfsprogs-3.0.0-gzip.patch"
diff --git a/main/xfsprogs/xfsprogs-3.0.0-gzip.patch b/main/xfsprogs/xfsprogs-3.0.0-gzip.patch
new file mode 100644
index 000000000..40f80023d
--- /dev/null
+++ b/main/xfsprogs/xfsprogs-3.0.0-gzip.patch
@@ -0,0 +1,24 @@
+diff -ru xfsprogs-3.0.0.orig/doc/Makefile xfsprogs-3.0.0/doc/Makefile
+--- xfsprogs-3.0.0.orig/doc/Makefile 2009-02-18 13:42:47.000000000 +0000
++++ xfsprogs-3.0.0/doc/Makefile 2009-02-18 13:43:10.000000000 +0000
+@@ -13,7 +13,7 @@
+ include $(BUILDRULES)
+
+ CHANGES.gz:
+- $(ZIP) --best -c < CHANGES > $@
++ $(ZIP) -c < CHANGES > $@
+
+ install: default
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+diff -ru xfsprogs-3.0.0.orig/include/buildmacros xfsprogs-3.0.0/include/buildmacros
+--- xfsprogs-3.0.0.orig/include/buildmacros 2009-02-18 13:42:47.000000000 +0000
++++ xfsprogs-3.0.0/include/buildmacros 2009-02-18 13:43:46.000000000 +0000
+@@ -128,7 +128,7 @@
+ MAN_MAKERULE = \
+ @for f in *.[12345678] ""; do \
+ if test ! -z "$$f"; then \
+- $(ZIP) --best -c < $$f > $$f.gz; \
++ $(ZIP) -c < $$f > $$f.gz; \
+ fi; \
+ done
+