summaryrefslogtreecommitdiffstats
path: root/main/xorg-server
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-30 14:51:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-30 14:51:52 +0000
commit858c54a9949286a25548349e77fe172e4f9dd6ee (patch)
tree2d06f141c272c44fd3c2ca4cde409a27277d3037 /main/xorg-server
parentca9c3d97f16f870d5f9958b4f875d5d1fa73b5ea (diff)
downloadaports-858c54a9949286a25548349e77fe172e4f9dd6ee.tar.bz2
aports-858c54a9949286a25548349e77fe172e4f9dd6ee.tar.xz
main/xorg-server: upgrade to 1.10.2
Diffstat (limited to 'main/xorg-server')
-rw-r--r--main/xorg-server/APKBUILD8
-rw-r--r--main/xorg-server/glx-pixmap-crash.patch85
2 files changed, 3 insertions, 90 deletions
diff --git a/main/xorg-server/APKBUILD b/main/xorg-server/APKBUILD
index 75ec0db62..bcc808532 100644
--- a/main/xorg-server/APKBUILD
+++ b/main/xorg-server/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xorg-server
-pkgver=1.10.1
-pkgrel=1
+pkgver=1.10.2
+pkgrel=0
pkgdesc="X.Org X servers"
url="http://xorg.freedesktop.org"
arch="all"
@@ -61,7 +61,6 @@ makedepends="
source="http://xorg.freedesktop.org/releases/individual/xserver/$pkgname-$pkgver.tar.bz2
xorg-redhat-die-ugly-pattern-die-die-die.patch
bg-none-revert.patch
- glx-pixmap-crash.patch
xserver-1.10-pointer-barriers.patch
"
@@ -152,8 +151,7 @@ xephyr() {
mv "$pkgdir"/usr/bin/Xephyr "$subpkgdir"/usr/bin/
}
-md5sums="75f117c74f2ecaf9dd167f6a66ac98de xorg-server-1.10.1.tar.bz2
+md5sums="c9ba50bd44ea70da51f13100336a5484 xorg-server-1.10.2.tar.bz2
222de594206d1148a90eddfda4f7a11a xorg-redhat-die-ugly-pattern-die-die-die.patch
030dd3ec221b895de3057d7513d8c1d7 bg-none-revert.patch
-baa098b7e1f95ab55e4c29fb3332baaf glx-pixmap-crash.patch
db48cea655c7bccec9171c5df1558a64 xserver-1.10-pointer-barriers.patch"
diff --git a/main/xorg-server/glx-pixmap-crash.patch b/main/xorg-server/glx-pixmap-crash.patch
deleted file mode 100644
index 48f258eb5..000000000
--- a/main/xorg-server/glx-pixmap-crash.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 390ba6686d1baf80627c01d4a4273981d6606cc9 Mon Sep 17 00:00:00 2001
-From: Adam Jackson <ajax@redhat.com>
-Date: Mon, 28 Mar 2011 16:30:09 +0000
-Subject: glx: Fix lifetime tracking for pixmaps
-
-GLX pixmaps take a reference on the underlying pixmap; X and GLX pixmap
-IDs can be destroyed in either order with no error. Only windows need
-to be tracked under both XIDs.
-
-Fixes piglit/glx-pixmap-life.
-
-Reviewed-by: Michel Dänzer <michel@daenzer.net>
-Signed-off-by: Adam Jackson <ajax@redhat.com>
----
-diff --git a/glx/glxcmds.c b/glx/glxcmds.c
-index 66d4c7e..d5b764f 100644
---- a/glx/glxcmds.c
-+++ b/glx/glxcmds.c
-@@ -1127,10 +1127,11 @@ DoCreateGLXDrawable(ClientPtr client, __GLXscreen *pGlxScreen,
- return BadAlloc;
- }
-
-- /* Add the glx drawable under the XID of the underlying X drawable
-- * too. That way we'll get a callback in DrawableGone and can
-- * clean up properly when the drawable is destroyed. */
-- if (drawableId != glxDrawableId &&
-+ /*
-+ * Windows aren't refcounted, so track both the X and the GLX window
-+ * so we get called regardless of destruction order.
-+ */
-+ if (drawableId != glxDrawableId && type == GLX_DRAWABLE_WINDOW &&
- !AddResource(pDraw->id, __glXDrawableRes, pGlxDraw)) {
- pGlxDraw->destroy (pGlxDraw);
- return BadAlloc;
-@@ -1161,6 +1162,8 @@ DoCreateGLXPixmap(ClientPtr client, __GLXscreen *pGlxScreen, __GLXconfig *config
- err = DoCreateGLXDrawable(client, pGlxScreen, config, pDraw, drawableId,
- glxDrawableId, GLX_DRAWABLE_PIXMAP);
-
-+ ((PixmapPtr)pDraw)->refcnt++;
-+
- return err;
- }
-
-diff --git a/glx/glxext.c b/glx/glxext.c
-index 3f3dd79..9cfc096 100644
---- a/glx/glxext.c
-+++ b/glx/glxext.c
-@@ -118,15 +118,15 @@ static Bool DrawableGone(__GLXdrawable *glxPriv, XID xid)
- {
- __GLXcontext *c, *next;
-
-- /* If this drawable was created using glx 1.3 drawable
-- * constructors, we added it as a glx drawable resource under both
-- * its glx drawable ID and it X drawable ID. Remove the other
-- * resource now so we don't a callback for freed memory. */
-- if (glxPriv->drawId != glxPriv->pDraw->id) {
-- if (xid == glxPriv->drawId)
-- FreeResourceByType(glxPriv->pDraw->id, __glXDrawableRes, TRUE);
-- else
-- FreeResourceByType(glxPriv->drawId, __glXDrawableRes, TRUE);
-+ if (glxPriv->type == GLX_DRAWABLE_WINDOW) {
-+ /* If this was created by glXCreateWindow, free the matching resource */
-+ if (glxPriv->drawId != glxPriv->pDraw->id) {
-+ if (xid == glxPriv->drawId)
-+ FreeResourceByType(glxPriv->pDraw->id, __glXDrawableRes, TRUE);
-+ else
-+ FreeResourceByType(glxPriv->drawId, __glXDrawableRes, TRUE);
-+ }
-+ /* otherwise this window was implicitly created by MakeCurrent */
- }
-
- for (c = glxAllContexts; c; c = next) {
-@@ -143,6 +143,10 @@ static Bool DrawableGone(__GLXdrawable *glxPriv, XID xid)
- c->readPriv = NULL;
- }
-
-+ /* drop our reference to any backing pixmap */
-+ if (glxPriv->type == GLX_DRAWABLE_PIXMAP)
-+ glxPriv->pDraw->pScreen->DestroyPixmap((PixmapPtr)glxPriv->pDraw);
-+
- glxPriv->destroy(glxPriv);
-
- return True;
---
-cgit v0.8.3-6-g21f6