summaryrefslogtreecommitdiffstats
path: root/main/xorg-server
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-03 13:09:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-03 13:09:08 +0000
commitb7f734b6bd771bd8787eb7c8109646de89bc2827 (patch)
tree629d2279ff7f4a7c7ff66a15c3b317dc3f72d37e /main/xorg-server
parentfdd19c63274921d12566330a7587c44092a3a4af (diff)
downloadaports-b7f734b6bd771bd8787eb7c8109646de89bc2827.tar.bz2
aports-b7f734b6bd771bd8787eb7c8109646de89bc2827.tar.xz
main/xorg-server: fix musl build
Diffstat (limited to 'main/xorg-server')
-rw-r--r--main/xorg-server/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/xorg-server/APKBUILD b/main/xorg-server/APKBUILD
index c1fea4ea3..f1d773ac5 100644
--- a/main/xorg-server/APKBUILD
+++ b/main/xorg-server/APKBUILD
@@ -72,7 +72,7 @@ source="http://xorg.freedesktop.org/releases/individual/xserver/$pkgname-$pkgver
prepare() {
cd "$srcdir"/$pkgname-$pkgver
-
+ update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -80,6 +80,7 @@ prepare() {
done
# Fix dbus config path
sed -i -e 's/\$(sysconfdir)/\/etc/' config/Makefile.* || return 1
+ sed -i -e 's/termio.h/termios.h/' hw/xfree86/os-support/xf86_OSlib.h || return 1
}
build() {
@@ -87,6 +88,8 @@ build() {
# xorg modules does not work with the -z now and it seems like we
# cannot pass over the linker flag to .so files. so we tweak the
# gcc specs.
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ [ "$CLIBC" == musl ] && export CFLAGS="$CFLAGS -D__gid_t=gid_t -D__uid_t=uid_t"
export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
_fontroot="/usr/share/fonts"