summaryrefslogtreecommitdiffstats
path: root/main/xz
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-21 20:30:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-21 20:30:34 +0000
commit29b5df4f9643103f6e72fdac2fb1bb426d35cb5b (patch)
treeb80091f529a86048f732e8bac4c0d03253770173 /main/xz
parent1b2de8c0a7ff84d0129a30ba96ed41a37b4ecf06 (diff)
downloadaports-29b5df4f9643103f6e72fdac2fb1bb426d35cb5b.tar.bz2
aports-29b5df4f9643103f6e72fdac2fb1bb426d35cb5b.tar.xz
main/xz: moved from testing
Diffstat (limited to 'main/xz')
-rw-r--r--main/xz/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/xz/APKBUILD b/main/xz/APKBUILD
new file mode 100644
index 000000000..da3784d39
--- /dev/null
+++ b/main/xz/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xz
+pkgver=5.0.1
+pkgrel=0
+pkgdesc="Library and command line tools for XZ and LZMA compressed files"
+url="http://tukaani.org/xz/"
+arch="all"
+license="GPL LGPL custom"
+depends=""
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://tukaani.org/xz/xz-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build ()
+{
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-rpath \
+ --enable-werror
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ pkgdesc="Libraries for decoding LZMA compression"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="60044a5701997e4e0904257197208ea9 xz-5.0.1.tar.gz"