summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2012-11-16 17:53:15 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-19 12:15:20 +0000
commit1bba205542b00512cc50c8a4807b358f0b2697c5 (patch)
tree5854aa1589c7e1043ab6a4532f1ba07e6fd6323a /main
parent408f1c4ba7903a8d7501f3468838ffef1ef5b6c6 (diff)
downloadaports-1bba205542b00512cc50c8a4807b358f0b2697c5.tar.bz2
aports-1bba205542b00512cc50c8a4807b358f0b2697c5.tar.xz
xen: prevent qemu daemon from screwing the console
Qemu when launched with -nographic and -monitor screws the console badly. Use nohup to prevent that. Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
Diffstat (limited to 'main')
-rw-r--r--main/xen/APKBUILD2
-rw-r--r--main/xen/xenqemu.initd5
2 files changed, 5 insertions, 2 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index 94a7c10ed..714385011 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -145,4 +145,4 @@ ec2252c72050d7d5870a3a629b873ba6 xenconsoled.confd
9b20e056d475b50586cf9e1fc94e13c4 xendomains.confd
9df68ac65dc3f372f5d61183abdc83ff xen-consoles.logrotate
6a2f777c16678d84039acf670d86fff6 xenqemu.confd
-fbd2082d448acfec2e69b860120d79b7 xenqemu.initd"
+f9afbf39e2b5a7d9dde60ebbd249ea7d xenqemu.initd"
diff --git a/main/xen/xenqemu.initd b/main/xen/xenqemu.initd
index 463bf598f..aeabd3094 100644
--- a/main/xen/xenqemu.initd
+++ b/main/xen/xenqemu.initd
@@ -7,8 +7,11 @@ depend() {
start() {
ebegin "Starting QEMU as disk backend for dom0"
- start-stop-daemon --start --exec /usr/lib/xen/bin/qemu-system-i386 \
+ # XXX: qemu f**** the console when launched with
+ # -nographic and -monitor, use nohup to prevent that.
+ start-stop-daemon --start --exec nohup \
--pidfile=/var/run/xenqemu.pid -b -- \
+ /usr/lib/xen/bin/qemu-system-i386 \
-xen-domid 0 -xen-attach -name dom0 -nographic \
-M xenpv -monitor /dev/null \
-pidfile /var/run/xenqemu.pid \