summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-25 21:00:49 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-25 21:00:49 -0600
commitccf8413c0b9397a1c14a7bd53fe196fb617ae0de (patch)
tree11ecc59e2bb200a8614106c6b3b3ebde2c062a5d /main
parentdcc39ed47e2a83ae916eaa5f9c374c99a11b5d2a (diff)
downloadaports-ccf8413c0b9397a1c14a7bd53fe196fb617ae0de.tar.bz2
aports-ccf8413c0b9397a1c14a7bd53fe196fb617ae0de.tar.xz
testing/firefox: promote to main
Diffstat (limited to 'main')
-rw-r--r--main/firefox/APKBUILD95
-rw-r--r--main/firefox/firefox-agent.patch12
-rw-r--r--main/firefox/firefox-defaults.patch28
-rw-r--r--main/firefox/firefox-safe.desktop11
-rw-r--r--main/firefox/firefox-version.patch11
-rw-r--r--main/firefox/firefox.desktop81
-rw-r--r--main/firefox/mozconfig35
7 files changed, 273 insertions, 0 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
new file mode 100644
index 000000000..156590666
--- /dev/null
+++ b/main/firefox/APKBUILD
@@ -0,0 +1,95 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=firefox
+pkgver=3.6.13
+_xulver=1.9.2.13
+pkgrel=2
+pkgdesc="firefox web browser (unofficial branding)"
+url="http://www.firefox.com"
+arch="all"
+license="GPL LGPL MPL"
+depends="xulrunner"
+makedepends="xulrunner-dev>=${_xulver}
+
+ nspr-dev
+ nss-dev
+ gtk+-dev
+ dbus-glib-dev
+ alsa-lib-dev
+ libvorbis-dev
+ libogg-dev
+ libtheora-dev
+ wireless-tools-dev
+ libnotify-dev
+ libevent-dev
+ libxt-dev
+ jpeg-dev
+ bzip2-dev
+ hunspell-dev
+ startup-notification-dev
+ sqlite-dev
+ libidl-dev
+
+ autoconf2.13
+
+ python
+ zip
+
+ autoconf
+ automake
+ libtool"
+install=""
+subpackages=""
+source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
+ mozconfig
+ firefox-agent.patch
+ firefox-defaults.patch
+ firefox-version.patch
+ firefox.desktop
+ firefox-safe.desktop"
+
+_xulrunner_version="${_xulver%.*}"
+_builddir="${srcdir}/mozilla-${_xulrunner_version}"
+prepare() {
+ local i
+
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cp "${srcdir}/mozconfig" .mozconfig
+}
+
+build() {
+ cd "$_builddir"
+
+ # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
+ # for the best. --nenolod
+ unset CFLAGS
+ unset CXXFLAGS
+
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m755 -d ${pkgdir}/usr/share/pixmaps
+ install -m644 ${srcdir}/mozilla-1.9.2/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png
+ install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/firefox.desktop
+ install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
+}
+
+md5sums="d7c90aed8209beefa74badf02e8eeae1 firefox-3.6.13.source.tar.bz2
+7938f0054456f3767d2427dff137ab34 mozconfig
+f437e94acff8f810991271ef4677d859 firefox-agent.patch
+1807651225b021e043154f8bba715a19 firefox-defaults.patch
+92c11c66dd69b03f214002fededd1fc8 firefox-version.patch
+ba96924ece1d77453e462429037a2ce5 firefox.desktop
+6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
diff --git a/main/firefox/firefox-agent.patch b/main/firefox/firefox-agent.patch
new file mode 100644
index 000000000..299f327e2
--- /dev/null
+++ b/main/firefox/firefox-agent.patch
@@ -0,0 +1,12 @@
+diff -Nur mozilla-1.9.2.orig/browser/app/profile/firefox.js mozilla-1.9.2/browser/app/profile/firefox.js
+--- mozilla-1.9.2.orig/browser/app/profile/firefox.js 2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/app/profile/firefox.js 2010-04-21 00:16:59.673528609 +0300
+@@ -183,7 +183,7 @@
+
+ pref("general.useragent.locale", "@AB_CD@");
+ pref("general.skins.selectedSkin", "classic/1.0");
+-pref("general.useragent.extra.firefox", "@APP_UA_NAME@/@APP_VERSION@");
++pref("general.useragent.extra.firefox", "Firefox/@APP_VERSION@");
+
+ pref("general.smoothScroll", false);
+ #ifdef UNIX_BUT_NOT_MAC
diff --git a/main/firefox/firefox-defaults.patch b/main/firefox/firefox-defaults.patch
new file mode 100644
index 000000000..d3cdb473a
--- /dev/null
+++ b/main/firefox/firefox-defaults.patch
@@ -0,0 +1,28 @@
+diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/locales/browserconfig.properties mozilla-1.9.2/browser/branding/unofficial/locales/browserconfig.properties
+--- mozilla-1.9.2.old//browser/branding/unofficial/locales/browserconfig.properties 2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/branding/unofficial/locales/browserconfig.properties 2010-04-20 23:55:32.036959438 +0300
+@@ -1,3 +1,3 @@
+ # Do NOT localize or otherwise change these values
+-browser.startup.homepage=http://www.mozilla.org/projects/namoroka/
++browser.startup.homepage=http://www.google.com/firefox
+
+diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js
+--- mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js 2010-04-14 01:21:35.000000000 +0300
++++ mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js 2010-04-20 23:55:01.290102941 +0300
+@@ -1,5 +1,5 @@
+-pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/");
+-pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
++pref("startup.homepage_override_url","http://www.mozilla.com/%APP%/%VERSION%/whatsnew/");
++pref("startup.homepage_welcome_url","http://www.mozilla.com/%APP%/%VERSION%/firstrun/");
+ // The time interval between checks for a new version (in seconds)
+ // nightly=8 hours, official=24 hours
+ pref("app.update.interval", 28800);
+@@ -14,7 +14,7 @@
+ pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/");
+
+ // Release notes URL
+-pref("app.releaseNotesURL", "http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/");
++pref("app.releaseNotesURL", "http://www.mozilla.com/%APP%/%VERSION%/releasenotes/");
+
+ // Search codes belong only in builds with official branding
+ pref("browser.search.param.yahoo-fr", "");
diff --git a/main/firefox/firefox-safe.desktop b/main/firefox/firefox-safe.desktop
new file mode 100644
index 000000000..1538fc674
--- /dev/null
+++ b/main/firefox/firefox-safe.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=firefox -safe-mode %u
+Icon=firefox
+Type=Application
+Terminal=false
+MultipleArgs=false
+Name=Firefox - Safe Mode
+GenericName=Web Browser - Safe Mode
+StartupNotify=false
+Categories=Network;WebBrowser;
diff --git a/main/firefox/firefox-version.patch b/main/firefox/firefox-version.patch
new file mode 100644
index 000000000..a7f3740c7
--- /dev/null
+++ b/main/firefox/firefox-version.patch
@@ -0,0 +1,11 @@
+--- mozilla-1.9.1/browser/installer/Makefile.in.ver 2009-07-18 13:32:35.000000000 +0200
++++ mozilla-1.9.1/browser/installer/Makefile.in 2009-07-18 13:33:12.000000000 +0200
+@@ -43,6 +43,8 @@
+
+ include $(DEPTH)/config/autoconf.mk
+
++MOZ_APP_VERSION="3.6"
++
+ NO_PKG_FILES = \
+ $(MOZ_APP_NAME)-config \
+ $(MOZ_APP_NAME)-bin.elf \
diff --git a/main/firefox/firefox.desktop b/main/firefox/firefox.desktop
new file mode 100644
index 000000000..d048ce46c
--- /dev/null
+++ b/main/firefox/firefox.desktop
@@ -0,0 +1,81 @@
+[Desktop Entry]
+Exec=firefox %u
+Icon=firefox
+Type=Application
+Terminal=false
+Name=Firefox
+Name[bn]=ফায়ারফক্স3
+Name[eo]=Fajrovulpo3
+Name[fi]=Firefox3
+Name[pa]=ਫਾਇਰਫੋਕਸ3
+Name[tg]=Рӯбоҳи оташин3
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+MimeType=text/html;
+StartupNotify=true
+Categories=Network;WebBrowser;
diff --git a/main/firefox/mozconfig b/main/firefox/mozconfig
new file mode 100644
index 000000000..e6ec2d1c2
--- /dev/null
+++ b/main/firefox/mozconfig
@@ -0,0 +1,35 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-pthreads
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+ac_add_options --enable-optimize
+ac_add_options --disable-installer
+ac_add_options --enable-xinerama
+ac_add_options --enable-default-toolkit=cairo-gtk2
+ac_add_options --disable-xprint
+ac_add_options --enable-strip
+ac_add_options --enable-pango
+ac_add_options --enable-svg
+ac_add_options --enable-canvas
+ac_add_options --enable-startup-notification
+ac_add_options --enable-libxul
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9.2
+ac_add_options --enable-safe-browsing
+ac_add_options --with-branding=browser/branding/unofficial
+
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export USE_SHORT_LIBNAME=1
+
+mk_add_options BUILD_OFFICIAL=1
+mk_add_options MOZILLA_OFFICIAL=1
+mk_add_options USE_SHORT_LIBNAME=1