summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-03-13 15:11:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-13 15:11:28 +0000
commite478a34043087fe833f82616eaeb005f5f338c86 (patch)
tree2b608fe411491cfc6fc52df06c16c31fc43771ab /main
parent418005d5e29f41b53cb309631d09d99b38d6f751 (diff)
downloadaports-e478a34043087fe833f82616eaeb005f5f338c86.tar.bz2
aports-e478a34043087fe833f82616eaeb005f5f338c86.tar.xz
main/python: rebuild with working mutiprocessing
The build server did not have /dev/shm so python got built without multiprocessing. ref #2747
Diffstat (limited to 'main')
-rw-r--r--main/python/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/main/python/APKBUILD b/main/python/APKBUILD
index fad33f84e..61de1eef4 100644
--- a/main/python/APKBUILD
+++ b/main/python/APKBUILD
@@ -2,7 +2,7 @@
pkgname=python
pkgver=2.7.6
_verbase=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -29,6 +29,13 @@ prepare() {
# Make sure we use system libs
rm -r Modules/expat Modules/_ctypes/libffi* Modules/zlib || return 1
+
+ # make sure our /dev/shm is world writeable
+ if ! touch /dev/shm/$pkgname-$pkgver; then
+ error "/dev/shm is not world writeable. this will cause a broken python build"
+ return 1
+ fi
+ rm /dev/shm/$pkgname-$pkgver
}
build() {