summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 09:01:42 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 09:01:42 +0000
commitf4ed74f439220f4fa54274f32c7e3863aac5e560 (patch)
treedb2532f83bdfc1f5d75316955b93cf30a001309d /main
parent157530e34b47e1b21a90163d23311c9fd038d623 (diff)
downloadaports-f4ed74f439220f4fa54274f32c7e3863aac5e560.tar.bz2
aports-f4ed74f439220f4fa54274f32c7e3863aac5e560.tar.xz
main/libnih: fix musl build
Diffstat (limited to 'main')
-rw-r--r--main/libnih/APKBUILD13
-rw-r--r--main/libnih/musl-fix-signals.patch12
2 files changed, 22 insertions, 3 deletions
diff --git a/main/libnih/APKBUILD b/main/libnih/APKBUILD
index 855b85581..879b1d309 100644
--- a/main/libnih/APKBUILD
+++ b/main/libnih/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libnih
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="glib-like library for embedded use"
url="http://launchpad.net/libnih"
arch="all"
@@ -12,7 +12,9 @@ depends_dev="dbus-dev expat-dev gettext-dev"
makedepends="$depends_dev pkgconfig"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
+source="http://launchpad.net/libnih/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
+ musl-fix-signals.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -45,4 +47,9 @@ package() {
rm -f "$pkgdir"/lib/*.la
}
-md5sums="db7990ce55e01daffe19006524a1ccb0 libnih-1.0.3.tar.gz"
+md5sums="db7990ce55e01daffe19006524a1ccb0 libnih-1.0.3.tar.gz
+a2653e792f5d88faa31e5a4a23097150 musl-fix-signals.patch"
+sha256sums="897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405 libnih-1.0.3.tar.gz
+5d7d51e5ccd4e819bf04be4066717465b086f45a990e8a06372bcfe6a7ac11cc musl-fix-signals.patch"
+sha512sums="fce40d2445b28c27b8838631681ca3206a4f053b2dd4fc488fc9ef98bbd3d933e3d62b82cf346be2ef1677f6457f692cf5544cd915a6bb1e5c618f98ffa101b4 libnih-1.0.3.tar.gz
+77a979b3076c4e4229359f28c2e9d4fb66d799a66d60391ab6fd7e0dfe2a615b88330a979877b105293a95ed147546596eca174f52b75beca0457c49a017d040 musl-fix-signals.patch"
diff --git a/main/libnih/musl-fix-signals.patch b/main/libnih/musl-fix-signals.patch
new file mode 100644
index 000000000..97ef8196d
--- /dev/null
+++ b/main/libnih/musl-fix-signals.patch
@@ -0,0 +1,12 @@
+--- libnih-1.0.3.orig/nih/signal.c
++++ libnih-1.0.3/nih/signal.c
+@@ -87,7 +87,9 @@
+ { SIGSTKFLT, "STKFLT" },
+ #endif
+ { SIGCHLD, "CHLD" },
++#ifdef SIGCLD
+ { SIGCLD, "CLD" },
++#endif
+ { SIGCONT, "CONT" },
+ { SIGSTOP, "STOP" },
+ { SIGTSTP, "TSTP" },