summaryrefslogtreecommitdiffstats
path: root/testing/aalib
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-08-28 21:07:46 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commit6ec7b0c2a1326894f0eb8cdd8a48eec52a420ce2 (patch)
treeb3b516bf659638f96f6c0f71ffb7348bd5fb36e4 /testing/aalib
parent8cadc64a8e14a5233a57e458422a1826b682eb86 (diff)
downloadaports-6ec7b0c2a1326894f0eb8cdd8a48eec52a420ce2.tar.bz2
aports-6ec7b0c2a1326894f0eb8cdd8a48eec52a420ce2.tar.xz
Initial APKBUILD for aalib
Package description: AA-lib is a low level gfx library just as many other libraries are. The main difference is that AA-lib does not require graphics device. In fact, there is no graphical output possible. AA-lib replaces those old-fashioned output methods with powerful ascii- art renderer.
Diffstat (limited to 'testing/aalib')
-rw-r--r--testing/aalib/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/aalib/APKBUILD b/testing/aalib/APKBUILD
new file mode 100644
index 000000000..0b5872de1
--- /dev/null
+++ b/testing/aalib/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=aalib
+pkgver=1.4.0
+_pkgver=1.4
+pkgrel=0.rc4
+pkgdesc="An portable ascii art GFX library"
+url="http://aa-project.sourceforge.net/aalib/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/aa-project/$pkgname-"$_pkgver"rc4.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="d5aa8e9eae07b7441298b5c30490f6a6 aalib-1.4rc4.tar.gz"