summaryrefslogtreecommitdiffstats
path: root/testing/abook
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-31 21:43:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-20 10:27:28 +0000
commitabbf2f81a7a41c212e6f3585f3974d9335b411a1 (patch)
tree4b181ca817246313259abc63cc8fbec2fb8eddd3 /testing/abook
parentf11f2e1e67eb270787c7ee17cac51a93601edb8b (diff)
downloadaports-abbf2f81a7a41c212e6f3585f3974d9335b411a1.tar.bz2
aports-abbf2f81a7a41c212e6f3585f3974d9335b411a1.tar.xz
testing/abook: add $pkgname-lang
Diffstat (limited to 'testing/abook')
-rw-r--r--testing/abook/APKBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/testing/abook/APKBUILD b/testing/abook/APKBUILD
index 54f0256c1..591eb676a 100644
--- a/testing/abook/APKBUILD
+++ b/testing/abook/APKBUILD
@@ -1,33 +1,37 @@
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
-
pkgname=abook
pkgver=0.6.0_pre2
_ver=0.6.0pre2
-pkgrel=0
-pkgdesc='Text-based addressbook designed for use with Mutt'
-url='http://abook.sourceforge.net/'
-license='GPL2'
-arch='all'
-makedepends='libiconv-dev ncurses-dev readline-dev'
-subpackages="$pkgname-doc"
+pkgrel=1
+pkgdesc="Text-based addressbook designed for use with Mutt"
+url="http://abook.sourceforge.net"
+license="GPL2"
+arch="all"
+makedepends="libiconv-dev ncurses-dev readline-dev"
+subpackages="$pkgname-doc $pkgname-lang"
source="http://$pkgname.sourceforge.net/devel/$pkgname-${_ver}.tar.gz
vcard-compat.patch"
+_builddir=$srcdir/$pkgname-$_ver
prepare() {
- cd "$srcdir/$pkgname-$_ver"
+ cd "$_builddir"
patch -Np1 -i "$srcdir"/vcard-compat.patch
}
build() {
- cd "$srcdir/$pkgname-$_ver"
- ./configure --prefix=/usr --mandir=/usr/share/man
- make
+ cd "$_builddir"
+ ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+ make || return 1
}
package() {
- cd "$srcdir/$pkgname-$_ver"
- make DESTDIR="$pkgdir" install
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
}
md5sums="1e4a7210b3507db7b3d47ee7a2457934 abook-0.6.0pre2.tar.gz
c7c4972eab913483198d86697ecbbaa1 vcard-compat.patch"
+sha256sums="59d444504109dd96816e003b3023175981ae179af479349c34fa70bc12f6d385 abook-0.6.0pre2.tar.gz
+11ecc05519021fdf08da943fe2ea81e68abbc67e909e16abdc02cd639de5b5cc vcard-compat.patch"
+sha512sums="d1bc437981964a5dd873b12458833c60306d37b36904a04b072cefe7501175933dd7817ca51f8634bbd6722f79f768b39e00b68d0699086d5efaf28d0cbdf1ed abook-0.6.0pre2.tar.gz
+e51311c10f9bfe6e5c8feb65bf66856719d286aa497aad5e7ace7e5b81c5d36aea419e28f29eb24b4d9bd1b05a403914b71eab7d3e46316f6766ddae4237117e vcard-compat.patch"