summaryrefslogtreecommitdiffstats
path: root/testing/aha
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-20 07:33:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-20 10:27:32 +0000
commit578cf2bf58cbf5f9b1111115da3232f4de9fb4b0 (patch)
tree7f83a533918a945a4d7b50553945835d841c24e4 /testing/aha
parent02e5f36b567e42588998169eb9685423aa95b224 (diff)
downloadaports-578cf2bf58cbf5f9b1111115da3232f4de9fb4b0.tar.bz2
aports-578cf2bf58cbf5f9b1111115da3232f4de9fb4b0.tar.xz
testing/aha: fix it so it actually builds
Diffstat (limited to 'testing/aha')
-rw-r--r--testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch32
-rw-r--r--testing/aha/0001-Honor-common-compiler-and-linker-flags.patch33
-rw-r--r--testing/aha/APKBUILD18
3 files changed, 5 insertions, 78 deletions
diff --git a/testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch b/testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
deleted file mode 100644
index 67105bd81..000000000
--- a/testing/aha/0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From ed4f29b64b16bec894ae1865b8d0b70c3ab7f7c9 Mon Sep 17 00:00:00 2001
-From: Axel Beckert <abe@deuxchevaux.org>
-Date: Wed, 1 Aug 2012 18:03:25 +0200
-Subject: [PATCH] Fix several hyphen-used-as-minus-sign issues in the man page
-
----
- aha.1 | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/aha.1 b/aha.1
-index 52796fa..93af54a 100644
---- a/aha.1
-+++ b/aha.1
-@@ -43,13 +43,13 @@ Don't include header into generated HTML, useful for inclusion in full HTML file
-
- .SH EXAMPLE
- .TP
--\fBaha\fP \-\-help | \fBaha\fP \-\-black --title "the awesome aha help"> aha-help.htm
-+\fBaha\fP \-\-help | \fBaha\fP \-\-black \-\-title "the awesome aha help"> aha\-help.htm
- Creates an HTML file with the help of aha with black background
- .TP
- \fBcolordiff\fP oldfile.c newfile.c | \fBaha\fP > colordiff.htm
- Creates an HTML file with a colorful diff-output of two files "oldfile.c" and "newfile.c" with white background
- .TP
--\fBls\fP \--color=always | \fBaha\fP \-\-pink > ls.htm
-+\fBls\fP \-\-color=always | \fBaha\fP \-\-pink > ls.htm
- Creates an HTML file with a colorful ls-output with pink background.
- .TP
- \fBecho\fP q | \fBhtop\fP | \fBaha\fP \-\-black \-\-line\-fix > htop.htm
---
-1.7.10.4
-
diff --git a/testing/aha/0001-Honor-common-compiler-and-linker-flags.patch b/testing/aha/0001-Honor-common-compiler-and-linker-flags.patch
deleted file mode 100644
index 977dd6999..000000000
--- a/testing/aha/0001-Honor-common-compiler-and-linker-flags.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From bf5ed98a037d40bcec0e4fdc4550f7e41eb7e828 Mon Sep 17 00:00:00 2001
-From: Axel Beckert <abe@deuxchevaux.org>
-Date: Tue, 31 Jul 2012 13:31:32 +0200
-Subject: [PATCH] Honor common compiler and linker flags
-
----
- CHANGELOG | 2 ++
- Makefile | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/CHANGELOG b/CHANGELOG
-index 3472806..b4ef123 100644
---- a/CHANGELOG
-+++ b/CHANGELOG
-@@ -1,3 +1,5 @@
-+- Honor common compiler and linker flags
-+
- Version 0.4.6:
- - Added Feature for not creating a header e.g. for already existing HTML-files (thanks to Nicolas Zagulajew)
-
-diff --git a/Makefile b/Makefile
-index b880ba0..f113108 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,4 +1,4 @@
- all: aha
-
- aha: aha.c
-- gcc -std=c99 aha.c -o aha
-+ gcc -std=c99 $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) aha.c -o aha
---
-1.7.10.4
-
diff --git a/testing/aha/APKBUILD b/testing/aha/APKBUILD
index b51b053c4..a5156a56f 100644
--- a/testing/aha/APKBUILD
+++ b/testing/aha/APKBUILD
@@ -12,11 +12,9 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
-source="http://ftp.de.debian.org/debian/pool/main/a/aha/${pkgname}_$pkgver.orig.tar.gz
- 0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
- 0001-Honor-common-compiler-and-linker-flags.patch"
+source="http://ftp.de.debian.org/debian/pool/main/a/aha/${pkgname}_$pkgver.orig.tar.gz"
-_builddir="$srcdir"/$pkgname-$pkgvers
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
@@ -40,12 +38,6 @@ package() {
"$pkgdir"/usr/share/man/man1/aha.1 || return 1
}
-md5sums="97a9266932e84694d8afa79a27b49835 aha_0.4.6.1.orig.tar.gz
-1105a981ee4973945c2000874eeb289b 0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
-71425c7044c709848606054578f730da 0001-Honor-common-compiler-and-linker-flags.patch"
-sha256sums="799af2006523ad33ac3c9cc352701b4651d0e38395174f4a7c9d259cb31ce4e1 aha_0.4.6.1.orig.tar.gz
-f600098eaa513502bd50b05a8a35fab06f0d064b50983fe297a7323964a82933 0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
-72370b25b77b164eacdd748540718cbdbfbe0acf4c895a13f088071828dcefb2 0001-Honor-common-compiler-and-linker-flags.patch"
-sha512sums="5db2f22ee7a48c79a8e2556d66dbb8b5d1c5871f7e26deb7e1970e93d4422add8b12a6fa8aef381458af51a100e4572ab704329182eec2613d3fce4fd2971b5d aha_0.4.6.1.orig.tar.gz
-4b6210d5c7a12572e0d62b416086a2ebcb5e9bfa900f5a1c7b19d9c76ce0b55403e4629a753b416d5f01031ead4ec5519ec930f72aa55a25dacc18e9001cb181 0001-Fix-several-hyphen-used-as-minus-sign-issues-in-the-.patch
-c25e540d5627a01b3e195ceee50b9f33dab9937f5900b8e1807d0b9563aff2259867c4cd74c4a91491e615de6b6666318cc5e60178d81431dbf52b45b6d34874 0001-Honor-common-compiler-and-linker-flags.patch"
+md5sums="97a9266932e84694d8afa79a27b49835 aha_0.4.6.1.orig.tar.gz"
+sha256sums="799af2006523ad33ac3c9cc352701b4651d0e38395174f4a7c9d259cb31ce4e1 aha_0.4.6.1.orig.tar.gz"
+sha512sums="5db2f22ee7a48c79a8e2556d66dbb8b5d1c5871f7e26deb7e1970e93d4422add8b12a6fa8aef381458af51a100e4572ab704329182eec2613d3fce4fd2971b5d aha_0.4.6.1.orig.tar.gz"