summaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-backtrace/APKBUILD
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-01-07 12:09:45 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-09 11:50:24 +0000
commit00780f574164565d372cb9bcefcca3829279a5cf (patch)
treea5236d3ad3ee20341ccd2bd7681cdf02f0718529 /testing/apache-mod-backtrace/APKBUILD
parent2b3d0c1781a7f013366eb9e35bb0b9334cba8569 (diff)
downloadaports-00780f574164565d372cb9bcefcca3829279a5cf.tar.bz2
aports-00780f574164565d372cb9bcefcca3829279a5cf.tar.xz
new aport: testing/apache-mod-backtrace
A module which uses system functions to format a backtrace to show what code did the dirty deed. http://people.apache.org/~trawick/exception_hook.html
Diffstat (limited to 'testing/apache-mod-backtrace/APKBUILD')
-rw-r--r--testing/apache-mod-backtrace/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/apache-mod-backtrace/APKBUILD b/testing/apache-mod-backtrace/APKBUILD
new file mode 100644
index 000000000..4e4cf80d7
--- /dev/null
+++ b/testing/apache-mod-backtrace/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=apache-mod-backtrace
+pkgver=0
+pkgrel=0
+pkgdesc="A module which uses system functions to format a backtrace to show what code did the dirty deed."
+url="http://people.apache.org/~trawick/exception_hook.html"
+arch="all"
+license="Apache2.0"
+depends="apache2"
+makedepends="apache2-dev apr-dev libexecinfo autoconf"
+install=
+subpackages=
+source="http://people.apache.org/~trawick/mod_backtrace.c
+ configure.in
+ Makefile.in"
+
+build() {
+ cd "$srcdir"
+ autoconf
+ ./configure
+ make DESTDIR="$pkgdir" || return 1
+}
+
+package() {
+ cd "$srcdir"
+ install -D -m755 "$srcdir"/.libs/mod_backtrace.so "$pkgdir"/usr/lib/apache2/mod_backtrace.so
+}
+
+md5sums="cd5361da31b3c1401e29ccb6e5220f6b mod_backtrace.c
+623409fd18dea63d6da509f2818491ef configure.in
+8034836d7eae8094443702302a0dc6ab Makefile.in"