summaryrefslogtreecommitdiffstats
path: root/testing/array-info
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-08 06:17:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-08 06:17:44 +0000
commit78d1bd5b54f2efdb2c4541655e64eba03a7aaeaa (patch)
tree4ace6917fc8b938a46b968b5a1cdbfcce9430891 /testing/array-info
parent34426ec2256c24299da13a5a4f5b1dd51dabfa1e (diff)
downloadaports-78d1bd5b54f2efdb2c4541655e64eba03a7aaeaa.tar.bz2
aports-78d1bd5b54f2efdb2c4541655e64eba03a7aaeaa.tar.xz
testing/array-info: new aport
retrieve informations and status from RAID controllers http://array-info.sourceforge.net/
Diffstat (limited to 'testing/array-info')
-rw-r--r--testing/array-info/APKBUILD27
-rw-r--r--testing/array-info/array-info-makefile.patch20
2 files changed, 47 insertions, 0 deletions
diff --git a/testing/array-info/APKBUILD b/testing/array-info/APKBUILD
new file mode 100644
index 000000000..77719a9c3
--- /dev/null
+++ b/testing/array-info/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=array-info
+pkgver=0.16
+pkgrel=0
+pkgdesc="retrieve informations and status from RAID controllers"
+url="http://array-info.sourceforge.net/"
+license="GPL"
+arch="all"
+depends=
+makedepends="docbook-xsl gzip"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ local _xsl=$(echo /usr/share/xml/docbook/xsl-stylesheets-*/manpages/docbook.xsl)
+ make prefix=/usr DOCBOOK2XMAN="xsltproc --nonet $_xsl" \
+ #build_lib build_plugins abuild-info array-info.1.gz \
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make prefix=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="802e9be5e40a5a945956a123fc81f65f array-info_0.16.tar.gz"
diff --git a/testing/array-info/array-info-makefile.patch b/testing/array-info/array-info-makefile.patch
new file mode 100644
index 000000000..db7c18e45
--- /dev/null
+++ b/testing/array-info/array-info-makefile.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig Tue Dec 29 13:46:28 2009
++++ Makefile Tue Dec 29 13:47:38 2009
+@@ -1,5 +1,5 @@
+ DESTDIR =
+-prefix = /usr/local
++prefix = /usr
+ sbindir = $(prefix)/sbin
+ pkglibdir = $(prefix)/lib/array-info
+ mandir = $(prefix)/share/man
+@@ -8,8 +8,8 @@
+
+ INCLUDES = -I./include -I./linuxheaders
+
+-CFLAGS = -g2 -Wall $(INCLUDES) -DARRAY_PLUGIN_PATH=\"$(ARRAY_PLUGIN_PATH)\"
+-LDFLAGS = -L./lib -larray-info -ldl
++CFLAGS += -Wall $(INCLUDES) -DARRAY_PLUGIN_PATH=\"$(ARRAY_PLUGIN_PATH)\"
++LDFLAGS += -L./lib -larray-info -ldl
+ OBJS = array_plugin.o array_utils.o main.o
+
+ ARRAY_PLUGIN_PATH=$(pkglibdir)/plugins