summaryrefslogtreecommitdiffstats
path: root/testing/array-info
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-31 20:57:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-20 10:27:27 +0000
commit88029dccfbab2b88a633ced0c3f47573e09db3a1 (patch)
tree47839b7795a2ea45df82000078d5669f73a4a8a4 /testing/array-info
parent2bf795da38f27587dab174f235b8084f0b1dd6dd (diff)
downloadaports-88029dccfbab2b88a633ced0c3f47573e09db3a1.tar.bz2
aports-88029dccfbab2b88a633ced0c3f47573e09db3a1.tar.xz
testing/array-info: specify license
Diffstat (limited to 'testing/array-info')
-rw-r--r--testing/array-info/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/testing/array-info/APKBUILD b/testing/array-info/APKBUILD
index 77719a9c3..0ab10ffb6 100644
--- a/testing/array-info/APKBUILD
+++ b/testing/array-info/APKBUILD
@@ -1,27 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=array-info
pkgver=0.16
-pkgrel=0
-pkgdesc="retrieve informations and status from RAID controllers"
-url="http://array-info.sourceforge.net/"
-license="GPL"
+pkgrel=1
+pkgdesc="Retrieve informations and status from RAID controllers"
+url="http://sourceforge.net/projects/array-info/"
+license="GPL2+"
arch="all"
-depends=
+depends=""
makedepends="docbook-xsl gzip"
-install=
+install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
local _xsl=$(echo /usr/share/xml/docbook/xsl-stylesheets-*/manpages/docbook.xsl)
make prefix=/usr DOCBOOK2XMAN="xsltproc --nonet $_xsl" \
#build_lib build_plugins abuild-info array-info.1.gz \
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make prefix=/usr DESTDIR="$pkgdir" install
+ cd "$_builddir"
+ make prefix=/usr DESTDIR="$pkgdir" install || return 1
}
md5sums="802e9be5e40a5a945956a123fc81f65f array-info_0.16.tar.gz"
+sha256sums="800090f8d6008c60a5018e230071b6f5fc9b81f8a72d38dae3242cf1372eee3a array-info_0.16.tar.gz"
+sha512sums="a671a503cacf12e4cc5b62a3290b0483eb9b8f80923e051867e0afc5f9b06132e6b1c98f6188fe2cfe41ab7c0ead209dd0a3bd1559a7d72bf0a789c445c242ba array-info_0.16.tar.gz"