summaryrefslogtreecommitdiffstats
path: root/testing/awake
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 19:01:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:15 +0000
commit57b8de84a663c47061582c234dc306e00872c70f (patch)
treec888bb9ff114c2b2a49c4897420c76b382d2bdb7 /testing/awake
parentdac145e504d5bed58c6261408682502686597bc9 (diff)
downloadaports-57b8de84a663c47061582c234dc306e00872c70f.tar.bz2
aports-57b8de84a663c47061582c234dc306e00872c70f.tar.xz
testing/awake: split out python package
Diffstat (limited to 'testing/awake')
-rw-r--r--testing/awake/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/awake/APKBUILD b/testing/awake/APKBUILD
index a94712aad..2456dcc20 100644
--- a/testing/awake/APKBUILD
+++ b/testing/awake/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-awake
+pkgname=awake
_pkgname=awake
pkgver=1.0
pkgrel=0
@@ -12,7 +12,7 @@ depends="python"
depends_dev=""
makedepends="python-dev"
install=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc py-$pkgname:py"
source="$_pkgname-$pkgver.tar.gz::https://github.com/cyraxjoe/awake/archive/v$pkgver.tar.gz"
_builddir="$srcdir"/$_pkgname-$pkgver
@@ -36,6 +36,13 @@ package() {
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
+py() {
+ cd "$_builddir"
+ pkgdesc="$pkgname python bindings"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
doc() {
# Doc files
_docs="CHANGES LICENSE README"