summaryrefslogtreecommitdiffstats
path: root/testing/boost-coroutine
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-25 19:56:10 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-25 19:57:23 -0500
commit6e49e8ddee9bb07fc8013b2d40e4e013e2eb6c9f (patch)
tree5345fbb68beadae90b95570b6a29417e817e65d0 /testing/boost-coroutine
parent3bd23f9df2faafce93495c92f1231845e74a04a6 (diff)
downloadaports-6e49e8ddee9bb07fc8013b2d40e4e013e2eb6c9f.tar.bz2
aports-6e49e8ddee9bb07fc8013b2d40e4e013e2eb6c9f.tar.xz
testing/boost-coroutine: use GNU pth as uclibc does not provide ucontext functions
Diffstat (limited to 'testing/boost-coroutine')
-rw-r--r--testing/boost-coroutine/APKBUILD10
-rw-r--r--testing/boost-coroutine/boost-coroutine-pth.patch19
2 files changed, 25 insertions, 4 deletions
diff --git a/testing/boost-coroutine/APKBUILD b/testing/boost-coroutine/APKBUILD
index 8a25a34e1..9803a3309 100644
--- a/testing/boost-coroutine/APKBUILD
+++ b/testing/boost-coroutine/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer:
pkgname=boost-coroutine
pkgver=0.0.1
-pkgrel=0
+pkgrel=2
pkgdesc="coroutine library for boost"
url="http://www.crystalclearsoftware.com/soc/coroutine/"
arch="noarch"
license="custom:boost"
depends=
-depends_dev="boost-dev"
+depends_dev="boost-dev pth-dev"
install=""
-source="saveas-http://www.boostpro.com/vault/index.php?action=downloadfile&filename=boost-coroutine-2009-12-01.tar.gz&directory=Concurrent%20Programming/boost-coroutine-2009-12-01.tar.gz"
+source="saveas-http://www.boostpro.com/vault/index.php?action=downloadfile&filename=boost-coroutine-2009-12-01.tar.gz&directory=Concurrent%20Programming/boost-coroutine-2009-12-01.tar.gz
+ boost-coroutine-pth.patch"
_builddir="${srcdir}/boost-coroutine"
prepare() {
@@ -33,4 +34,5 @@ package() {
cp -r "$_builddir"/boost "$pkgdir"/usr/include/boost
}
-md5sums="9837f5f2024dfc4da68bf62e0aab529a boost-coroutine-2009-12-01.tar.gz"
+md5sums="9837f5f2024dfc4da68bf62e0aab529a boost-coroutine-2009-12-01.tar.gz
+53d3c4752668f0332dc31bd2341db609 boost-coroutine-pth.patch"
diff --git a/testing/boost-coroutine/boost-coroutine-pth.patch b/testing/boost-coroutine/boost-coroutine-pth.patch
new file mode 100644
index 000000000..3a6af66af
--- /dev/null
+++ b/testing/boost-coroutine/boost-coroutine-pth.patch
@@ -0,0 +1,19 @@
+--- boost-coroutine.orig/boost/coroutine/detail/context_posix.hpp
++++ boost-coroutine/boost/coroutine/detail/context_posix.hpp
+@@ -46,13 +46,10 @@
+ #include <boost/config.hpp>
+ #include <boost/assert.hpp>
+
+-#if defined(_XOPEN_UNIX) && defined(_XOPEN_VERSION) && _XOPEN_VERSION >= 500
++#if 1
++#if 1
+
+-// OS X 10.4 -- despite passing the test above -- doesn't support
+-// swapcontext() et al. Use GNU Pth workalike functions.
+-#if defined(__APPLE__) && (__ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__ < 1050)
+-
+-#include "pth/pth.h"
++#include <pth.h>
+ #include <cerrno>
+
+ namespace boost { namespace coroutines { namespace detail {