summaryrefslogtreecommitdiffstats
path: root/testing/boost-coroutine
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-25 14:13:28 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-25 14:13:28 -0500
commita635dd7f7bb7f10f46020256d9c35b247e0829e7 (patch)
treeef88ab058a54efe719a50da36371c73f7939027c /testing/boost-coroutine
parent2d2e02b94b10ee5b4c2afeb69667015f1fc9015f (diff)
downloadaports-a635dd7f7bb7f10f46020256d9c35b247e0829e7.tar.bz2
aports-a635dd7f7bb7f10f46020256d9c35b247e0829e7.tar.xz
testing/boost-coroutine: new aport
Diffstat (limited to 'testing/boost-coroutine')
-rw-r--r--testing/boost-coroutine/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/boost-coroutine/APKBUILD b/testing/boost-coroutine/APKBUILD
new file mode 100644
index 000000000..8a25a34e1
--- /dev/null
+++ b/testing/boost-coroutine/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=boost-coroutine
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="coroutine library for boost"
+url="http://www.crystalclearsoftware.com/soc/coroutine/"
+arch="noarch"
+license="custom:boost"
+depends=
+depends_dev="boost-dev"
+install=""
+source="saveas-http://www.boostpro.com/vault/index.php?action=downloadfile&filename=boost-coroutine-2009-12-01.tar.gz&directory=Concurrent%20Programming/boost-coroutine-2009-12-01.tar.gz"
+
+_builddir="${srcdir}/boost-coroutine"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/include
+ cp -r "$_builddir"/boost "$pkgdir"/usr/include/boost
+}
+
+md5sums="9837f5f2024dfc4da68bf62e0aab529a boost-coroutine-2009-12-01.tar.gz"