summaryrefslogtreecommitdiffstats
path: root/testing/chntpw
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-15 12:08:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-15 12:08:04 +0000
commit019c76895cc1a860aa50c116d1f040ebb6c058ff (patch)
tree6142bcfc1d088deab0ca6c6c20e4f029b9fb8b55 /testing/chntpw
parent6b6bbf34a6ebe2667f2c2b9dfcba906d80b9a010 (diff)
downloadaports-019c76895cc1a860aa50c116d1f040ebb6c058ff.tar.bz2
aports-019c76895cc1a860aa50c116d1f040ebb6c058ff.tar.xz
testing/chntpw: new aport
Change passwords in Windows SAM files http://pogostick.net/~pnh/ntpasswd/
Diffstat (limited to 'testing/chntpw')
-rw-r--r--testing/chntpw/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/chntpw/APKBUILD b/testing/chntpw/APKBUILD
new file mode 100644
index 000000000..a572d49bd
--- /dev/null
+++ b/testing/chntpw/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor:
+# Maintainer:
+pkgname=chntpw
+pkgver=110511
+pkgrel=0
+pkgdesc="Change passwords in Windows SAM files"
+url="http://pogostick.net/~pnh/ntpasswd/"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev openssl-dev"
+install=""
+subpackages=""
+source="http://pogostick.net/~pnh/ntpasswd/chntpw-source-$pkgver.zip"
+
+_builddir="$srcdir"/chntpw-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make CC="$CC" CFLAGS="$CFLAGS -DUSEOPENSSL" LIBS="-lcrypto" \
+ chntpw cpnt reged || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/bin
+ install chntpw cpnt reged "$pkgdir"/usr/bin/
+}
+
+md5sums="a3fb358d1adec589cd6bc8dedf68896c chntpw-source-110511.zip"