summaryrefslogtreecommitdiffstats
path: root/testing/deadbeef
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-14 18:09:57 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-14 18:09:57 -0500
commit810161c34aa0f5f6d38f6509cf2a03a31953383b (patch)
tree4da44761b101bee1704d958385539299824c391c /testing/deadbeef
parenta63a6be997d59b0a8bdadd3c1d1441c691d5e3ae (diff)
downloadaports-810161c34aa0f5f6d38f6509cf2a03a31953383b.tar.bz2
aports-810161c34aa0f5f6d38f6509cf2a03a31953383b.tar.xz
testing/deadbeef: upgrade to 0.5.0_rc1
Diffstat (limited to 'testing/deadbeef')
-rw-r--r--testing/deadbeef/APKBUILD18
-rw-r--r--testing/deadbeef/deadbeef-execinfo.patch29
-rw-r--r--testing/deadbeef/deadbeef-junklib.patch31
3 files changed, 16 insertions, 62 deletions
diff --git a/testing/deadbeef/APKBUILD b/testing/deadbeef/APKBUILD
index 10e453365..95c7de16f 100644
--- a/testing/deadbeef/APKBUILD
+++ b/testing/deadbeef/APKBUILD
@@ -1,22 +1,21 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=deadbeef
-pkgver=0.4.4
+pkgver=0.5.0_rc1
pkgrel=0
pkgdesc="fairly capable playlist-oriented audio player"
url="http://deadbeef.sourceforge.net/"
arch="all"
license="GPL"
depends=
-depends_dev="gtk+-dev libmad-dev alsa-lib-dev ffmpeg-dev libsamplerate-dev gettext-dev"
+depends_dev="gtk+-dev libmad-dev alsa-lib-dev ffmpeg-dev libsamplerate-dev gettext-dev libiconv-dev"
makedepends="$depends_dev intltool"
install=""
subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.bz2
- deadbeef-execinfo.patch
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-0.5.0-rc1.tar.bz2
deadbeef-junklib.patch"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
+_builddir="${srcdir}/${pkgname}-0.5.0-rc1"
prepare() {
local i
cd "$_builddir"
@@ -29,12 +28,10 @@ prepare() {
build() {
cd "$_builddir"
- LIBS="-lintl" ./configure --prefix=/usr \
+ LIBS="-lintl -lubacktrace" ./configure --prefix=/usr \
--sysconfdir=/etc \
--disable-sid \
--disable-ffap || return 1
- echo "#undef HAVE_ICONV" >> config.h
- echo "#define HAVE_ICONV 0" >> config.h
make || return 1
}
@@ -43,6 +40,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="546e63d456d6a5625461019b15501e38 deadbeef-0.4.4.tar.bz2
-0df7ea65269c41789b3b22520c7b0e0a deadbeef-execinfo.patch
-c0335b0d2561e4f7d594eaa3ba695ace deadbeef-junklib.patch"
+md5sums="ec8100402338d075ff39e714e99e5543 deadbeef-0.5.0-rc1.tar.bz2
+8bf4eb1c52f251da7c7a78b2bb021359 deadbeef-junklib.patch"
diff --git a/testing/deadbeef/deadbeef-execinfo.patch b/testing/deadbeef/deadbeef-execinfo.patch
deleted file mode 100644
index cd125d9d0..000000000
--- a/testing/deadbeef/deadbeef-execinfo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- deadbeef-0.4.4/main.c
-+++ deadbeef-0.4.4.mod/main.c
-@@ -38,7 +38,7 @@
- #include <sys/fcntl.h>
- #include <sys/errno.h>
- #include <signal.h>
--#ifdef __linux__
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
- #endif
- #ifdef HAVE_CONFIG_H
-@@ -450,7 +450,7 @@
- }
- #endif
-
--#ifdef __linux__
-+#ifdef HAVE_EXECINFO_H
- void
- sigsegv_handler (int sig) {
- fprintf (stderr, "Segmentation Fault\n");
-@@ -521,7 +521,7 @@
-
- int
- main (int argc, char *argv[]) {
--#ifdef __linux__
-+#ifdef HAVE_EXECINFO_H
- signal (SIGSEGV, sigsegv_handler);
- #endif
- setlocale (LC_ALL, "");
diff --git a/testing/deadbeef/deadbeef-junklib.patch b/testing/deadbeef/deadbeef-junklib.patch
index 948ce88de..63a29ca93 100644
--- a/testing/deadbeef/deadbeef-junklib.patch
+++ b/testing/deadbeef/deadbeef-junklib.patch
@@ -1,23 +1,10 @@
---- deadbeef-0.4.4.orig/junklib.c
-+++ deadbeef-0.4.4/junklib.c
-@@ -155,7 +155,7 @@
- int
- junk_iconv (const char *in, int inlen, char *out, int outlen, const char *cs_in, const char *cs_out) {
+--- deadbeef-0.5.0-rc1.orig/junklib.c
++++ deadbeef-0.5.0-rc1/junklib.c
+@@ -23,7 +23,6 @@
+ #include <stdlib.h>
+ #include <string.h>
#if HAVE_ICONV
-- iconv_t cd = iconv_open (cs_out, cs_in);
-+ iconv_t cd = libiconv_open (cs_out, cs_in);
- if (cd == (iconv_t)-1) {
- return -1;
- }
-@@ -171,9 +171,9 @@
- char *pout = out;
- memset (out, 0, outbytesleft);
-
-- size_t res = iconv (cd, &pin, &inbytesleft, &pout, &outbytesleft);
-+ size_t res = libiconv (cd, &pin, &inbytesleft, &pout, &outbytesleft);
- int err = errno;
-- iconv_close (cd);
-+ libiconv_close (cd);
-
- //trace ("iconv -f %s -t %s '%s': returned %d, inbytes %d/%d, outbytes %d/%d, errno=%d\n", cs_in, cs_out, in, res, inlen, inbytesleft, outlen, outbytesleft, err);
- if (res == -1) {
+- #define LIBICONV_PLUG
+ #include <iconv.h>
+ #elif HAVE_ICU
+ #warning icu