summaryrefslogtreecommitdiffstats
path: root/testing/dia
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-28 13:40:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-28 13:40:08 +0000
commita2fe915a153f2d22dd8496c474317b2aed3af926 (patch)
treee7d2dc017b0a36ee5730b4d635e671cb4b4401b8 /testing/dia
parente76db8bf7a5f085999a885e379f1e3923651228b (diff)
downloadaports-a2fe915a153f2d22dd8496c474317b2aed3af926.tar.bz2
aports-a2fe915a153f2d22dd8496c474317b2aed3af926.tar.xz
testing/dia: fix another isfinite
Diffstat (limited to 'testing/dia')
-rw-r--r--testing/dia/APKBUILD4
-rw-r--r--testing/dia/isfinite.patch46
2 files changed, 36 insertions, 14 deletions
diff --git a/testing/dia/APKBUILD b/testing/dia/APKBUILD
index 1cea1fd02..c23f67152 100644
--- a/testing/dia/APKBUILD
+++ b/testing/dia/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dia
pkgver=0.97.2
-pkgrel=0
+pkgrel=1
pkgdesc="a GTK+ based diagram creation program"
url="http://live.gnome.org/Dia"
arch="all"
@@ -45,4 +45,4 @@ package() {
md5sums="1e1180a513fb567709b09bc19f12105e dia-0.97.2.tar.xz
cbbc32d417297b855353f86b484b369b isinf.patch
-c5429dd3b25211811e343bc761d7af4c isfinite.patch"
+eda8e89483e97473d983b048f834861a isfinite.patch"
diff --git a/testing/dia/isfinite.patch b/testing/dia/isfinite.patch
index 796d4fda8..173b00046 100644
--- a/testing/dia/isfinite.patch
+++ b/testing/dia/isfinite.patch
@@ -1,5 +1,5 @@
diff --git a/lib/arrows.c b/lib/arrows.c
-index 4371946..389ef58 100644
+index 4371946..5b6cd3a 100644
--- a/lib/arrows.c
+++ b/lib/arrows.c
@@ -18,7 +18,7 @@
@@ -11,7 +11,7 @@ index 4371946..389ef58 100644
#include <math.h>
#include <stdio.h>
#include <string.h>
-@@ -29,11 +28,7 @@
+@@ -29,11 +29,7 @@
#ifdef G_OS_WIN32
#include <float.h>
@@ -24,7 +24,7 @@ index 4371946..389ef58 100644
#endif
#include "arrows.h"
-@@ -421,7 +416,7 @@ draw_one_exactly(DiaRenderer *renderer, Point *to, Point *from,
+@@ -421,7 +417,7 @@ draw_one_exactly(DiaRenderer *renderer, Point *to, Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -33,7 +33,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
point_get_perp(&vt,&vl);
-@@ -498,7 +493,7 @@ draw_one_or_none(DiaRenderer *renderer, Point *to, Point *from,
+@@ -498,7 +494,7 @@ draw_one_or_none(DiaRenderer *renderer, Point *to, Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -42,7 +42,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
point_get_perp(&vt,&vl);
-@@ -610,7 +605,7 @@ draw_fill_ellipse(DiaRenderer *renderer, Point *to, Point *from,
+@@ -610,7 +606,7 @@ draw_fill_ellipse(DiaRenderer *renderer, Point *to, Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -51,7 +51,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
point_get_perp(&vt,&vl);
-@@ -672,7 +667,7 @@ draw_empty_ellipse(DiaRenderer *renderer, Point *to, Point *from,
+@@ -672,7 +668,7 @@ draw_empty_ellipse(DiaRenderer *renderer, Point *to, Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -60,7 +60,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
-@@ -718,7 +713,7 @@ calculate_box (Point *poly, const Point *to, const Point *from,
+@@ -718,7 +714,7 @@ calculate_box (Point *poly, const Point *to, const Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -69,7 +69,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
point_get_perp(&vt,&vl);
-@@ -832,7 +827,7 @@ draw_fill_dot(DiaRenderer *renderer, Point *to, Point *from,
+@@ -832,7 +828,7 @@ draw_fill_dot(DiaRenderer *renderer, Point *to, Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -78,7 +78,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
point_get_perp(&vt,&vl);
-@@ -908,7 +903,7 @@ draw_integral(DiaRenderer *renderer, Point *to, Point *from,
+@@ -908,7 +904,7 @@ draw_integral(DiaRenderer *renderer, Point *to, Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -87,7 +87,7 @@ index 4371946..389ef58 100644
vl.x = 1.0; vl.y = 0.0;
}
point_get_perp(&vt,&vl);
-@@ -946,7 +941,7 @@ calculate_slashed (Point *poly, const Point *to, const Point *from,
+@@ -946,7 +942,7 @@ calculate_slashed (Point *poly, const Point *to, const Point *from,
else {
vl.x = 1.0; vl.y = 0.0;
}
@@ -97,7 +97,7 @@ index 4371946..389ef58 100644
}
point_get_perp(&vt,&vl);
diff --git a/lib/boundingbox.c b/lib/boundingbox.c
-index 6d2749f..c589334 100644
+index 6d2749f..6938537 100644
--- a/lib/boundingbox.c
+++ b/lib/boundingbox.c
@@ -21,7 +21,7 @@
@@ -109,7 +109,7 @@ index 6d2749f..c589334 100644
#include <math.h>
#include <string.h> /* memcmp() */
-@@ -510,7 +509,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
+@@ -510,7 +510,7 @@ polybezier_bbox(const BezPoint *pts, int numpoints,
real overshoot;
Point vovs,pto;
@@ -118,3 +118,25 @@ index 6d2749f..c589334 100644
overshoot = extra->middle_trans / sin(alpha/2.0);
else /* prependicular? */
overshoot = extra->middle_trans;
+diff --git a/objects/standard/arc.c b/objects/standard/arc.c
+index 28302a6..80674a3 100644
+--- a/objects/standard/arc.c
++++ b/objects/standard/arc.c
+@@ -21,7 +21,7 @@
+ #endif
+
+ #include <assert.h>
+-#define _BSD_SOURCE 1 /* to get finite */
++#define _GNU_SOURCE 1 /* to get finite */
+ #include <math.h>
+
+ #include "intl.h"
+@@ -407,7 +407,7 @@ arc_compute_midpoint(Arc *arc, const Point * ep0, const Point * ep1 , Point * mi
+ angle -= -atan2(oep0->y - arc->center.y, oep0->x - arc->center.x); /* minus angle of old */
+ angle += -atan2(ep1->y - arc->center.y, ep1->x - arc->center.x); /* plus angle of new */
+ angle -= -atan2(oep1->y - arc->center.y, oep1->x - arc->center.x); /* minus angle of old */
+- if (!finite(angle)){
++ if (!isfinite(angle)){
+ return 0;
+ }
+ if (angle < -1 * M_PI){