summaryrefslogtreecommitdiffstats
path: root/testing/empty
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-24 11:28:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-24 11:28:35 +0000
commit874a278f5de53ff3f92416da7a3a24831c351029 (patch)
treebb772d5e83a97c3a9afed355916b5290881ee111 /testing/empty
parente770add1c7f5eae6446970fcaac714402235a767 (diff)
downloadaports-874a278f5de53ff3f92416da7a3a24831c351029.tar.bz2
aports-874a278f5de53ff3f92416da7a3a24831c351029.tar.xz
testing/empty: new aport
run applications under pseudo-terminal (PTY) sessions http://empty.sourceforge.net/
Diffstat (limited to 'testing/empty')
-rw-r--r--testing/empty/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/empty/APKBUILD b/testing/empty/APKBUILD
new file mode 100644
index 000000000..0e43068a6
--- /dev/null
+++ b/testing/empty/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=empty
+pkgver=0.6.18b
+pkgrel=0
+pkgdesc="run applications under pseudo-terminal (PTY) sessions"
+url="http://empty.sourceforge.net/"
+license="BSD"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/empty/empty-$pkgver.tgz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D empty "$pkgdir"/usr/bin/empty
+ install -D empty.1 "$pkgdir"/usr/share/man/man1/empty.1
+}
+
+md5sums="2cf5e1b8ff58c41b63738bdc7c24fbc2 empty-0.6.18b.tgz"