summaryrefslogtreecommitdiffstats
path: root/testing/ettercap/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-10-25 11:10:54 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-10-25 11:11:31 +0000
commitd485a0b7a7259e67b841e8de251432a2d5c5b6b9 (patch)
tree53e129458083f06a156131e9853e80061ca4769b /testing/ettercap/APKBUILD
parent26689a8255c2429aa344b3c0c94ea9a9333eb0e4 (diff)
downloadaports-d485a0b7a7259e67b841e8de251432a2d5c5b6b9.tar.bz2
aports-d485a0b7a7259e67b841e8de251432a2d5c5b6b9.tar.xz
testing/ettercap: new aport
Comprehensive suite for man in the middle attacks
Diffstat (limited to 'testing/ettercap/APKBUILD')
-rw-r--r--testing/ettercap/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/ettercap/APKBUILD b/testing/ettercap/APKBUILD
new file mode 100644
index 000000000..c385381d3
--- /dev/null
+++ b/testing/ettercap/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=ettercap
+pkgver=0.7.4.1
+pkgrel=0
+pkgdesc="Comprehensive suite for man in the middle attacks"
+url="http://ettercap.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="autoconf automake bison flex libnet-dev libpcap-dev libtool
+ ncurses-dev openssl-dev pkgconfig"
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ ettercap-0.7.4-autotools.patch"
+
+
+_builddir="$srcdir"/$pkgname
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 < ../ettercap-0.7.4-autotools.patch
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-gtk \
+ --enable-plugins \
+ --enable-https
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="8e13ff5504b5bb4f1fc6a465d57ce7ea ettercap-0.7.4.1.tar.gz
+ec7418a5c21dcda2edae6e36fe7cad72 ettercap-0.7.4-autotools.patch"