summaryrefslogtreecommitdiffstats
path: root/testing/exfat-utils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-09-16 08:47:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-16 08:47:08 +0000
commitbb2046f73e50f33fc9cc0cc9f3c502ef4350c557 (patch)
treec5ed4472980e0e19332cef11c3f756351bb09ab2 /testing/exfat-utils
parent25397ba3f7dbd86b4cd6261cbb8f1e0759eca22e (diff)
downloadaports-bb2046f73e50f33fc9cc0cc9f3c502ef4350c557.tar.bz2
aports-bb2046f73e50f33fc9cc0cc9f3c502ef4350c557.tar.xz
testing/exfat-utils: new aport
Free exFAT file system implementation http://code.google.com/p/exfat/
Diffstat (limited to 'testing/exfat-utils')
-rw-r--r--testing/exfat-utils/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/exfat-utils/APKBUILD b/testing/exfat-utils/APKBUILD
new file mode 100644
index 000000000..3f321869f
--- /dev/null
+++ b/testing/exfat-utils/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=exfat-utils
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Free exFAT file system implementation"
+url="http://code.google.com/p/exfat/"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev scons"
+install=""
+subpackages=""
+source="http://exfat.googlecode.com/files/exfat-utils-$pkgver.tar.gz"
+
+_builddir="$srcdir"/exfat-utils-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ scons -j${JOBS:-2} || return 1
+
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/sbin
+ scons DESTDIR="$pkgdir"/sbin install || return 1
+}
+
+md5sums="e592130829d0bf61fa5e3cd1c759d329 exfat-utils-1.0.1.tar.gz"
+sha256sums="eeacedca1878065dc3886674ae39cd51149c37bd7d6d7e9325c971a1d1acdab3 exfat-utils-1.0.1.tar.gz"
+sha512sums="e2716e902110858e33e21395c45881315cbe469cf5192de130031ce989bdcb388944ad22d8588ae1a29d682615809be886086d313d5ab46b3aafa6d356a0e8ac exfat-utils-1.0.1.tar.gz"