summaryrefslogtreecommitdiffstats
path: root/testing/fotoxx
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-26 10:39:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-26 10:39:42 +0000
commitff54f1f738ef23950ee4deab322c14f146b0655d (patch)
treeedbefc0f8afcac8128f5fb2f46f696a7bc896499 /testing/fotoxx
parente18a27badf95d1329ab44c8fd52360004c012728 (diff)
downloadaports-ff54f1f738ef23950ee4deab322c14f146b0655d.tar.bz2
aports-ff54f1f738ef23950ee4deab322c14f146b0655d.tar.xz
testing/fotoxx: new aport
Photo editing and collection management http://kornelix.squarespace.com/fotoxx
Diffstat (limited to 'testing/fotoxx')
-rw-r--r--testing/fotoxx/APKBUILD39
-rw-r--r--testing/fotoxx/no-execinfo.patch65
2 files changed, 104 insertions, 0 deletions
diff --git a/testing/fotoxx/APKBUILD b/testing/fotoxx/APKBUILD
new file mode 100644
index 000000000..50b654558
--- /dev/null
+++ b/testing/fotoxx/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fotoxx
+pkgver=10.11.2
+pkgrel=0
+pkgdesc="Photo editing and collection management"
+url="http://kornelix.squarespace.com/fotoxx"
+arch="all"
+license="GPL-3"
+depends="xdg-utils"
+makedepends="gtk+-dev tiff-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://kornelix.squarespace.com/storage/downloads/fotoxx-$pkgver.tar.gz
+ no-execinfo.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr LDFLAGS="$LFDLAGS" CXXFLAGS="$CFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+md5sums="644d7a6675272ce47785de61ba22890c fotoxx-10.11.2.tar.gz
+2651f3e1a422f5dbfe2d09eb789af783 no-execinfo.patch"
diff --git a/testing/fotoxx/no-execinfo.patch b/testing/fotoxx/no-execinfo.patch
new file mode 100644
index 000000000..2c8195c9e
--- /dev/null
+++ b/testing/fotoxx/no-execinfo.patch
@@ -0,0 +1,65 @@
+diff --git a/zfuncs.cc b/zfuncs.cc
+index 0427f99..686b75a 100644
+--- a/zfuncs.cc
++++ b/zfuncs.cc
+@@ -45,12 +45,14 @@ void appcrash(cchar *pMess, ... )
+ va_end(arglist);
+
+ printf("appcrash: \n %s \n",message);
+-
++#ifndef __UCLIBC__
+ nstack = backtrace(stacklist,nstack); // good for g++ -rdynamic
+ stackents = backtrace_symbols(stacklist,nstack);
+ for (ii = 0; ii < nstack; ii++)
+ printf(" %s \n",stackents[ii]);
+-
++#else
++ printf("backtrace not available\n");
++#endif
+ abort(); // good for gdb backtrace
+ }
+
+@@ -105,11 +107,13 @@ void zappcrash(cchar *pMess, ... ) // v
+
+ printf("zappcrash: \n %s \n",message); // stdout message v.3.7
+
++#ifndef __UCLIBC__
+ nstack = backtrace(stacklist,nstack); // get traceback data
+ stackents = backtrace_symbols(stacklist,nstack);
+
+ for (ii = 0; ii < nstack; ii++) // stdout backtrace
+ printf(" %s \n",stackents[ii]);
++#endif
+
+ fid1 = fopen("zappcrash","w"); // text file for backtrace
+
+@@ -118,6 +122,7 @@ void zappcrash(cchar *pMess, ... ) // v
+ cc = readlink("/proc/self/exe",progexe,300); // get own program path
+ progexe[cc] = 0;
+
++#ifndef __UCLIBC__
+ for (ii = 0; ii < nstack; ii++) // output backtrace
+ {
+ pfunc = 0;
+@@ -137,6 +142,7 @@ void zappcrash(cchar *pMess, ... ) // v
+
+ fprintf(fid1," %s %s \n",stackents[ii],pfunc); // write to text file
+ }
++#endif
+
+ fclose(fid1);
+
+diff --git a/zfuncs.h b/zfuncs.h
+index 9ec9a6b..76b7b44 100644
+--- a/zfuncs.h
++++ b/zfuncs.h
+@@ -34,7 +34,9 @@
+ #include <pthread.h>
+ #include <errno.h>
+ #include <signal.h>
++#ifndef __UCLIBC__
+ #include <execinfo.h>
++#endif
+ #include <locale.h>
+ #include <sys/inotify.h>
+