summaryrefslogtreecommitdiffstats
path: root/testing/geany-plugins
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-06 09:01:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-06 09:01:39 +0000
commit73dd17638eb341748f14bf6dd570c49d348a0aa2 (patch)
tree04c643795270892dc4f4840a70ba32bf221918d0 /testing/geany-plugins
parentc5ec3e56b6b22b2ad822db094ae8597a3ddc4a5c (diff)
downloadaports-73dd17638eb341748f14bf6dd570c49d348a0aa2.tar.bz2
aports-73dd17638eb341748f14bf6dd570c49d348a0aa2.tar.xz
testing/geany-plugins: upgrade to 1.23
Diffstat (limited to 'testing/geany-plugins')
-rw-r--r--testing/geany-plugins/APKBUILD45
1 files changed, 35 insertions, 10 deletions
diff --git a/testing/geany-plugins/APKBUILD b/testing/geany-plugins/APKBUILD
index 7ef1f484f..80f2f063a 100644
--- a/testing/geany-plugins/APKBUILD
+++ b/testing/geany-plugins/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=geany-plugins
-pkgver=0.21
+pkgver=1.23
pkgrel=0
pkgdesc="Plugins for Geany"
url="http://plugins.geany.org/"
@@ -9,25 +9,35 @@ arch="all"
license="GPLv3+"
depends=
makedepends="lua-dev geany-dev enchant-dev intltool gtkspell-dev libxml2-dev
- bash"
+ bash vte-dev vala"
install=""
subpackages="$pkgname-doc
$pkgname-addons
$pkgname-codenav
+ $pkgname-commander
+ $pkgname-debugger
$pkgname-geanydoc
$pkgname-geanyextrasel
- $pkgname-geanygdb
$pkgname-geanyinsertnum
$pkgname-geanylatex
$pkgname-geanylipsum
$pkgname-geanylua
+ $pkgname-geanymacro
+ $pkgname-geanyminiscript
+ $pkgname-geanynumberedbookmarks
$pkgname-geanyprj
$pkgname-geanysendmail
$pkgname-geanyvc
- $pkgname-pretty-print:pretty_print
+ $pkgname-gproject
+ $pkgname-multiterm
+ $pkgname-pretty-printer:pretty_printer
+ $pkgname-scope
$pkgname-shiftcolumn
$pkgname-spellcheck
+ $pkgname-tableconvert
$pkgname-treebrowser
+ $pkgname-xmlsnippets
+
$pkgname-lang
"
@@ -51,6 +61,7 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
+ --with-lua-pkg=lua \
|| return 1
make || return 1
}
@@ -59,7 +70,8 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/*.la \
- "$pkgdir"/usr/lib/*/*.la
+ "$pkgdir"/usr/lib/geany-plugins/*/*.la \
+ "$pkgdir"/usr/lib/geany/*.la
}
_plugin() {
@@ -78,20 +90,33 @@ _plugin() {
addons() { _plugin addons "Miscellaneous Addons for Geany"; }
codenav() { _plugin codenav "Navigate through your source code easily"; }
+commander() { _plugin commander "Control Geany using commands from a command panel"; }
+debugger() { _plugin debugger "Debugger Plugin for Geany"; }
geanydoc() { _plugin geanydoc "Call documentation from within Geany"; }
geanyextrasel() { _plugin geanyextrasel "Additional features for selecting code"; }
-geanygdb() { _plugin geanygdb "Debugger Plugin for Geany using GDB"; }
geanyinsertnum() { _plugin geanyinsertnum "Insert huge number ranges with small efforts"; }
geanylatex() { _plugin geanylatex "LaTeX support for Geany"; }
geanylipsum() { _plugin geanylipsum "Lorem Ipsum generator for Inserting Placeholder Text"; }
geanylua() { _plugin geanylua "Lua Scripting for Geany"; }
+geanymacro() { _plugin geanymacro "User defined Macros for Geany"; }
+geanyminiscript() { _plugin geanyminiscript "Geany Mini-Script filter plugin"; }
+geanynumberedbookmarks() { _plugin geanynumberedbookmarks "Provide users 10 numbered Bookmarks"; }
geanyprj() { _plugin geanyprj "Alternate project management tool for Geany"; }
geanysendmail() { _plugin geanysendmail "Send E-Mails from within Geany"; }
geanyvc() { _plugin geanyvc "Version Control for Geany"; }
-pretty_print() { _plugin pretty-print "XML pretty printing plugin for Geany"; }
+gproject() { _plugin gproject "Extension of Geany's project management";
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
+}
+multiterm() { _plugin multiterm "Multiple terminals inside of Geany"; }
+pretty_printer() { _plugin pretty-printer "XML pretty printing plugin for Geany"; }
+scope() { _plugin scope "Graphical GDB front-end"; }
shiftcolumn() { _plugin shiftcolumn "Move Blocks of Text horizontally"; }
spellcheck() { _plugin spellcheck "Spellcheck text in Geany"; }
-treebrowser() { _plugin treebrowser "Alternate file browser plugin "; }
-
+tableconvert() { _plugin tableconvert "Helps on converting a tabulator separated selection into a table"; }
+treebrowser() { _plugin treebrowser "Alternate file browser plugin"; }
+xmlsnippets() { _plugin xmlsnippets "Extends XML/HTML tag autocompletion provided by Geany"; }
-md5sums="22e106d7a026e720dd91feb79e44456f geany-plugins-0.21.tar.bz2"
+md5sums="d851dbdaf95fb8b74ece43c0a973b748 geany-plugins-1.23.tar.bz2"
+sha256sums="ff26860edd1cbaea88c73bd8c2bd02f9ba04046674f05d3696baf66582e2bf58 geany-plugins-1.23.tar.bz2"
+sha512sums="6b8eab1b3cb0555aaf1a81714ddb6d9cb1c636e0a2839c476c3740bd9fe34851243fdbd5ef3cf52b6d30eb9536844d1504d2547740f8d1d1a6cb377e001be109 geany-plugins-1.23.tar.bz2"