summaryrefslogtreecommitdiffstats
path: root/testing/geany-plugins
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-09 18:59:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-09 19:01:36 +0000
commit77f469de35a03628d8de148cb4483da1283e660a (patch)
tree6053b39f731b7d7dbb85710dcc23b9fd2206d38d /testing/geany-plugins
parent24a39976b3b46fd2f52ce4a1553994d3a770f656 (diff)
downloadaports-77f469de35a03628d8de148cb4483da1283e660a.tar.bz2
aports-77f469de35a03628d8de148cb4483da1283e660a.tar.xz
testing/geany-plugins: new aport
Plugins for Geany http://plugins.geany.org/
Diffstat (limited to 'testing/geany-plugins')
-rw-r--r--testing/geany-plugins/APKBUILD95
1 files changed, 95 insertions, 0 deletions
diff --git a/testing/geany-plugins/APKBUILD b/testing/geany-plugins/APKBUILD
new file mode 100644
index 000000000..68a5398b4
--- /dev/null
+++ b/testing/geany-plugins/APKBUILD
@@ -0,0 +1,95 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=geany-plugins
+pkgver=0.20
+pkgrel=0
+pkgdesc="Plugins for Geany"
+url="http://plugins.geany.org/"
+arch="all"
+license="GPLv3+"
+depends=
+makedepends="lua-dev geany-dev enchant-dev intltool gtkspell-dev libxml2-dev"
+install=""
+subpackages="$pkgname-doc
+ $pkgname-addons
+ $pkgname-codenav
+ $pkgname-geanydoc
+ $pkgname-geanyextrasel
+ $pkgname-geanygdb
+ $pkgname-geanyinsertnum
+ $pkgname-geanylatex
+ $pkgname-geanylipsum
+ $pkgname-geanylua
+ $pkgname-geanyprj
+ $pkgname-geanysendmail
+ $pkgname-geanyvc
+ $pkgname-pretty-print:pretty_print
+ $pkgname-shiftcolumn
+ $pkgname-spellcheck
+ $pkgname-treebrowser
+ "
+
+source="http://plugins.geany.org/geany-plugins/geany-plugins-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/geany-plugins-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/*/*.la
+}
+
+_plugin() {
+ pkgdesc="$2"
+ local _d
+ mkdir -p "$subpkgdir"/usr/lib/geany
+ mv "$pkgdir"/usr/lib/geany/$1.so "$subpkgdir"/usr/lib/geany/ || return 1
+ cd "$pkgdir"
+ for _d in usr/*/geany-plugins/$1; do
+ if [ -d "$_d" ]; then
+ mkdir -p "$subpkgdir"/${_d%/*}
+ mv "$pkgdir"/$_d "$subpkgdir"/$_d
+ fi
+ done
+}
+
+addons() { _plugin addons "Miscellaneous Addons for Geany"; }
+codenav() { _plugin codenav "Navigate through your source code easily"; }
+geanydoc() { _plugin geanydoc "Call documentation from within Geany"; }
+geanyextrasel() { _plugin geanyextrasel "Additional features for selecting code"; }
+geanygdb() { _plugin geanygdb "Debugger Plugin for Geany using GDB"; }
+geanyinsertnum() { _plugin geanyinsertnum "Insert huge number ranges with small efforts"; }
+geanylatex() { _plugin geanylatex "LaTeX support for Geany"; }
+geanylipsum() { _plugin geanylipsum "Lorem Ipsum generator for Inserting Placeholder Text"; }
+geanylua() { _plugin geanylua "Lua Scripting for Geany"; }
+geanyprj() { _plugin geanyprj "Alternate project management tool for Geany"; }
+geanysendmail() { _plugin geanysendmail "Send E-Mails from within Geany"; }
+geanyvc() { _plugin geanyvc "Version Control for Geany"; }
+pretty_print() { _plugin pretty-print "XML pretty printing plugin for Geany"; }
+shiftcolumn() { _plugin shiftcolumn "Move Blocks of Text horizontally"; }
+spellcheck() { _plugin spellcheck "Spellcheck text in Geany"; }
+treebrowser() { _plugin treebrowser "Alternate file browser plugin "; }
+
+
+md5sums="94bc4901217641a07f840d92179643b0 geany-plugins-0.20.tar.bz2"