summaryrefslogtreecommitdiffstats
path: root/testing/gnash
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-03-30 02:48:41 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-03-30 02:49:11 -0500
commit9aa577b7700b60d000483b0551a9f53b8e937212 (patch)
treee131baca374fa56e9e546835ba3653e7ae34c3dd /testing/gnash
parent6185e1ece14658b5d6ca7ac80a5567eed10565ae (diff)
downloadaports-9aa577b7700b60d000483b0551a9f53b8e937212.tar.bz2
aports-9aa577b7700b60d000483b0551a9f53b8e937212.tar.xz
testing/gnash: new aport
Diffstat (limited to 'testing/gnash')
-rw-r--r--testing/gnash/APKBUILD66
-rw-r--r--testing/gnash/gnash-ffmpeg.patch24
2 files changed, 90 insertions, 0 deletions
diff --git a/testing/gnash/APKBUILD b/testing/gnash/APKBUILD
new file mode 100644
index 000000000..c3cd91b6e
--- /dev/null
+++ b/testing/gnash/APKBUILD
@@ -0,0 +1,66 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gnash
+pkgver=0.8.9
+pkgrel=0
+pkgdesc="GNU flash player implementation"
+url="http://www.gnashdev.org/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="agg-dev cairo-dev gstreamer-dev gst-plugins-base-dev
+ ffmpeg-dev mesa-dev gtk+-dev sdl-dev boost-dev giflib-dev
+ speex-dev libxml2-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc $pkgname-dev $pkgname-mozilla $pkgname-sdl $pkgname-fb"
+source="http://mirrors.igsobe.com/gnu/gnash/$pkgver/gnash-$pkgver.tar.gz
+ gnash-ffmpeg.patch"
+
+_builddir="$srcdir"/gnash-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sdl() {
+ pkgdesc="$pkgdesc (sdl player)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/sdl-gnash "$subpkgdir"/usr/bin
+}
+
+fb() {
+ pkgdesc="$pkgdesc (framebuffer player)"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/fb-gnash "$subpkgdir"/usr/bin
+}
+
+mozilla() {
+ pkgdesc="$pkgdesc (mozilla plugin)"
+ mkdir -p "$subpkgdir"/usr/lib/mozilla/plugins
+ mv "$_builddir"/plugin/npapi/.libs/libgnashplugin.so "$subpkgdir"/usr/lib/mozilla/plugins
+}
+
+md5sums="01d0420932eede07211e368d405aee9c gnash-0.8.9.tar.gz
+b324b3fee1e017d8fcc4d991146266f8 gnash-ffmpeg.patch"
diff --git a/testing/gnash/gnash-ffmpeg.patch b/testing/gnash/gnash-ffmpeg.patch
new file mode 100644
index 000000000..dc78e81c5
--- /dev/null
+++ b/testing/gnash/gnash-ffmpeg.patch
@@ -0,0 +1,24 @@
+--- gnash-0.8.9.orig/libmedia/ffmpeg/MediaParserFfmpeg.cpp
++++ gnash-0.8.9/libmedia/ffmpeg/MediaParserFfmpeg.cpp
+@@ -52,8 +52,8 @@
+ return p->readPacket(buf, buf_size);
+ }
+
+-boost::int64_t
+-MediaParserFfmpeg::seekMediaWrapper(void *opaque, boost::int64_t offset, int whence)
++::int64_t
++MediaParserFfmpeg::seekMediaWrapper(void *opaque, ::int64_t offset, int whence)
+ {
+ MediaParserFfmpeg* p = static_cast<MediaParserFfmpeg*>(opaque);
+ return p->seekMedia(offset, whence);
+--- gnash-0.8.9.orig/libmedia/ffmpeg/MediaParserFfmpeg.h
++++ gnash-0.8.9/libmedia/ffmpeg/MediaParserFfmpeg.h
+@@ -126,7 +126,7 @@
+ boost::int64_t seekMedia(boost::int64_t offset, int whence);
+
+ /// ffmpeg callback function
+- static boost::int64_t seekMediaWrapper(void *opaque, boost::int64_t offset, int whence);
++ static int64_t seekMediaWrapper(void *opaque, int64_t offset, int whence);
+
+ /// Read some of the input to figure an AVInputFormat
+ AVInputFormat* probeStream();