summaryrefslogtreecommitdiffstats
path: root/testing/hexcurse
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-06-10 11:53:08 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-06-10 11:53:22 +0000
commitadf5a3941cb6c63dd5e99470c7e5e5339aece434 (patch)
tree1410d9cfc24996d968c658003f544a03441c5329 /testing/hexcurse
parentc386d3f482eb65e4df67aefffe21d0bb4f04d6fa (diff)
downloadaports-adf5a3941cb6c63dd5e99470c7e5e5339aece434.tar.bz2
aports-adf5a3941cb6c63dd5e99470c7e5e5339aece434.tar.xz
testing/hexcurse: new aport
Diffstat (limited to 'testing/hexcurse')
-rw-r--r--testing/hexcurse/APKBUILD46
-rw-r--r--testing/hexcurse/hexcurse-alloca.patch14
2 files changed, 60 insertions, 0 deletions
diff --git a/testing/hexcurse/APKBUILD b/testing/hexcurse/APKBUILD
new file mode 100644
index 000000000..7bf023913
--- /dev/null
+++ b/testing/hexcurse/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=hexcurse
+pkgver=1.55
+pkgrel=0
+pkgdesc="Versatile ncurses-based hex editor"
+url="http://directory.fsf.org/project/HexCurse"
+arch="all"
+license="GPL"
+depends=
+depends_dev="ncurses-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/hexcurse-$pkgver.tar.gz
+ hexcurse-alloca.patch"
+
+_builddir="$srcdir"/hexcurse-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="c9f9485490300b5111aa429eabfef789 hexcurse-1.55.tar.gz
+5aae74a76923ee8e4fe033e0aa381a82 hexcurse-alloca.patch"
diff --git a/testing/hexcurse/hexcurse-alloca.patch b/testing/hexcurse/hexcurse-alloca.patch
new file mode 100644
index 000000000..2ea060f2d
--- /dev/null
+++ b/testing/hexcurse/hexcurse-alloca.patch
@@ -0,0 +1,14 @@
+--- hexcurse/src/getopt.c 2002-03-21 17:55:54.000000000 +0100
++++ hexcurse/src/getopt.c 2004-08-09 12:52:39.592951560 +0200
+@@ -36,8 +36,8 @@
+ * enables hexcurse to be compiled with SGI's proprietary compiler */
+ #ifdef _SGIAPI
+ #include <alloca.h>
+-#else
+-char *alloca ();
++//#else
++//char *alloca ();
+ #endif
+ #define __alloca alloca
+ /* end of modification */
+