summaryrefslogtreecommitdiffstats
path: root/testing/ifupdown
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-13 11:20:02 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-13 11:20:02 -0600
commita7453a07290838947e08fd1bc927f7a116e561c0 (patch)
tree69f94144d5c1ccd885dc20f8550162f4cc9a181a /testing/ifupdown
parent667583cce4da29fe4320de4805c1bd14c2c337ed (diff)
downloadaports-a7453a07290838947e08fd1bc927f7a116e561c0.tar.bz2
aports-a7453a07290838947e08fd1bc927f7a116e561c0.tar.xz
testing/ifupdown: busybox uses -f instead of --force so allow both
Diffstat (limited to 'testing/ifupdown')
-rw-r--r--testing/ifupdown/APKBUILD8
-rw-r--r--testing/ifupdown/ifupdown-busybox-compat.patch38
2 files changed, 43 insertions, 3 deletions
diff --git a/testing/ifupdown/APKBUILD b/testing/ifupdown/APKBUILD
index 31fb37ce0..9c4719724 100644
--- a/testing/ifupdown/APKBUILD
+++ b/testing/ifupdown/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=ifupdown
pkgver=0.6.10
-pkgrel=0
+pkgrel=1
pkgdesc="high level tools to configure network interfaces"
url="http://packages.debian.org/ifupdown"
arch="all"
@@ -12,7 +12,8 @@ depends_dev=
makedepends=
install="$pkgname.post-deinstall $pkgname.post-upgrade"
subpackages=
-source="http://ftp.debian.org/pool/main/i/$pkgname/${pkgname}_$pkgver.tar.gz"
+source="http://ftp.debian.org/pool/main/i/$pkgname/${pkgname}_$pkgver.tar.gz
+ ifupdown-busybox-compat.patch"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -35,4 +36,5 @@ package() {
make BASEDIR="$pkgdir" install || return 1
}
-md5sums="70db0d8caf06a17d65b612fa8919732b ifupdown_0.6.10.tar.gz"
+md5sums="70db0d8caf06a17d65b612fa8919732b ifupdown_0.6.10.tar.gz
+b0f42f7ce1a4f416eddaa304db2d270e ifupdown-busybox-compat.patch"
diff --git a/testing/ifupdown/ifupdown-busybox-compat.patch b/testing/ifupdown/ifupdown-busybox-compat.patch
new file mode 100644
index 000000000..10d4ceeaa
--- /dev/null
+++ b/testing/ifupdown/ifupdown-busybox-compat.patch
@@ -0,0 +1,38 @@
+--- ifupdown-0.6.10.orig/main.c
++++ ifupdown-0.6.10/main.c
+@@ -61,7 +61,7 @@
+ printf("\t\t\t\t(note that this option doesn't disable mappings)\n");
+ printf("\t-v, --verbose\t\tprint out what would happen before doing it\n");
+ printf("\t--no-mappings\t\tdon't run any mappings\n");
+- printf("\t--force\t\t\tforce de/configuration\n");
++ printf("\t-f, --force\t\t\tforce de/configuration\n");
+ exit(0);
+ }
+ #line 3573 "ifupdown.nw"
+@@ -345,7 +345,7 @@
+ {"exclude", required_argument, NULL, 'e'},
+ {"no-act", no_argument, NULL, 'n'},
+ {"no-mappings", no_argument, NULL, 1 },
+- {"force", no_argument, NULL, 2 },
++ {"force", no_argument, NULL, 'f'},
+ {0,0,0,0}
+ };
+ #line 3173 "ifupdown.nw"
+@@ -415,7 +415,7 @@
+ #line 3235 "ifupdown.nw"
+ for(;;) {
+ int c;
+- c = getopt_long(argc, argv, "e:s:i:hVvna", long_opts, NULL);
++ c = getopt_long(argc, argv, "e:s:i:hVvnaf", long_opts, NULL);
+ if (c == EOF) break;
+
+ switch(c) {
+@@ -445,7 +445,7 @@
+ run_mappings = 0;
+ break;
+ #line 3283 "ifupdown.nw"
+-case 2:
++case 'f':
+ force = 1;
+ break;
+ #line 3288 "ifupdown.nw"