summaryrefslogtreecommitdiffstats
path: root/testing/ipt-netflow-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-14 07:30:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-14 07:52:22 +0000
commit2e229842647775e2c19f1742d1f7ee872ca67841 (patch)
tree1d427c4cf23ad5640334a76e173aed4cdb456fb5 /testing/ipt-netflow-grsec
parenta1cf54a3c50497e18ae1a7360f9de17edca18bad (diff)
downloadaports-2e229842647775e2c19f1742d1f7ee872ca67841.tar.bz2
aports-2e229842647775e2c19f1742d1f7ee872ca67841.tar.xz
testing/ipt-netflow-grsec: rebuild against kernel 3.9.2-r0
Diffstat (limited to 'testing/ipt-netflow-grsec')
-rw-r--r--testing/ipt-netflow-grsec/0001-Fix-compilation-with-3.9.y-kernel.patch28
-rw-r--r--testing/ipt-netflow-grsec/APKBUILD6
2 files changed, 33 insertions, 1 deletions
diff --git a/testing/ipt-netflow-grsec/0001-Fix-compilation-with-3.9.y-kernel.patch b/testing/ipt-netflow-grsec/0001-Fix-compilation-with-3.9.y-kernel.patch
new file mode 100644
index 000000000..f3cbfae42
--- /dev/null
+++ b/testing/ipt-netflow-grsec/0001-Fix-compilation-with-3.9.y-kernel.patch
@@ -0,0 +1,28 @@
+From 2f4b540bb2e60aca47263cf0fd2b3abc0a499d87 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 14 May 2013 07:25:47 +0000
+Subject: [PATCH] Fix compilation with 3.9.y kernel
+
+use new hlist_for_each api
+---
+ ipt_NETFLOW.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/ipt_NETFLOW.c b/ipt_NETFLOW.c
+index d4c91e1..4e1b9f3 100644
+--- a/ipt_NETFLOW.c
++++ b/ipt_NETFLOW.c
+@@ -854,9 +854,7 @@ static struct ipt_netflow *
+ ipt_netflow_find(const struct ipt_netflow_tuple *tuple, unsigned int hash)
+ {
+ struct ipt_netflow *nf;
+- struct hlist_node *pos;
+-
+- hlist_for_each_entry(nf, pos, &ipt_netflow_hash[hash], hlist) {
++ hlist_for_each_entry(nf, &ipt_netflow_hash[hash], hlist) {
+ if (ipt_netflow_tuple_equal(tuple, &nf->tuple) &&
+ nf->nr_bytes < FLOW_FULL_WATERMARK) {
+ NETFLOW_STAT_INC(found);
+--
+1.8.2.2
+
diff --git a/testing/ipt-netflow-grsec/APKBUILD b/testing/ipt-netflow-grsec/APKBUILD
index cd629a121..0887bd1be 100644
--- a/testing/ipt-netflow-grsec/APKBUILD
+++ b/testing/ipt-netflow-grsec/APKBUILD
@@ -3,7 +3,7 @@
_flavor=grsec
_kpkg=linux-$_flavor
-_kver=3.8.12
+_kver=3.9.2
_kpkgrel=0
# when chaning _ver we *must* bump _mypkgrel
@@ -31,6 +31,7 @@ url="http://ipt-netflow.sourceforge.net/"
arch="all"
license=GPL-2
source="ipt-netflow-$_ver.tar.gz::https://github.com/RushOnline/ipt-netflow/archive/v$_ver.tar.gz
+ 0001-Fix-compilation-with-3.9.y-kernel.patch
constify.patch"
depends="$_kpkg-dev=$_kpkgver"
makedepends="linux-${_flavor}-dev=$_kpkgver iptables-dev bash"
@@ -66,8 +67,11 @@ dev() {
}
md5sums="a5d564dd5f30d5b61a93decf29e3a208 ipt-netflow-1.8.4.tar.gz
+b300776001b3cc8448ec4019ac9e3b2e 0001-Fix-compilation-with-3.9.y-kernel.patch
2d9335c3d5c32c1e18a67fbb83018bae constify.patch"
sha256sums="bb2446a0b16aa7f6052599410c2b4ce184d40893ec2ca12756f3bcb341890f43 ipt-netflow-1.8.4.tar.gz
+f1f5d33c4f000e22c34a954856ef7d23c24106465c61209c0267f76c7d49011b 0001-Fix-compilation-with-3.9.y-kernel.patch
5a86c64bdc536bddb780ebaa4aa5fe3bede93d645ed0f00afb41f23314662d1f constify.patch"
sha512sums="e15ad33b4b3df9e1e53fbac6334dbe08802d66f4850cbf489d7a60184cdb47d94448ae13480d586474a6bec6204680d059543b619ae40a0f74fad22fed1b024a ipt-netflow-1.8.4.tar.gz
+ae42d882ff10f4f8062ca4e2ad9cb2b5bfd05dfde829ffa23b683ee9dcb9aa9063b391171e07f61f6d0d158f1c35e381236e625b7ecaf8192fc6c5964acb6bb8 0001-Fix-compilation-with-3.9.y-kernel.patch
08835d3de5925d868b70c240e65094a9262c5871d7ca0290001697cf8b7cee74bfc8ac2897b30c3d5ec89700b329d30b539699596f15c1150e18a85234484758 constify.patch"