summaryrefslogtreecommitdiffstats
path: root/testing/jemalloc
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 21:28:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:15 +0000
commit048e21753f5be9a3b4bd914fcfb2d1f6974ba9b5 (patch)
tree645be915c76ac22d5f80fe90617978a6e0e58d41 /testing/jemalloc
parent299908203feda897ae7c3556ed81bc52f44cdf11 (diff)
downloadaports-048e21753f5be9a3b4bd914fcfb2d1f6974ba9b5.tar.bz2
aports-048e21753f5be9a3b4bd914fcfb2d1f6974ba9b5.tar.xz
testing/jemalloc: new aport
A general purpose malloc(3) implementation http://www.canonware.com/jemalloc/
Diffstat (limited to 'testing/jemalloc')
-rw-r--r--testing/jemalloc/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/jemalloc/APKBUILD b/testing/jemalloc/APKBUILD
new file mode 100644
index 000000000..e4cf02a40
--- /dev/null
+++ b/testing/jemalloc/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=jemalloc
+pkgver=3.4.0
+pkgrel=0
+pkgdesc="A general purpose malloc(3) implementation"
+url="http://www.canonware.com/jemalloc/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.canonware.com/download/jemalloc/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="c4fa3da0096d5280924a5f7ebc8dbb1c jemalloc-3.4.0.tar.bz2"
+sha256sums="f60802c4c2c60bc24598fd052494aea96f4426f3d4decd832eadeed520ff81c0 jemalloc-3.4.0.tar.bz2"
+sha512sums="8727e13d5e1d677eeaaba50a33ad8eb3dca09f4e90639cf2957d6be0728fd962f10184e91f404b8c9985e680128a838375b122451601271653c8c6d6386a252b jemalloc-3.4.0.tar.bz2"