summaryrefslogtreecommitdiffstats
path: root/testing/kdesdk
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-05-10 12:11:59 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-05-10 12:11:59 -0500
commit13658f193f843947e8825cf8acf9fa95f7287b56 (patch)
tree0f769349336e481e85015be5c863d21b59e21057 /testing/kdesdk
parentcf86b2d5c728f06fe1cb8aa2f9bf9d7db2077172 (diff)
downloadaports-13658f193f843947e8825cf8acf9fa95f7287b56.tar.bz2
aports-13658f193f843947e8825cf8acf9fa95f7287b56.tar.xz
testing/kdesdk: new aport
Diffstat (limited to 'testing/kdesdk')
-rw-r--r--testing/kdesdk/APKBUILD42
-rw-r--r--testing/kdesdk/not-glibc.patch12
2 files changed, 54 insertions, 0 deletions
diff --git a/testing/kdesdk/APKBUILD b/testing/kdesdk/APKBUILD
new file mode 100644
index 000000000..f259f6be6
--- /dev/null
+++ b/testing/kdesdk/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=kdesdk
+pkgver=4.6.3
+pkgrel=0
+pkgdesc="software development tools for kde"
+url="http://www.kde.org/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="kdebase-workspace-dev hunspell-dev boost-dev perl-dev subversion-dev"
+makedepends="$depends_dev cmake automoc4"
+install=""
+subpackages="$pkgname-dev"
+source="http://kde.mirrors.tds.net/pub/kde/stable/$pkgver/src/kdesdk-$pkgver.tar.bz2
+ not-glibc.patch"
+
+_builddir="$srcdir"/kdesdk-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PATH=/usr -DCMAKE_SKIP_RPATH=ON "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="c4a223067a228688c6b62a6bdd67a022 kdesdk-4.6.3.tar.bz2
+00e1451447f9097a677c4606484077ca not-glibc.patch"
diff --git a/testing/kdesdk/not-glibc.patch b/testing/kdesdk/not-glibc.patch
new file mode 100644
index 000000000..646efb4f9
--- /dev/null
+++ b/testing/kdesdk/not-glibc.patch
@@ -0,0 +1,12 @@
+--- kdesdk-4.6.3.orig/CMakeLists.txt
++++ kdesdk-4.6.3/CMakeLists.txt
+@@ -71,9 +71,7 @@
+ #include <stdlib.h>
+
+ int main() {
+-#ifndef __GLIBC__
+ choke me
+-#endif
+ return 0;
+ }" LIBC_IS_GLIBC)
+ if (LIBC_IS_GLIBC)