summaryrefslogtreecommitdiffstats
path: root/testing/libreswan
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-19 15:30:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-19 15:31:13 +0000
commitdcf6ad434ce58db0d32d371aca40f0604039cdbe (patch)
tree653cd247e27a45ecaf8a1beb57f4a238d36ad62a /testing/libreswan
parent1aaf47d7aecbf7b029ce230e078f1e0c3cb31d88 (diff)
downloadaports-dcf6ad434ce58db0d32d371aca40f0604039cdbe.tar.bz2
aports-dcf6ad434ce58db0d32d371aca40f0604039cdbe.tar.xz
testing/libreswan: fix typo in init.d script and add iproute2 as dep
ref #1852
Diffstat (limited to 'testing/libreswan')
-rw-r--r--testing/libreswan/APKBUILD25
-rw-r--r--testing/libreswan/openrc.patch26
2 files changed, 45 insertions, 6 deletions
diff --git a/testing/libreswan/APKBUILD b/testing/libreswan/APKBUILD
index 8745bdfc1..b9f1938cf 100644
--- a/testing/libreswan/APKBUILD
+++ b/testing/libreswan/APKBUILD
@@ -2,18 +2,28 @@
pkgname=libreswan
pkgver=3.6
-pkgrel=0
+pkgrel=1
pkgdesc="IPsec implementation for Linux"
url="https://libreswan.org"
arch="all"
license="GPLv2"
-depends="nss-tools"
+depends="nss-tools iproute2"
depends_dev="gmp-dev linux-pam-dev nss-dev unbound-dev libcap-ng-dev curl-dev nspr-dev"
makedepends="$depends_dev bison flex pkgconf coreutils bash"
subpackages="$pkgname-doc"
-source="https://download.libreswan.org/libreswan-$pkgver.tar.gz"
+source="https://download.libreswan.org/libreswan-$pkgver.tar.gz
+ openrc.patch"
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
make INC_RCDEFAULT=/etc/init.d \
@@ -34,6 +44,9 @@ package() {
FINALLIBEXECDIR=/usr/libexec/ipsec \
install || return 1
}
-md5sums="6c6f0ffec329e09d2d7fa24ae102c69b libreswan-3.6.tar.gz"
-sha256sums="50e7fdeccd9626bab15c47d69f78dbfce108c7cb583957d9f7b1559db9d5ee92 libreswan-3.6.tar.gz"
-sha512sums="3eb0a8de0ae271a6036656a1b02600c02c2e4ee484128a7d6e5e170cbe0edc26010576201ecc9cc7ce88ad6f9292d42a8755f9c07720d7d9af2e4ed6e308532b libreswan-3.6.tar.gz"
+md5sums="6c6f0ffec329e09d2d7fa24ae102c69b libreswan-3.6.tar.gz
+7feffc23906671e6bf5d653355a21b6e openrc.patch"
+sha256sums="50e7fdeccd9626bab15c47d69f78dbfce108c7cb583957d9f7b1559db9d5ee92 libreswan-3.6.tar.gz
+b86a2ec9111c071446b83d446a72149d0540e0c9b3a76776f60b2354624a2c2f openrc.patch"
+sha512sums="3eb0a8de0ae271a6036656a1b02600c02c2e4ee484128a7d6e5e170cbe0edc26010576201ecc9cc7ce88ad6f9292d42a8755f9c07720d7d9af2e4ed6e308532b libreswan-3.6.tar.gz
+223b730e1ced8086e5361435f2d5bdf47ccd764e95e570ec0d81e101b7b63f67ee6ae746087ffd99c887e46fbf0fbe5024a7a08ae80a991a69cfb81d8527f448 openrc.patch"
diff --git a/testing/libreswan/openrc.patch b/testing/libreswan/openrc.patch
new file mode 100644
index 000000000..8a32c53ce
--- /dev/null
+++ b/testing/libreswan/openrc.patch
@@ -0,0 +1,26 @@
+From cf3af91d861caa849f6f72e3af2d7c7ee56e6b27 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 19 Nov 2013 15:25:41 +0000
+Subject: [PATCH] initsystems: fix typo in openrc script
+
+---
+ initsystems/openrc/ipsec.init.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/initsystems/openrc/ipsec.init.in b/initsystems/openrc/ipsec.init.in
+index 027b253..f3ab2f9 100755
+--- a/initsystems/openrc/ipsec.init.in
++++ b/initsystems/openrc/ipsec.init.in
+@@ -50,7 +50,7 @@ stop() {
+ start-stop-daemon --stop --pidfile "${PLUTO_PIDFILE}"
+ RETVAL=$?
+ ${IPSEC_BINARY} _stackmanager stop
+- eend RETVAL
++ eend $RETVAL
+ }
+
+ reload() {
+--
+1.8.4.3
+
+