summaryrefslogtreecommitdiffstats
path: root/testing/lightdm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-30 09:19:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-30 09:19:52 +0000
commit152e22d13fee521a7ad51e50855b2cafd06c8245 (patch)
tree1b3bcb0d33d4ad348e6ccea8f02b832c719851ec /testing/lightdm
parenta698043a5c26a506b78e6d3c11ffc8114954f653 (diff)
downloadaports-152e22d13fee521a7ad51e50855b2cafd06c8245.tar.bz2
aports-152e22d13fee521a7ad51e50855b2cafd06c8245.tar.xz
testing/lightdm: upgrade to 1.4.0
Diffstat (limited to 'testing/lightdm')
-rw-r--r--testing/lightdm/APKBUILD17
-rw-r--r--testing/lightdm/disallow-guest.patch14
-rw-r--r--testing/lightdm/lightdm-x11-configure.patch122
-rw-r--r--testing/lightdm/uclibc-language.patch34
4 files changed, 49 insertions, 138 deletions
diff --git a/testing/lightdm/APKBUILD b/testing/lightdm/APKBUILD
index f4ab08e0b..694f83a73 100644
--- a/testing/lightdm/APKBUILD
+++ b/testing/lightdm/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lightdm
-pkgver=1.1.0
-pkgrel=4
+pkgver=1.4.0
+pkgrel=0
pkgdesc="A cross-desktop display manager"
url="http://www.freedesktop.org/wiki/Software/LightDM"
arch="all"
@@ -10,12 +10,12 @@ license="GPL-3"
depends="dbus"
depends_dev=""
makedepends="linux-pam-dev gtk+3.0-dev libxklavier-dev libxext-dev
- autoconf automake libtool gobject-introspection-dev"
+ autoconf automake libtool gobject-introspection-dev itstool"
install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="http://people.ubuntu.com/~robert-ancell/lightdm/releases/lightdm-$pkgver.tar.gz
- lightdm-x11-configure.patch
+source="https://launchpad.net/lightdm/${pkgver%.*}/$pkgver/+download/lightdm-$pkgver.tar.gz
disallow-guest.patch
+ uclibc-language.patch
lightdm.initd"
_builddir="$srcdir"/lightdm-$pkgver
@@ -35,7 +35,6 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--enable-liblightdm-gobject \
- --enable-gtk-greeter \
--with-greeter-session=lightdm-gtk-greeter \
|| return 1
@@ -54,7 +53,7 @@ package() {
install -Dm755 "$srcdir"/lightdm.initd "$pkgdir"/etc/init.d/lightdm
}
-md5sums="c2347200b1af29c677ef5ad83855217b lightdm-1.1.0.tar.gz
-10b9a72013ed824a12a8720ff28810a1 lightdm-x11-configure.patch
-04956acfe2817e8d953f012ad6c72998 disallow-guest.patch
+md5sums="622d9087ec773dd0626a250a5868f88c lightdm-1.4.0.tar.gz
+72a44670872ce38ec0229e6595f0c629 disallow-guest.patch
+66782244aa11446e586d80e52ca74775 uclibc-language.patch
9eb01e4202919424face9bafbda4936c lightdm.initd"
diff --git a/testing/lightdm/disallow-guest.patch b/testing/lightdm/disallow-guest.patch
index b9ed6b3c2..e44335962 100644
--- a/testing/lightdm/disallow-guest.patch
+++ b/testing/lightdm/disallow-guest.patch
@@ -1,8 +1,8 @@
--- ./data/lightdm.conf.orig
+++ ./data/lightdm.conf
-@@ -63,7 +63,7 @@
- #greeter-session=example-gtk-gnome
- #greeter-hide-users=false
+@@ -75,7 +75,7 @@
+ #greeter-show-manual-login=false
+ #greeter-show-remote-login=true
#user-session=default
-#allow-guest=true
+#allow-guest=false
@@ -11,12 +11,12 @@
#display-setup-script=
--- ./src/lightdm.c.orig
+++ ./src/lightdm.c
-@@ -957,7 +957,7 @@
+@@ -1004,7 +1004,7 @@
if (!config_has_key (config_get_instance (), "SeatDefaults", "start-session"))
config_set_boolean (config_get_instance (), "SeatDefaults", "start-session", TRUE);
if (!config_has_key (config_get_instance (), "SeatDefaults", "allow-guest"))
- config_set_boolean (config_get_instance (), "SeatDefaults", "allow-guest", TRUE);
+ config_set_boolean (config_get_instance (), "SeatDefaults", "allow-guest", FALSE);
- if (!config_has_key (config_get_instance (), "SeatDefaults", "greeter-session"))
- config_set_string (config_get_instance (), "SeatDefaults", "greeter-session", GREETER_SESSION);
- if (!config_has_key (config_get_instance (), "SeatDefaults", "user-session"))
+ if (!config_has_key (config_get_instance (), "SeatDefaults", "greeter-allow-guest"))
+ config_set_boolean (config_get_instance (), "SeatDefaults", "greeter-allow-guest", TRUE);
+ if (!config_has_key (config_get_instance (), "SeatDefaults", "greeter-show-remote-login"))
diff --git a/testing/lightdm/lightdm-x11-configure.patch b/testing/lightdm/lightdm-x11-configure.patch
deleted file mode 100644
index e1819eaa4..000000000
--- a/testing/lightdm/lightdm-x11-configure.patch
+++ /dev/null
@@ -1,122 +0,0 @@
---- ./configure.orig
-+++ ./configure
-@@ -17154,10 +17154,12 @@
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- \""; } >&5
- ($PKG_CONFIG --exists --print-errors "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-@@ -17165,6 +17167,7 @@
- pkg_cv_LIGHTDM_GTK_GREETER_CFLAGS=`$PKG_CONFIG --cflags "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
-@@ -17180,10 +17183,12 @@
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- \""; } >&5
- ($PKG_CONFIG --exists --print-errors "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-@@ -17191,6 +17196,7 @@
- pkg_cv_LIGHTDM_GTK_GREETER_LIBS=`$PKG_CONFIG --libs "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
-@@ -17215,11 +17221,13 @@
- LIGHTDM_GTK_GREETER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>&1`
- else
- LIGHTDM_GTK_GREETER_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
-@@ -17250,10 +17258,12 @@
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- \""; } >&5
- ($PKG_CONFIG --exists --print-errors "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-@@ -17261,6 +17271,7 @@
- pkg_cv_LIGHTDM_GTK_GREETER_CFLAGS=`$PKG_CONFIG --cflags "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
-@@ -17276,10 +17287,12 @@
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- \""; } >&5
- ($PKG_CONFIG --exists --print-errors "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- ") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-@@ -17287,6 +17300,7 @@
- pkg_cv_LIGHTDM_GTK_GREETER_LIBS=`$PKG_CONFIG --libs "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>/dev/null`
- test "x$?" != "x0" && pkg_failed=yes
- else
-@@ -17311,11 +17325,13 @@
- LIGHTDM_GTK_GREETER_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>&1`
- else
- LIGHTDM_GTK_GREETER_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- " 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
-@@ -17324,6 +17340,7 @@
- as_fn_error $? "Package requirements (
- gtk+-3.0
- gmodule-export-2.0
-+ x11
- ) were not met:
-
- $LIGHTDM_GTK_GREETER_PKG_ERRORS
diff --git a/testing/lightdm/uclibc-language.patch b/testing/lightdm/uclibc-language.patch
new file mode 100644
index 000000000..b1bbe7970
--- /dev/null
+++ b/testing/lightdm/uclibc-language.patch
@@ -0,0 +1,34 @@
+--- ./liblightdm-gobject/language.c.orig
++++ ./liblightdm-gobject/language.c
+@@ -225,6 +225,7 @@
+
+ if (!priv->name)
+ {
++#ifndef __UCLIBC__
+ gchar *locale = get_locale_name (priv->code);
+ if (locale)
+ {
+@@ -238,6 +239,7 @@
+
+ setlocale (LC_ALL, current);
+ }
++#endif
+ if (!priv->name)
+ {
+ gchar **tokens = g_strsplit_set (priv->code, "_.@", 2);
+@@ -268,6 +270,7 @@
+
+ if (!priv->territory && strchr (priv->code, '_'))
+ {
++#ifndef __UCLIBC__
+ gchar *locale = get_locale_name (priv->code);
+ if (locale)
+ {
+@@ -281,6 +284,7 @@
+
+ setlocale (LC_ALL, current);
+ }
++#endif
+ if (!priv->territory)
+ {
+ gchar **tokens = g_strsplit_set (priv->code, "_.@", 3);