summaryrefslogtreecommitdiffstats
path: root/testing/lightdm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-13 11:57:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-13 11:57:32 +0000
commit6fa84d9d81f5b745d132a6d2f90baae75c5e0a58 (patch)
treec9a29850fbc180049f9aacdd298431ddfad79218 /testing/lightdm
parent063a5ab86401606a8ade8515e78ccc27dd6ea3e1 (diff)
downloadaports-6fa84d9d81f5b745d132a6d2f90baae75c5e0a58.tar.bz2
aports-6fa84d9d81f5b745d132a6d2f90baae75c5e0a58.tar.xz
testing/lightdm: new aport
A cross-desktop display manager http://www.freedesktop.org/wiki/Software/LightDM
Diffstat (limited to 'testing/lightdm')
-rw-r--r--testing/lightdm/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/lightdm/APKBUILD b/testing/lightdm/APKBUILD
new file mode 100644
index 000000000..d3ee29104
--- /dev/null
+++ b/testing/lightdm/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lightdm
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="A cross-desktop display manager"
+url="http://www.freedesktop.org/wiki/Software/LightDM"
+arch="all"
+license="GPL-3"
+depends=""
+depends_dev=""
+makedepends="linux-pam-dev gtk+3.0-dev libxklavier-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://people.ubuntu.com/~robert-ancell/lightdm/releases/lightdm-$pkgver.tar.gz"
+
+_builddir="$srcdir"/lightdm-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-liblightdm-gobject \
+ --enable-gtk-greeter \
+ || return 1
+
+ # workaround build bug
+ touch tests/src/lightdm-session
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+ mv "$pkgdir"/usr/lib/locale "$pkgdir"/usr/share/
+}
+
+md5sums="c2347200b1af29c677ef5ad83855217b lightdm-1.1.0.tar.gz"