summaryrefslogtreecommitdiffstats
path: root/testing/lshell
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-09-21 15:42:53 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-09-21 22:28:11 +0000
commit18fa92363dd3db0959f858c194ec94b51a37c165 (patch)
tree53c14ca258920cfdd09dbe9b9d7491e800b36820 /testing/lshell
parent107f426b734af190fdd7cf7a4306f338543d3602 (diff)
downloadaports-18fa92363dd3db0959f858c194ec94b51a37c165.tar.bz2
aports-18fa92363dd3db0959f858c194ec94b51a37c165.tar.xz
testing/lshell: new aport
Diffstat (limited to 'testing/lshell')
-rw-r--r--testing/lshell/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/lshell/APKBUILD b/testing/lshell/APKBUILD
new file mode 100644
index 000000000..d52c8d592
--- /dev/null
+++ b/testing/lshell/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=lshell
+pkgver=0.9.15.1
+pkgrel=0
+pkgdesc="Python-based limited Shell"
+url="http://ghantoos.org/limited-shell-lshell"
+arch="noarch"
+license="GPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="0a6aca8d5f03b55289c1d3557c1bdc6d lshell-0.9.15.1.tar.gz"